FS#20724 - [gvfs] can no longer connect via sftp

Attached to Project: Arch Linux
Opened by Dave Morgan (loafer) - Thursday, 02 September 2010, 20:36 GMT
Last edited by Jan de Groot (JGC) - Monday, 04 October 2010, 12:06 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture i686
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 29
Private No



Following today's openssh update nautilus can no longer connect via sftp. I am using a fully up-to-date system, testing not enabled with Gnome.

Error as follows:

Could not display "sftp://user@server/".

Error: Error reading from unix: Input/output error
Please select another viewer and try again.

Additional info:
* package version(s)
* config and/or log files etc.

Steps to reproduce:

Update to openssh 5.6p1-1
This task depends upon

Closed by  Jan de Groot (JGC)
Monday, 04 October 2010, 12:06 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in 1.6.4.
Comment by Matt Runion (mrunion) - Thursday, 02 September 2010, 23:47 GMT
Confirmed -- upgrading from openssh 5.5 to openssh 5.6 breaks nautilus' sftp connections. Downgrading back to openssh 5.5 fixes it.
Comment by c b (cb474) - Sunday, 05 September 2010, 19:31 GMT
Yes, I'm having the same experience as well. I found in a French Ubuntu forum someone with the same problem, who reports that openssh still works fine from the command line and that newly created user accounts do not have the problem, see: http://forum.ubuntu-fr.org/viewtopic.php?id=412251.

Should this be reported upstream? Is is a openssh bug or a nautilus bug?
Comment by Green (The_Green_Arrow) - Monday, 06 September 2010, 09:27 GMT
Same thing here. Downgrading Openssh fixes this issue...
The issue described on ubuntu-fr.org is not exactly the same : there is no input/output error and I think the openssh version in Ubuntu is 5.3...
Comment by stopspam (stopspam) - Monday, 06 September 2010, 13:52 GMT
Same problem. Another workaround is to use sshfs which works with openssl 5.6.
Comment by c b (cb474) - Monday, 06 September 2010, 20:42 GMT
The error message on ubuntu-fr.org is:

Impossible d'afficher « sftp://85.xx.xx.xx:xxxxx/ ».
Erreur : Le programme ssh s'est terminé de manière inattendue
Sélectionnez un autre visionneur et essayez à nouveau.

I think that's just the French way of reporting the same error. It says, "Error: The program ssh quit in an unexpected manner." I would not be suprised if the French do not use the exact same wording as is used in English. If you read the whole thread it really sounds like the same problem. But perhaps others know better than me. I suppose I could post something there and ask what version of openssh that person is using.
Comment by stopspam (stopspam) - Monday, 06 September 2010, 21:14 GMT
yes it's the same error.
Comment by Jon Jenkins (yevgeni) - Tuesday, 07 September 2010, 19:32 GMT
Confirmed as well. I opened a duplicate bug because this one didn't come up when I searched for it.

Is this just up to ssh maintainers to fix?
Comment by Cristian Liendo (cristian_dkb) - Thursday, 09 September 2010, 12:54 GMT
Same problem with x86_64
Comment by Jaap-Willem Dooge (JapyDooge) - Friday, 10 September 2010, 08:38 GMT
Same problem over here.

[root@wvun002 ~]# uname -a
Linux wvun002 2.6.35-ARCH #1 SMP PREEMPT Fri Aug 27 17:14:28 CEST 2010 x86_64 Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.40GHz GenuineIntel GNU/Linux

[root@wvun002 ~]# nautilus --version
GNOME nautilus 2.30.1

[root@wvun002 ~]# ssh -V
OpenSSH_5.6p1, OpenSSL 1.0.0a 1 Jun 2010
Comment by Sean Burau (sixblades) - Friday, 10 September 2010, 18:11 GMT
I'm experiencing this problem as well. Downgrading OpenSSH to 5.5p1 fixed the problem.

uname -a
Linux trinaryShift 2.6.35-ARCH #1 SMP PREEMPT Fri Aug 27 17:14:28 CEST 2010 x86_64 Intel(R) Core(TM)2 Duo CPU T9300 @ 2.50GHz GenuineIntel GNU/Linux

nautilus --version
GNOME nautilus 2.30.1

ssh -V
OpenSSH_5.6p1, OpenSSL 1.0.0a 1 Jun 2010
Comment by Ionut Biru (wonder) - Friday, 10 September 2010, 18:13 GMT
any of you tried at least to debug the problem by checking upstream bugtrackers and report it?

is kinda useless to add "i have this problem too" comments
Comment by c b (cb474) - Friday, 10 September 2010, 21:00 GMT
I looked for bugs upstream with nautilus and openssh, but didn't find any. I was going to report it as a bug upstream, but was not sure which package it should be reported against (nautilus or openssh). You can see can see in the *second* comment on this bug, I asked where it should be reported and no one responded to my question.
Comment by Ionut Biru (wonder) - Friday, 10 September 2010, 21:03 GMT
if sftp works in terminal i guess is an nautilus problem. try there
Comment by Ulf Winkelvos (uwinkelvos) - Friday, 10 September 2010, 21:31 GMT
sftp and sshfs work fine, but its not a nautilus bug either. gvfs is the problem: see https://bugs.archlinux.org/task/20737

I am pretty much out of time to do anything these days, so i did not report this upstream yet.

edit: but the gentoo guys did: http://bugs.gentoo.org/show_bug.cgi?id=335316#c8
Comment by Etienne Lepercq (guepe) - Sunday, 19 September 2010, 20:55 GMT
Apparently solved upstream now, but no release yet. The good thing to know is that publickey authentication works, so if you can use it, it is a good workaround for now.
Comment by Ulf Winkelvos (uwinkelvos) - Sunday, 19 September 2010, 23:17 GMT
publickey did not work for me, but this patch does:
Comment by Hector Mtz-Seara Monne (hseara) - Friday, 24 September 2010, 11:38 GMT
Does anybody know when the working patch will be incorporated to the official repositories? This is a feature that I use very often so I will really appreciate a new patched package released. Thanks
Comment by Green (The_Green_Arrow) - Monday, 27 September 2010, 09:39 GMT
Hector >> it's quite easy to apply the patch :
1) make sure you have abs installed, pacman -S abs
2) as root, type : abs extra/gvfs
3) somewhere in your home directory type : cp -r /var/abs/extra/gvfs .
4) go to this directory and create a file containing the patch (from the link given by Ulf). Name this file fixnautilus.patch for example
5) edit PKGBUILD and before the line 19 (./configure --prefix=/usr --sysconfdir=/etc) add : patch -p1 < ../../fixnautilus.patch || return 1
6) Increase PKGBUILD pkgrel variable from 1 to 2
6) save the PKGBUILD and type : makepkg -si (this will upgrade 'gvfs' 'gvfs-smb' 'gvfs-afc' 'gvfs-gphoto2' and 'gvfs-obexftp' (5 packages then))
Comment by Otto Allmendinger (OttoA) - Monday, 27 September 2010, 18:39 GMT
Fixed upstream in gvfs version 1.6.4
Comment by Ionut Biru (wonder) - Monday, 27 September 2010, 18:44 GMT
i pushed gvfs 1.6.4 in gnome-unstable repo
Comment by Ulf Winkelvos (uwinkelvos) - Sunday, 03 October 2010, 00:15 GMT
gvfs 1.6.4-1 in testing works fine as expected... so this can be closed whenever it hits extra.