Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#19645 - [v86d] cannot reserve video memory: kernel 2.6.34

Attached to Project: Arch Linux
Opened by Pascal (pascalp) - Sunday, 30 May 2010, 10:31 GMT
Last edited by Allan McRae (Allan) - Friday, 15 April 2011, 04:58 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:

v86d can't start with the kernel in testing (2.6.34). It is fine with 2.6.33 kernel.

errors.log:
May 30 11:42:24 einstein kernel: pci_root PNP0A08:00: address space
collision: host bridge window [mem 0x000c0000-0x000dffff] conflicts
with reserved [mem 0x000d0000-0x000fffff]
May 30 11:42:24 einstein kernel: uvesafb: cannot reserve video memory
at 0x3f800000

lspci:
00:02.0 VGA compatible controller: Intel Corporation System Controller
Hub (SCH Poulsbo) Graphics Controller (rev 07)

Additional info:
testing/kernel26 2.6.34-1
extra/v86d 0.1.9-10

Steps to reproduce:
upgrade from 2.6.33 to 2.6.34 with v86d
This task depends upon

Closed by  Allan McRae (Allan)
Friday, 15 April 2011, 04:58 GMT
Reason for closing:  No response
Comment by Ike Devolder (BlackEagle) - Sunday, 30 May 2010, 10:42 GMT
my guess would be that intel cards support KMS, so you won't need v86d anymore

maybe you could try to boot with i915.modeset=0
Comment by Jan de Groot (JGC) - Sunday, 30 May 2010, 11:14 GMT
Poulsbo is not intel, it's a powerVR chip with very bad driver support in linux.
Comment by Ike Devolder (BlackEagle) - Sunday, 30 May 2010, 11:24 GMT
great, never heard of; this is netbook stuff or so ?

for asus netbook and sony vaio following is suggested

kernel line add following in menu.lst:
mem=2000mb acpi_osi=Linux
Comment by Pascal (pascalp) - Sunday, 30 May 2010, 12:34 GMT
Poulsbo is the worst chipset ever. It's not critical in my case, I do not have Xorg, I am just using uvesafb to increase a bit the screen resolution.

It's not in a netbook but in a tiny pc: http://www.fit-pc.com/web/

Thanks for the grub parameter, I was looking for it on the web without any luck.
Comment by Lucas Cano (canolucas) - Friday, 18 June 2010, 23:50 GMT
i can confirm this with my acer aspire one 751h netbook. v86d doesn't load anymore with the kernel in testing.
Comment by Lucas Cano (canolucas) - Friday, 18 June 2010, 23:56 GMT
my errors.log is quite the same as the onein the bug description:

Jun 18 20:22:01 tux kernel: pci_root PNP0A08:00: address space collision: host bridge window [mem 0x000c0000-0x000dffff] conflicts with reserved [mem 0x000d0000-0x000fffff]
Jun 18 20:22:02 tux kernel: uvesafb: cannot reserve video memory at 0x7f800000
Comment by Lucas Cano (canolucas) - Saturday, 19 June 2010, 01:30 GMT
updated mkinitcpio to 0.6.6-1 and kernel26 to 2.6.34-2 and still get the error.
Comment by Lucas Cano (canolucas) - Sunday, 20 June 2010, 10:20 GMT
still getting the error. v86d fails to load on this new kernel
Comment by Pascal (pascalp) - Sunday, 20 June 2010, 11:16 GMT
I also still have an error

Jun 20 12:38:32 einstein kernel: pci_root PNP0A08:00: address space collision: host bridge window [mem 0x000c0000-0x000dffff] conflicts with reserved [mem 0x000d0000-0x000fffff]
Jun 20 12:38:32 einstein kernel: uvesafb: cannot reserve video memory at 0x3f800000

cat /var/log/dmesg.log|grep 0x3f800000:

pci_root PNP0A08:00: host bridge window [mem 0x3f800000-0xfebfffff]
pci 0000:00:1c.1: BAR 15: assigned [mem 0x3f800000-0x3f9fffff pref]
pci 0000:00:1c.1: bridge window [mem 0x3f800000-0x3f9fffff pref]
pci_bus 0000:00: resource 9 [mem 0x3f800000-0xfebfffff]
pci_bus 0000:03: resource 2 [mem 0x3f800000-0x3f9fffff pref]
uvesafb: cannot reserve video memory at 0x3f800000

I tried to reserve the memory without any luck with the method above and with the links below:
http://bbs.archlinux.org/viewtopic.php?id=78719&p=9
http://bbs.archlinux.org/viewtopic.php?pid=770309

Comment by MArtin (redada) - Monday, 21 June 2010, 13:00 GMT
Exactly the same here on my fit-PC2.
Comment by Lucas Cano (canolucas) - Monday, 05 July 2010, 23:14 GMT
is this bug present in the vanilla kernel ? or is it caused by an archlinux patch ?
Comment by Thomas Bächler (brain0) - Monday, 05 July 2010, 23:50 GMT
The only modification Arch does to the kernel are a few added exported symbols so we can run the 'aufs' module. This should not affect anything related to uvesafb.

I am pretty clueless about the problem itself though.
Comment by Lucas Cano (canolucas) - Tuesday, 06 July 2010, 00:47 GMT
I am kinda clueless too, but after some research i found this: http://en.gentoo-wiki.com/wiki/Framebuffer
There, it says that video card drivers which support KMS do not need specific framebuffer drivers. In fact, building a kernel with them may cause all-black console screen, other graphical artifacts, or complete failure at loadtime, so they should be disabled.

So I supose that KMS cannot coexist with vesafb, uvesafb, etc.. And KMS is becoming default/mandatory !

Hope this helps.
Comment by Lucas Cano (canolucas) - Tuesday, 06 July 2010, 01:04 GMT Comment by Mulenmar (mulenmar) - Sunday, 11 July 2010, 23:30 GMT
I also have an Acer Aspire One, 2.6.34-ARCH kernel, and this problem. Adding pci=nocrs as mentioned in dmesg.log removed the conflict.
Comment by Lucas Cano (canolucas) - Monday, 12 July 2010, 00:58 GMT
@mulenmar: thanks for the tip. it works here too.

i suppose this a workaround, and not a fix. am i right?
Comment by Mulenmar (mulenmar) - Monday, 12 July 2010, 04:05 GMT
Right, but perhaps it narrows things down to changes in the PCI or ACPI system between 2.6.33 and 2.6.34? I'm not much of a programmer in such things, just giving my 0.02 credits.
Comment by Lucas Cano (canolucas) - Wednesday, 28 July 2010, 23:15 GMT
@mulenmar: yep. i can bet this is because the kernel is not noticing that the memory reserved for mapping pci devices is already in use, so it tries unlock it/overwrite it, when this is not possible coz its in use by the framebuffer loaded first in the initrd. seems that all we can do is cross fingers and hope it gets fixed for 2.6.35.
i haven't tested current git (2.6.35-rc6), but chances are they already handled the pci mapping issue.
Comment by Greg (dolby) - Friday, 04 March 2011, 03:09 GMT
Did you report this to the kernel bug tracker?
Comment by Tobias Powalowski (tpowa) - Saturday, 26 March 2011, 16:19 GMT
Any update on this?

Loading...