Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#19082 - [eclipse] make xulrunner optional

Attached to Project: Arch Linux
Opened by Alexey A Illarionov (ogronom) - Tuesday, 13 April 2010, 20:28 GMT
Last edited by Ionut Biru (wonder) - Friday, 14 October 2011, 18:44 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Paul Mattal (paul)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No


Xulrunner should be optional dependence of eclipse, since it's possible to run without xulrunner. Documentation can be viewed by any other external browser

Additional info:
* package version(s)
* config and/or log files etc.

Steps to reproduce:
This task depends upon

Closed by  Ionut Biru (wonder)
Friday, 14 October 2011, 18:44 GMT
Reason for closing:  Fixed
Additional comments about closing:  eclipse 3.7.1
libwebkit replaced xulrunner as dependency
Comment by Henry Lee (bsdson) - Wednesday, 23 March 2011, 07:23 GMT
I think it's a good idea to make it optional.

since the API in XULRunner keeps changing.
eclipse might get crashed after XULRunner upgrade.
(for example from 1.9.x to 2.0)

at least we should restrict XULRunner's version.
Comment by Benjamin Robin (benjarobin) - Tuesday, 29 March 2011, 11:12 GMT
If we made xulrunner optional, could you add: libwebkit has an optional dependency
Comment by Paul Mattal (paul) - Sunday, 26 June 2011, 11:32 GMT
On initial consideration, this sounds right to me.

I'll have a second look, and then resolve this in the next pkgrel.
Comment by Ionut Biru (wonder) - Wednesday, 29 June 2011, 13:27 GMT
imo libwebkit should be a dependency because it tries to load libwebkit first
Comment by Ionut Biru (wonder) - Wednesday, 29 June 2011, 13:28 GMT
this shows that it tries to load libwebkit first and then does a check for xul and bails out
   log (229.2 KiB)
Comment by Kien Truong (dikei) - Tuesday, 16 August 2011, 16:38 GMT
Eclipse stops supports for xulrunner>=2.0, so it'll not even detect xulrunner 5.0. I think xulrunner should be dropped as a dependency.