Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#18923 - [compiz] Doesn't support GNOME cursor settings

Attached to Project: Community Packages
Opened by Alessio Biancalana (dottorblaster) - Friday, 02 April 2010, 11:34 GMT
Last edited by Jelle van der Waa (jelly) - Saturday, 13 August 2011, 20:14 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ronald van Haren (pressh)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 25
Private No

Details

Description: If you try to change your WM from Metacity to Compiz, or Openbox, or another thing but GNOME's Metacity, you will get the X11 cursor as the black Xorg default (and this is ugly!).
Falling back to Metacity solves the problem, but it's not a solution.


Additional info:
* package version(s): all GNOME 2.30 up-to-date @ 2 Apr 2010 - 13:28


Steps to reproduce: Change the WM from Metacity to Compiz (tested), Openbox (tested).
This task depends upon

Closed by  Jelle van der Waa (jelly)
Saturday, 13 August 2011, 20:14 GMT
Reason for closing:  No response
Additional comments about closing:  no response we don't have gnome2.3 anymore
Comment by youplease (youplease) - Saturday, 03 April 2010, 09:01 GMT
Also the cursor changes to the default when I run smplayer (or vlc) and mouse over its window.
EDIT: seems like it is for any qt application
Comment by Michael Kogan (Photon) - Wednesday, 07 April 2010, 06:38 GMT
I've observed that some cursor modes aren't reset, like: text cursor, hand cursor (when hovering urls), all direction cursors (when resizing a window). The busy cursor may or may not be reset depending on the application it's above (not reset above Nautilus).
Comment by Alessio Biancalana (dottorblaster) - Wednesday, 07 April 2010, 15:37 GMT
Michael and Eugene, you are right. I didn't found any patch trying to solve this issue.
Comment by Robert J. (perpetrator) - Wednesday, 07 April 2010, 19:07 GMT
I can affirm Michael's observations, but they only apply to gnome/gtk applications. In qt applications, all cursors are reset, also the text, hand, busy and direction cursors.

Also, Firefox shows strange behaviour:
Navigating through the menus sometimes changes the cursor to the default. Just klick on 'File' and move the cursor to 'Edit', 'View' and so on.
In my case now, it is reset to the default on 'File' and 'History', but this changes from time to time, I also saw it changing on 'Edit'.

Comment by Alessio Biancalana (dottorblaster) - Sunday, 11 April 2010, 17:36 GMT
I confirm the strange behaviour in Firefox. Any ideas?
Comment by Robert J. (perpetrator) - Sunday, 11 April 2010, 20:13 GMT
Using the following workaround (cf. http://wiki.archlinux.org/index.php/X11_Cursors#Configuring_Cursor_Themes) it works now for me:

- create a directory /usr/share/icons/default/ (did not exist in my case)
- create /usr/share/icons/default/index.theme and add the following lines:

[icon theme]
Inherits=foobar



Comment by Alessio Biancalana (dottorblaster) - Monday, 26 April 2010, 18:44 GMT
It doesn't solve the problem :/
Comment by Simon Perry (pezz) - Tuesday, 01 June 2010, 14:26 GMT
I believe I have successfully worked around this.

It appears the DMZ-White theme is pretty complete as far as a cursor set goes. If you inherit that, you will find that drag and drop cursors etc. appear in Firefox (and anywhere else).

Any cursor that isn't included in your own cursor set will use the DMZ-White version. However you still have to do the /usr/share/icons/default/ hack in order to have the theme you want not get overridden by an ugly X cursor.

You also have to inherit your own cursor theme in order for it to not get overridden by a DMZ-White cursor e.g.:

[Icon Theme]
Inherits=Aero,DMZ-White

I have attached a file of terminal output that (I hope) shows how I've gotten it to work.

Cheers!
Comment by Mihai Coman (z0id) - Thursday, 07 October 2010, 16:46 GMT
Bug still present with GNOME 2.32 and Compiz 0.8.6-2. Apparently, the Ubuntu guys have a fix https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/459647
Comment by Jan de Groot (JGC) - Thursday, 07 October 2010, 17:23 GMT
This is not a bug in GNOME, but a shortcoming in compiz. When GNOME sets the cursor theme, it sets this in a GConf key and makes metacity (or probably mutter in upcoming 3.0) do the change. When you replace the window manager, the cursor theme is no longer applied. What Ubuntu does is patching Compiz to support GNOME cursor themes by reading the settings from GConf and applying it trough libXcursor.

Technically, this is not a bug in GNOME, but I don't get it why they designed the cursor choice system to use Metacity instead of gnome-settings-daemon. Except for the window borders, all other appearance settings are set trough gnome-settings-daemon, why would someone want to set cursor themes trough the window manager then?
Comment by Alessio Biancalana (dottorblaster) - Thursday, 07 October 2010, 17:33 GMT
Exactly, can I say this is a projectual error? :P
Comment by Jan de Groot (JGC) - Thursday, 07 October 2010, 17:44 GMT
I looked up the code (or ehm, bugreports a few years back when GTK 2.8 was released) that actually sets the cursor... gnome-settings-daemon DOES set the cursor, but only GTK applications respond to that. To update the root cursor, the window manager has to do all the work, and so does metacity.
Comment by Jan de Groot (JGC) - Thursday, 07 October 2010, 17:49 GMT
  • Field changed: Attached to Project (Arch Linux → Community Packages)
  • Field changed: Summary ([gnome] doesn't display custom cursor → [compiz] Doesn't support GNOME cursor settings)
  • Task reassigned to Ronald van Haren (pressh)
Assinging to Ronald and moving to community. This is not a GNOME bug, but a shortcoming in compiz and other window managers.
Comment by Alessio Biancalana (dottorblaster) - Thursday, 07 October 2010, 17:51 GMT
I agree. But we want this to be fixed! :D
Comment by Ronald van Haren (pressh) - Thursday, 07 October 2010, 18:15 GMT
note to myself so I don't have to search again for the patch: http://zenwalk.pinguix.com/user-accounts/bip/EXTRA/xap/compiz/013-add-cursor-theme-support.patch

I'll give the patch a try next week and see if no side effects come up. If everything is fine (also in kde) I'll apply it, if not...bad luck.
Comment by Alessio Biancalana (dottorblaster) - Thursday, 07 October 2010, 18:25 GMT
appreciation. What package needs patching? I can try out now :P
Comment by Mihai Coman (z0id) - Wednesday, 20 October 2010, 10:45 GMT
I tried applying the patch, but I get the following errors, despite having the appropriate headers.

display.o: In function `compDisplaySetCursorTheme':
display.c:(.text+0x613): undefined reference to `XcursorSetTheme'
display.c:(.text+0x622): undefined reference to `XcursorSetDefaultSize'
collect2: ld returned 1 exit status

I have also attached the modified PKGBUILD.

Any ideas?
   PKGBUILD (3.8 KiB)
Comment by Jelle van der Waa (jelly) - Friday, 17 June 2011, 21:19 GMT
any update?

Loading...