Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#18836 - [netcfg] wpa_actiond doesn't function properly on resume

Attached to Project: Arch Linux
Opened by Ng Oon-Ee (ngoonee) - Friday, 26 March 2010, 01:05 GMT
Last edited by Rémy Oudompheng (remyoudompheng) - Saturday, 30 July 2011, 18:06 GMT
Task Type Bug Report
Category Arch Projects
Status Closed
Assigned To Thomas Bächler (brain0)
Rémy Oudompheng (remyoudompheng)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No


After a suspend/resume, wpa_actiond does not seem to do anything (connect to a network) until /etc/rc.d/net-auto-wireless restart is run. I am using pm-utils.

If the wireless network was connected at suspend time, it will reconnect due to /usr/lib/pm-utils/sleep.d/11netcfg being called, which basically resumes the connection. If no wireless network was connected at suspend time, no further action is taken by wpa_actiond.

Additional info:
* package version(s)
netcfg 2.6.4-1
* config and/or log files etc.
Not sure what log files wpa_actiond generates, /etc/rc.d/net-auto-wireless seems to redirect output to /dev/null

Steps to reproduce:
1. Suspend computer when wireless network not in range (for example, in the office when I use my LAN).
2. Resume computer when a wireless network (which is setup in /etc/network.d) is in range (in my example, at home)
3. Wait. Connection is not established even after an hour. Immediately established on /etc/rc.d/net-auto-wireless restart.

I guess I could make /etc/pm/sleep.d/11netcfg issue a restart to /etc/rc.d/net-auto-wireless on resume. It does seem that wpa_actiond doesn't 'function' pass a suspend/resume though.
This task depends upon

Closed by  Rémy Oudompheng (remyoudompheng)
Saturday, 30 July 2011, 18:06 GMT
Reason for closing:  Duplicate
Additional comments about closing:  see  FS#20330 
Comment by Thomas Bächler (brain0) - Tuesday, 13 July 2010, 17:33 GMT
Stopping wireless on suspend and restarting it on resume is the only way I know to fix this. wpa_supplicant does not handle suspend/resume very well, it just fails to reconnect as far as I know. Need to investigate this (but my laptop has broken suspend, so this might be hard to investigate for me).