Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#18356 - [xf86-video-intel] X.org freezes

Attached to Project: Arch Linux
Opened by Westley Martinez (anikom15) - Tuesday, 16 February 2010, 03:18 GMT
Last edited by Paul Mattal (paul) - Friday, 13 August 2010, 11:54 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:
Ever since switched from intel-legacy to the intel driver for X.org, I have had random freeze ups. It seems to happen during "animations" and during 3D, but sometimes it's just random. Nothing moves, not even mouse. Only way to escape is SysRq. I'm using the intel brookdale-g i845g integrated chip. Intel driver works fine on laptop, which uses a more recent card.

Additional info:
xf86-video-intel 2.10.0-1
depends on:
* intel-dri>=7.6
* libdrm>=2.4.17-4
* libpciaccess>=0.10.9
* libxcb>=1.5
* libxvmc>=1.0.5
* xcb-util>=0.3.6
kernel26 2.6.32.8-1

Steps to reproduce:
If you have my same chipset and use the same driver, it'll probably happen to you.
This task depends upon

Closed by  Paul Mattal (paul)
Friday, 13 August 2010, 11:54 GMT
Reason for closing:  Fixed
Additional comments about closing:  See comments.
Comment by Jan de Groot (JGC) - Tuesday, 16 February 2010, 08:24 GMT
This might be a duplicate of this bug:
http://bugs.archlinux.org/task/16974

BTW: intel-dri 7.7 is the latest version.
Comment by Igor (cheer) - Wednesday, 17 February 2010, 10:03 GMT
I think it's not the duplicate because people faced problems with 2.6.31 as well but mine problem happens only on 2.6.32 (I suppose because of KMS). It doesn't freeze if I browse the web for example but after ~10 mins of video it freezes. I'm sorry but now I cannot attach any logs. I will try to do it later at home.
Comment by Daniele C. (legolas558) - Wednesday, 17 February 2010, 10:52 GMT
I just come from [1] and this bug seems fixed by using drm-intel-big-hammer.patch [2] with latest kernel
Can you give it a try?

[1] http://bugzilla.kernel.org/show_bug.cgi?id=15248
[2] http://bugzilla.kernel.org/attachment.cgi?id=25084
Comment by Daniele C. (legolas558) - Wednesday, 17 February 2010, 14:16 GMT
I confirm this bug, title should be changed to "Xorg freezes when playing videos".

Bug also happens with the kernel mix that I am using; also, I have XvMC enabled so it's not its fault.

I will play with it around since now I only this video playing bug and the fonts garbled bug; are you experiencing any other crash when not playing videos by the way?
Comment by Igor (cheer) - Wednesday, 17 February 2010, 14:20 GMT
Daniele:

I've been working with my photos in Digikam about 30 mins with no freeze but I'm not sure if this time is enough. I think that may be playing could also cause freezing (e.g. wesnoth or any other game that requires some work from the videocard).
Comment by Daniele C. (legolas558) - Wednesday, 17 February 2010, 14:53 GMT
@JGC: the video-playing crash and the crash I was experiencing before applying drm-intel-big-hammer.patch produce the same Xorg error about batchbuffer sync failure, so I assume they are similar and a patch similar to drm-intel-big-hammer.patch is needed to fix also the video-playing failures.

But unless the system is proven to be unstable also with 855nolid.patch + drm-intel-big-hammer.patch (e.g. crashes even when not playing videos) I think this bug should be separate, having a separate cause; otherwise they would be the same bug actually.

I will also investigate if crashes will happen when using openGL surfaces (perhaps the real cause is there)
Comment by Westley Martinez (anikom15) - Thursday, 18 February 2010, 01:36 GMT
It's not only during video, sometimes it's random.
Comment by Daniele C. (legolas558) - Friday, 19 February 2010, 12:11 GMT
@anikom15: yes I confirm, it happens when GPU "hickups". Did you try the drm-intel-big-hammer.patch?

Also, this bug can be either in kernel, libdrm or in xf86-video-intel; the error message is printed by libdrm.

@JGC: can you please fix the title and add related tasks?
Comment by ikster (ikster) - Wednesday, 24 February 2010, 12:24 GMT
hi folks, i was just about to downgrade my kernel on the wiki downgrade page and they told me to post bugs so im just trying out to help post my situation hopes its to any good use.

im using dell latitude d520, stock archlinux kernel.
the screen flickers and hang at random intervals, sometimes green, blue, red, black screen.
happens just suddenly when surfing the web, flash websites, facebook..
i tried xf86-video-intel/intel-newest/intel-git, all seems to be the same.
lastime i only reboot the machine to regain work but it seems only the screen is hang.
i tried ctrl+alt F1 to switch console, enter my user n pass n typed reboot and the laptop rebooted. (this is while the screen still blank-hang, i just typed slowly n properly). so i think its a bug in either the new kernel or intel xorg.
other than that im just a newbie. /var/log messages dont help at all or im not seeing anything of use.
previous o/s on this laptop was XP so i have no cache of old kernel package to downgrade to looks like gota look elsewhere.
im an archlinux user since 2008 on several machines. my desktop uses "vesa" driver and hang is frequent also but im too lazy to
check it out just wait til the next pacman -Syu and hope the bug is gone.

thanks.
Comment by Igor (cheer) - Wednesday, 24 February 2010, 22:47 GMT
my problem with the video playing seems to be gone with last update to kernel 2.6.32.9
Comment by ikster (ikster) - Thursday, 25 February 2010, 23:40 GMT
my problem as above is gone with yesterdays pacman -Syu.
kernel is 2.6.32.9

thanks all!
Comment by Daniele C. (legolas558) - Sunday, 28 February 2010, 20:54 GMT
I have just tried the Arch Linux stock kernel and nothing changed for me; I really think yours was a different bug
Comment by Paul Mattal (paul) - Monday, 15 March 2010, 03:37 GMT
I've lost track of who's still got a problem here and who has not. Westley, you still have the same problem, and sometimes its videos, sometimes random? Or is it resolved with recent kernels? Sounds like this or a similar issue was resolved for ikster and Igor with 2.6.23.9.

Daniele, are you experiencing this bug also?
Comment by Daniele C. (legolas558) - Monday, 15 March 2010, 12:58 GMT
@paul: I think we are facing here a "family" of Intel KMS bugs, so I can't really say if I have this bug or not.

I am affected by http://bugs.archlinux.org/task/18690 and http://bugs.archlinux.org/task/16974
The former prevents straightforward access to the latter.

Since  bug 16974  happens almost instantly, I'd say it is an ancestor of this bug, and that I am not affected by this one. Although it is highly likely that fixing  bug 16974  will also fix this one.
Comment by Westley Martinez (anikom15) - Monday, 15 March 2010, 22:42 GMT
I still have the problem, though it's much less frequent.
Comment by Daniele C. (legolas558) - Monday, 15 March 2010, 23:06 GMT
With recent xorg/dri updates I have crashes also with the utter-stable Xorg 1.6 which I was using!
Comment by ikster (ikster) - Tuesday, 16 March 2010, 01:22 GMT
i dont have the problem with recent upgrades. but yesterday after some high pc processing, the screen was kinda like struck a virus, moving up n down left to right (across at the top, block/brick sizes) like a screen puzzle trying to undo/complete itself. or was that purposely done by devs to make some screen effect? i dont think so anyways but im not sure how to reproduce it will post if it gets ugly.

but it seems sleep/waking up doesnt work as of now.
if i close my laptop lid, the pc sleeps
open lid, i only c a cursor. switch to tty1, restarted gdm
i still only hav a mouse.
so only way is to restart.

will try -Syu today c wusup...
Comment by ikster (ikster) - Tuesday, 16 March 2010, 16:01 GMT
well, my problem still persist and its because of compiz
closing laptop lid and opening it / sleep and wakeup problem
kdm or gdm goes to black screen even if restarted via tty1
with only mouse cursor but yet the system in the backend
is operating normal..

system up to date using:

dell latitude d520 / 1gb ram
xorg-server 1.7.5.902-1
xf86-video-intel-newest 2.10.0-2
archlinux stock kernel 2.6.32 with latest updates
kde / gnome but tested on gnome
with compiz and cairo-dock turned on...

should i make a new bug report?
here or on compiz-fusion website or freedesktop?

thanks
Comment by Daniele C. (legolas558) - Friday, 19 March 2010, 11:56 GMT
Some updates from upstream.

Daniel Vetter has almost fixed this bug with patch available here:

http://bugs.freedesktop.org/show_bug.cgi?id=27187

With that patch, KMS enabled and latest intel drivers I only get  bug 17705  (my hardware is i855GM rev02). This is clearly a progress since previously only the DRM "big hammer" patch could give some minutes of working Xorg. With D.Vetter's patch you can use Xorg for long time, but forget about playing videos or using graphics-intensive applications: it will crash as per  bug 17705 .

So I think that D.Vetter's patch fixes this bug; he is working on an improved patch which will lead to no GTT flush failures (you can find them in dmesg). Anyway, that's probably the way to go to fix this bug.
Comment by Mark Huetsch (garply) - Sunday, 21 March 2010, 09:58 GMT
I recently did a 'pacman -Syu' and I've also recently started having lockups reminiscent of the old intel video bugs I had a few months ago. The lockups are peculiar in that they are not always 'all-or-nothing'. Sometimes just my terminals will freeze, but I can still move the mouse, browse the web, listen to music, etc. Sometimes mplayer will freeze while playing music but my other capabilities will remain intact. After a few seconds to a few minutes, the freeze will generally resolve itself, or will get worse (i.e., the whole system will freeze). Even a wholly frozen system appears to resolve itself, given enough time, such as a half hour to a few hours, but I usually don't have a couple of hours to wait around and forcibly reboot instead. The freeze seem most likely to occur when playing video.

Does this sound like the same bug? I was using the xf86-video-intel and libdrm packages (up to date) when it started and since switched through the -newest versions and am now using the -git versions, in hope that some published patch would have resolved my issues. Unfortunately, no improvement thus far. I do not see any dmesg notifications about my problems, otherwise I would post my logs.
Comment by Daniele C. (legolas558) - Thursday, 25 March 2010, 17:18 GMT
@garply: to my best knowledge, this bug becomes suddenly apparent when you play a video (even flash videos but better if VLC is playing them)

@JGC: D.Vetter's patch should be used in our kernel because it makes it usable for i855GM users. the stock kernel is currently unusable for them. I also forecast that it will be soon merged upstream, but until that it would be nice to have such patch since I am actually using the latest intel/xorg *only* with this patch (impossible otherwise)

Thanks
Comment by David Bluecame (david.bluecame) - Saturday, 03 April 2010, 16:16 GMT
I had strange problems with intel i915 using kernel 2.6.32 and solved them upgrading the kernel to 2.6.33

By the way, I have experienced a lot of problems with 2.6.32 in several aspects, not just screen. With 2.6.33 some of them have been solved and others continue. What happened with 2.6.32??

Best regards! David.
Comment by Daniele C. (legolas558) - Thursday, 08 April 2010, 22:03 GMT
i855GM issues have just been radically fixed by Daniel Vetter, you can find the working patch and the complete kernel sources archive here:

http://www.iragan.com/linux/i855GM/

Patch has not yet been pushed upstream so it will take a lot of time before seeing it in regularly released kernel; all people interested can get the patch and/or the patched kernel which I have put above.

The bug should be closed as soon as the patch is accepted in linus' tree (it still has to get to drm-intel-next).
Comment by Westley Martinez (anikom15) - Thursday, 08 April 2010, 22:30 GMT
You say thats i855GM. Does that affect my i845GM card as well?
Comment by Daniele C. (legolas558) - Thursday, 08 April 2010, 23:14 GMT
It affects all hardware which uses the i915/intel driver. You might want to partecipate directly at the upstream freedesktop bug tracker for more.
Comment by Gerardo Exequiel Pozzi (djgera) - Friday, 13 August 2010, 03:49 GMT
  • Field changed: Status (Assigned → Waiting on Response)
is this still valid with latest kernel 2.6.35 and related packages?
Comment by Westley Martinez (anikom15) - Friday, 13 August 2010, 03:59 GMT
No, I don't think so. I haven't had any problems since. 3D works and I'm loving it.

Loading...