Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#18353 - [chromium] Missing dependency? (ttf-ms-fonts)

Attached to Project: Arch Linux
Opened by Marcel Korpel (Marcel-) - Monday, 15 February 2010, 22:10 GMT
Last edited by Dan Griffiths (Ghost1227) - Monday, 15 February 2010, 23:15 GMT
Task Type General Gripe
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture i686
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

Pacman installed Chromium, with its dependencies, on a rather 'clean' system (just installed X). First run showed the general dialog about Chromium not being my default browser, after clicking 'no' (I don't want it being the default one) it crashed, spitting out the following message on my terminal:

[7547:7547:26204900482:FATAL:app/gfx/font_skia.cc(152)] Check failed: tf. Could not find any font: Helvetica, sans
Trace/breakpoint trap

Second and third run gave very similar errors. Of course I suspected the lack of fonts as the cause of this problem, so I installed ttf-ms-fonts, providing basic fonts browsers generally use. After this the problem is gone.

So, shouldn't ttf-ms-fonts be a dependency?

Additional info:
* Chromium 4.0.249.78-3
This task depends upon

Closed by  Dan Griffiths (Ghost1227)
Monday, 15 February 2010, 23:15 GMT
Reason for closing:  Not a bug
Additional comments about closing:  See comments below
Comment by Gerardo Exequiel Pozzi (djgera) - Monday, 15 February 2010, 22:39 GMT
Nope. Another example can be using some program (for example based on gtk2 or kde/qt or other that uses ttf font), and using xorg-server outside chroot. You also need to install some ttf font, otherwise will fail or most common will see squares insteads of chars.

You can see that there is no package (maybe one or two) that depends on a ttf font.
Comment by Pierre Schmitz (Pierre) - Monday, 15 February 2010, 22:44 GMT
You wont need a specific font. E.g. I don't have any MS fonts installed and everything is working fine.
Comment by Marcel Korpel (Marcel-) - Monday, 15 February 2010, 22:50 GMT
Strange. I tried to uninstall the fonts and ran Chromium again, and everything is working fine now.

EDIT: nevermind, in the mean time I installed DejaVu, uninstalling that package resulted in the error message mentioned above.
But you're right, there are so many packages depending on *any* font being installed...

Loading...