Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#17771 - [kernel26] Very high power consumption on laptop with any kernel26-2.6.32.*

Attached to Project: Arch Linux
Opened by Wojo (Wojo) - Saturday, 09 January 2010, 17:48 GMT
Last edited by Ionut Biru (wonder) - Saturday, 03 July 2010, 20:20 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
After last upgrade package kernel26-2.6.31.6-1 in x86_64 system to any kernel26-2.6.32.*
consumption of power usage dramatic went up, which is killing battery in my laptop - from 3h on battery to not even 1h.
I was testing it using powertop tool. When usually there was about 300 to 1000 wakeups from idle per second,
now, with any 2.6.32.* kernel, there is about 30000 to 40000. Also jump from 16-18Watts then to even 35Watts!

System load seems to be pretty normal, not higer than ~0.10. Tempratures aren't higher than usuall.
I tried to dislabe KMS (which is default on in that kernel for intel cards), but with no results.

Any clue? Everything works fine when i downgraded it to kernel26-2.6.31.6-1.

Additional info:
* package version(s)
* config and/or log files etc.

Everything up-to-date (x86_64).

lspci:
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 4 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)
04:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
06:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5906M Fast Ethernet PCI Express (rev 02)
08:06.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
08:06.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
08:06.2 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
08:06.3 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 12)

What else would be needed?

Steps to reproduce:
This task depends upon

Closed by  Ionut Biru (wonder)
Saturday, 03 July 2010, 20:20 GMT
Reason for closing:  Won't fix
Additional comments about closing:  upstream rejected all bug reports
Comment by Wojo (Wojo) - Saturday, 09 January 2010, 19:04 GMT
"Tempratures aren't higher than usuall." - I meant that none of known temperatures (lm-sensors, hddtemp) are higher than usually.
Comment by Thomas Dziedzic (tomd123) - Saturday, 09 January 2010, 23:19 GMT
What steps did you take to add power savings to your laptop? What laptop tools do you have installed?
Comment by Thomas Dziedzic (tomd123) - Sunday, 10 January 2010, 05:48 GMT
Oh, I see that you have an intel 3945. I know that 2.6.32.3 (not sure if older .32.*) turn off powersavings mode for your wifi card. This is to temporarily fix a bug. I'm sure they will turn power savings on when it get's properly fixed. I don't know if this could be one of the main causes for your problem

Link to commit in 2.6.32.3 that turns of powersavings mode in intel 3945.
http://git.kernel.org/?p=linux/kernel/git/stable/linux-2.6.32.y.git;a=commitdiff;h=66c9e44e5740fe9024e3ed02fd66ad6e0e57408f
Comment by Wojo (Wojo) - Sunday, 10 January 2010, 09:28 GMT
tom, only tool i use on that laptop is cpufreq tool to manage CPU power usage. When i run on battery i set that to range 800-800MHz and powersave governor.
Also i set low brightness of the screen. In the system there are also packages pm-utils, laptopmode, but i don't use them, installed only because there were dependence.

But, important could be that, power consumption is high even when i don't use that wifi card. I tried to rmmod iwl3945, turn it off using laptop's switch, etc.
Still there was a lot of wakeups from idle per seconds. Any clue?

Thanks in advance.
Comment by Daniele C. (legolas558) - Friday, 15 January 2010, 12:18 GMT
what does powertop say?
Comment by Dimitrios Apostolou (jimis) - Friday, 15 January 2010, 18:24 GMT
I've seen the same behaviour. For a workaround until a proper fix is available boot with "clocksource=pit" kernel parameter. I've also sent a bug report to the LKML but they don't intend on incorporating a more generic fix( http://lkml.indiana.edu/hypermail/linux/kernel/1001.1/00502.html ). If you tell me you email address I'll CC you to that LKML thread so you can add your own experience (and debugging info ofcourse :-).
Comment by Dimitrios Apostolou (jimis) - Tuesday, 19 January 2010, 20:45 GMT
Wojo, did the "clocksource=pit" workaround worked for you?
Comment by Wojo (Wojo) - Wednesday, 20 January 2010, 00:31 GMT
Hello there.
Sorry for time delay but i am on holiday.

@jimis, no unfortunately it did not help. Still very high power consumption on 2.6.32.*. :-(

@legolas558, i already wrote what powertop says but there you go:

Cn Avg residency P-states (frequencies)
C0 (cpu running) (28.4%) 1.74 Ghz 0.0%
polling 0.0ms ( 0.0%) 1333 Mhz 0.0%
C1 mwait 0.0ms ( 0.0%) 1067 Mhz 0.0%
C3 mwait 0.0ms (71.6%) 800 Mhz 100.0%


Wakeups-from-idle per second : 28198.2 interval: 3.0s
no ACPI power usage estimate available

Top causes for wakeups:
56.7% (338.3) <interrupt> : PS/2 keyboard/mouse/touchpad
26.4% (157.7) <kernel IPI> : Rescheduling interrupts
10.2% ( 61.0) <interrupt> : extra timer interrupt
3.4% ( 20.3) <interrupt> : iwl3945
1.6% ( 9.7) X : schedule_hrtimeout_range (hrtimer_wakeup)
0.4% ( 2.7) <interrupt> : i915
0.3% ( 1.7) <interrupt> : ahci
0.3% ( 1.7) X : i915_add_request (i915_hangcheck_elapsed)
0.2% ( 1.0) i915/1 : i915_gem_retire_work_handler (delayed_work_timer_fn)
0.2% ( 1.0) fluxbox : schedule_hrtimeout_range (hrtimer_wakeup)
0.1% ( 0.3) <kernel core> : enqueue_task_rt (sched_rt_period_timer)
0.1% ( 0.3) terminal : schedule_hrtimeout_range (hrtimer_wakeup)
0.1% ( 0.3) <kernel core> : run_timer_softirq (sta_info_cleanup)
0.1% ( 0.3) <kernel core> : blk_finish_request (laptop_timer_fn)
0.1% ( 0.3) <kernel core> : run_timer_softirq (sync_supers_timer_fn)
0.1% ( 0.3) crond : start_this_handle (commit_timeout)


I am bouncing between 2.6.31.6-1 and 2.6.32.3-1, during working and during debugging.
I hope there will be some fixes soon.
Comment by Dimitrios Apostolou (jimis) - Wednesday, 20 January 2010, 14:23 GMT
What do the following commands output when booting with 2.6.31, and what with 2.6.32 with or without "clocksource=pit" boot option:

cat /sys/devices/system/clocksource/clocksource0/available_clocksource
cat /sys/devices/system/clocksource/clocksource0/current_clocksource

Do you have a quick way of finding out if the system consumption is high or not? In my case I was looking at temperatures but if in your case that doesn't show immediately perhaps you can look the wakeups-from-idle-per-second measurement of powertop.

Another thing I would suggest is booting the 2.6.32 kernel with "init=/bin/sh". This will drop you to a prompt with minimum modules loaded, and the / fs mounted as readonly. Check if the problem persists in that case with:

mount -t proc none /proc
powertop -d

My guess is it doesn't... So now load some of your normal modules and see where the problem is (look at the output of lsmod from a normal boot). My guess is you should give priority to ACPI related modules, especially the "processor" module that was the culprit in my case.

For example do:

modprobe processor # Note output messages
powertop -d

and see if the problem persists.

Oh, and have a nice holiday... ;-)
Comment by Thomas Bächler (brain0) - Saturday, 23 January 2010, 23:54 GMT Comment by Wojo (Wojo) - Sunday, 07 February 2010, 00:00 GMT
Good evening guys.
Sorry for delay but as i said earlier i was on holiday.

@brain0, unfortunately problems still remains, even for latest kernel26 2.6.32.7-1,
a lot of wakeups from idle per seconds which means really high power consumption.

@jimis, The outputs are following:

(everything is fine on that kernel)
[root@cytrynka:~]$ pacman -Q kernel26
kernel26 2.6.31.5-1
[root@cytrynka:~]$ cat /sys/devices/system/clocksource/clocksource0/available_clocksource
hpet acpi_pm tsc
[root@cytrynka:~]$ cat /sys/devices/system/clocksource/clocksource0/current_clocksource
hpet

and later,

[root@cytrynka:~]$ pacman -Q kernel26
kernel26 2.6.32.7-1

without "clocksource=pit":
[root@cytrycat /sys/devices/system/clocksource/clocksource0/available_clocksource
hpet acpi_pm
[root@cytrynka:~]$ cat /sys/devices/system/clocksource/clocksource0/current_clocksource
hpet

with "clocksource=pit":
[root@cytrynka:~]$ cat /sys/devices/system/clocksource/clocksource0/available_clocksource
hpet acpi_pm
[root@cytrynka:~]$ cat /sys/devices/system/clocksource/clocksource0/current_clocksource
hpet

So no changes at all. :'(


I think good news is that with init=/bin/sh booting power consumption is normal/lower,
but i haven't figured out which module is responsible for the problem yet.
Comment by Wojo (Wojo) - Sunday, 07 February 2010, 00:03 GMT
I've tested jimis's suggestion about booting with init=/bin/sh and later modprobing next modules.
I confirm that module called "processor" in any kernel26 2.6.32.* is a root problem of high power consumption.
Here's output of modprobing it:

ACPI: SSDT 000000003f6d94fb 00238 (v01 PmRef Cpu0Ist 000003000 INTL 20050624)
ACPI: SSDT 000000003f6d8e8c 005EA (v01 PmRef Cpu0Cst 000003001 INTL 20050624)
Marking TSC unstable due to TSC halts in idle
processor LNXCPU:00: registered as cooling_device0
ACPI: SSDT 000000003f6d9733 000C8(v01 PmRef Cpu1Ist 000003000 INTL 20050624)
ACPI: SSDT 00000000376d9476 00085 (v01 PmRef Cpu1Cst 000003000 INTL 20050624)
Swtiching to clocksource hpet
processor LNXCPU:01: registered as cooling_device1

Any advices now? Thanks in advance.
Comment by Dimitrios Apostolou (jimis) - Wednesday, 10 February 2010, 20:38 GMT
Sorry for not replying, but flyspray didn't notify me by email for your last update...

I will notify Arjan van de Ven who is responsible for the relevant changes in the processor module. Can you please give me your email address so I can CC you in case he needs more info? And I would also suggest you post the output of dmidecode, I know he will need it.
Comment by Wojo (Wojo) - Wednesday, 10 February 2010, 21:21 GMT
Hello jimis.
I've sent you an e-mail, have you got it?

Here's my dmidecode output...

[root@cytrynka:~]$ dmidecode
# dmidecode 2.10
SMBIOS 2.4 present.
25 structures occupying 1056 bytes.
Table at 0x000DC010.

Handle 0x0000, DMI type 0, 24 bytes
BIOS Information
Vendor: LENOVO
Version: 68ET31WW
Release Date: 12/21/2007
Address: 0xE5750
Runtime Size: 108720 bytes
ROM Size: 1024 kB
Characteristics:
PCI is supported
PNP is supported
APM is supported
BIOS is upgradeable
BIOS shadowing is allowed
ESCD support is available
Boot from CD is supported
Selectable boot is supported
EDD is supported
5.25"/360 kB floppy services are supported (int 13h)
5.25"/1.2 MB floppy services are supported (int 13h)
3.5"/720 kB floppy services are supported (int 13h)
3.5"/2.88 MB floppy services are supported (int 13h)
Print screen service is supported (int 5h)
8042 keyboard services are supported (int 9h)
Serial services are supported (int 14h)
Printer services are supported (int 17h)
CGA/mono video services are supported (int 10h)
ACPI is supported
USB legacy is supported
LS-120 boot is supported
BIOS boot specification is supported
Targeted content distribution is supported
BIOS Revision: 0.49
Firmware Revision: 0.49

Handle 0x0001, DMI type 1, 27 bytes
System Information
Manufacturer: LENOVO
Product Name: 0769EAG
Version: 3000 N200
Serial Number: L3ML727
UUID: 2583AD9A-056B-11DD-9B88-001EEC09614B
Wake-up Type: Power Switch
SKU Number: Lenovo
Family: Lenovo

Handle 0x0002, DMI type 2, 8 bytes
Base Board Information
Manufacturer: LENOVO
Product Name: IEL10
Version: REFERENCE
Serial Number: 43N7645Z1ZEBL84B2P3

Handle 0x0003, DMI type 3, 17 bytes
Chassis Information
Manufacturer: No Enclosure
Type: Notebook
Lock: Not Present
Version: N/A
Serial Number: None
Asset Tag: No Asset Tag
Boot-up State: Safe
Power Supply State: Safe
Thermal State: Safe
Security Status: None
OEM Information: 0x00001234

Handle 0x0004, DMI type 4, 35 bytes
Processor Information
Socket Designation: U2E1
Type: Central Processor
Family: Other
Manufacturer: Intel
ID: FD 06 00 00 FF FB EB BF
Version: CPU Version
Voltage: 3.3 V
External Clock: Unknown
Max Speed: 4096 MHz
Current Speed: 1730 MHz
Status: Populated, Enabled
Upgrade: ZIF Socket
L1 Cache Handle: 0x0005
L2 Cache Handle: 0x0006
L3 Cache Handle: Not Provided
Serial Number: Not Specified
Asset Tag: Not Specified
Part Number: Not Specified

Handle 0x0005, DMI type 7, 19 bytes
Cache Information
Socket Designation: L1 Cache
Configuration: Enabled, Socketed, Level 1
Operational Mode: Write Back
Location: Internal
Installed Size: 64 kB
Maximum Size: 64 kB
Supported SRAM Types:
Burst
Pipeline Burst
Asynchronous
Installed SRAM Type: Asynchronous
Speed: Unknown
Error Correction Type: Unknown
System Type: Unknown
Associativity: Unknown

Handle 0x0006, DMI type 7, 19 bytes
Cache Information
Socket Designation: L2 Cache
Configuration: Enabled, Socketed, Level 2
Operational Mode: Write Back
Location: Internal
Installed Size: 1024 kB
Maximum Size: 4096 kB
Supported SRAM Types:
Burst
Pipeline Burst
Asynchronous
Installed SRAM Type: Burst
Speed: Unknown
Error Correction Type: Unknown
System Type: Unknown
Associativity: Unknown

Handle 0x0007, DMI type 8, 9 bytes
Port Connector Information
Internal Reference Designator: J1A1
Internal Connector Type: None
External Reference Designator: Keyboard
External Connector Type: Circular DIN-8 male
Port Type: Keyboard Port

Handle 0x0008, DMI type 8, 9 bytes
Port Connector Information
Internal Reference Designator: J1A1
Internal Connector Type: None
External Reference Designator: PS/2 Mouse
External Connector Type: Circular DIN-8 male
Port Type: Mouse Port

Handle 0x0009, DMI type 9, 13 bytes
System Slot Information
Designation: PCI Slot J8B1
Type: 32-bit PCI
Current Usage: Unknown
Length: Long
ID: 0
Characteristics:
5.0 V is provided
3.3 V is provided

Handle 0x000A, DMI type 10, 6 bytes
On Board Device Information
Type: Sound
Status: Disabled
Description: HD-Audio

Handle 0x000B, DMI type 11, 5 bytes
OEM Strings
String 1: FDjTUWvN+idJb
String 2: mFZuVNav5orPn
String 3: Mq0ZfbVnqhRmb

Handle 0x000C, DMI type 12, 5 bytes
System Configuration Options
Option 1: SMI:00B2C1
Option 2: DSN: 804070BB2220BWWJJDC5
Option 3: DSN: HYMP564S64EP6-Y5 00006293
Option 4: DSN: SANYOLNV-42T5216015F3894
Option 5: TIM:

Handle 0x000D, DMI type 16, 15 bytes
Physical Memory Array
Location: System Board Or Motherboard
Use: System Memory
Error Correction Type: None
Maximum Capacity: 1000 MB
Error Information Handle: Not Provided
Number Of Devices: 2

Handle 0x000E, DMI type 17, 27 bytes
Memory Device
Array Handle: 0x000D
Error Information Handle: No Error
Total Width: 64 bits
Data Width: 64 bits
Size: 512 MB
Form Factor: SODIMM
Set: 1
Locator: M1
Bank Locator: Bank 0
Type: DDR2
Type Detail: Synchronous
Speed: 533 MHz
Manufacturer: Mfg 0
Serial Number: 1234-B0
Asset Tag: Not Specified
Part Number: SODIMM000

Handle 0x000F, DMI type 17, 27 bytes
Memory Device
Array Handle: 0x000D
Error Information Handle: No Error
Total Width: 64 bits
Data Width: 64 bits
Size: 512 MB
Form Factor: SODIMM
Set: 1
Locator: M2
Bank Locator: Bank 1
Type: DDR2
Type Detail: Synchronous
Speed: 533 MHz
Manufacturer: Mfg 1
Serial Number: 1234-B1
Asset Tag: Not Specified
Part Number: SODIMM001

Handle 0x0010, DMI type 19, 15 bytes
Memory Array Mapped Address
Starting Address: 0x00000000000
Ending Address: 0x0003FFFFFFF
Range Size: 1 GB
Physical Array Handle: 0x000D
Partition Width: 0

Handle 0x0011, DMI type 20, 19 bytes
Memory Device Mapped Address
Starting Address: 0x00000000000
Ending Address: 0x0001FFFFFFF
Range Size: 512 MB
Physical Device Handle: 0x000E
Memory Array Mapped Address Handle: 0x0010
Partition Row Position: Unknown
Interleave Position: Unknown
Interleaved Data Depth: Unknown

Handle 0x0012, DMI type 20, 19 bytes
Memory Device Mapped Address
Starting Address: 0x00020000000
Ending Address: 0x0003FFFFFFF
Range Size: 512 MB
Physical Device Handle: 0x000F
Memory Array Mapped Address Handle: 0x0010
Partition Row Position: Unknown
Interleave Position: Unknown
Interleaved Data Depth: Unknown

Handle 0x0013, DMI type 32, 20 bytes
System Boot Information
Status: <OUT OF SPEC>

Handle 0x0014, DMI type 131, 22 bytes
OEM-specific Type
Header and Data:
83 16 14 00 01 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 01
Strings:
TVT-Enablement

Handle 0x0015, DMI type 131, 22 bytes
OEM-specific Type
Header and Data:
83 16 15 00 01 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 01
Strings:
TVT-Enablement

Handle 0x0016, DMI type 133, 5 bytes
OEM-specific Type
Header and Data:
85 05 16 00 01
Strings:
KHOIHGIUCCHHII

Handle 0x0017, DMI type 135, 10 bytes
OEM-specific Type
Header and Data:
87 0A 17 00 50 54 07 03 01 05

Handle 0x0018, DMI type 127, 4 bytes
End Of Table
Comment by Thomas Bächler (brain0) - Wednesday, 10 February 2010, 22:33 GMT
If you submit this problem upstream, please CC me on the conversation, my address is thomas AT archlinux.org.
Comment by Stefano (kki) - Monday, 22 February 2010, 10:02 GMT
same problem happens to me guys :-/

with kernel26 > 2.6.31 i have about 35000 powertop wakeups !
otherwise i have only 4-500 wakeups...

root ~ # dmidecode
# dmidecode 2.10
SMBIOS 2.6 present.
24 structures occupying 1185 bytes.
Table at 0x000E8280.

Handle 0x0000, DMI type 0, 24 bytes
BIOS Information
Vendor: Hewlett-Packard
Version: F.12
Release Date: 12/11/2009
ROM Size: 2048 kB
Characteristics:
PCI is supported
BIOS is upgradeable
BIOS shadowing is allowed
Boot from CD is supported
Selectable boot is supported
BIOS ROM is socketed
EDD is supported
Japanese floppy for NEC 9800 1.2 MB is supported (int 13h)
Japanese floppy for Toshiba 1.2 MB is supported (int 13h)
5.25"/360 kB floppy services are supported (int 13h)
5.25"/1.2 MB floppy services are supported (int 13h)
3.5"/720 kB floppy services are supported (int 13h)
3.5"/2.88 MB floppy services are supported (int 13h)
8042 keyboard services are supported (int 9h)
CGA/mono video services are supported (int 10h)
ACPI is supported
USB legacy is supported
Targeted content distribution is supported
BIOS Revision: 15.18
Firmware Revision: 73.13

Handle 0x0001, DMI type 1, 27 bytes
System Information
Manufacturer: Hewlett-Packard
Product Name: HP Pavilion dm1 Notebook PC
Version: 048C110000241B00000320000
Serial Number: CNF9513F0Z
UUID: 39464E43-3135-4633-305A-00269EC4496F
Wake-up Type: Power Switch
SKU Number: VY489EA#ABZ
Family: 103C_5335KV

Handle 0x0002, DMI type 2, 16 bytes
Base Board Information
Manufacturer: Hewlett-Packard
Product Name: 3663
Version: 49.0D
Serial Number: CNF9513F0Z
Asset Tag: Base Board Asset Tag
Features:
Board is a hosting board
Board is replaceable
Location In Chassis: Base Board Chassis Location
Chassis Handle: 0x0003
Type: Motherboard
Contained Object Handles: 0

Handle 0x0003, DMI type 3, 22 bytes
Chassis Information
Manufacturer: Hewlett-Packard
Type: Notebook
Lock: Not Present
Version: N/A
Serial Number: None
Asset Tag: Not Specified
Boot-up State: Safe
Power Supply State: Safe
Thermal State: Safe
Security Status: None
OEM Information: 0x0000001B
Height: Unspecified
Number Of Power Cords: 1
Contained Elements: 0

Handle 0x0004, DMI type 16, 15 bytes
Physical Memory Array
Location: System Board Or Motherboard
Use: System Memory
Error Correction Type: None
Maximum Capacity: 5 GB
Error Information Handle: Not Provided
Number Of Devices: 2

Handle 0x0005, DMI type 17, 28 bytes
Memory Device
Array Handle: 0x0004
Error Information Handle: Not Provided
Total Width: 64 bits
Data Width: 64 bits
Size: 1024 MB
Form Factor: SODIMM
Set: None
Locator: DIMM0
Bank Locator: BANK 0
Type: <OUT OF SPEC>
Type Detail: Synchronous
Speed: 800 MHz
Manufacturer: Micron
Serial Number: 00000000
Asset Tag: Unknown
Part Number: 8JSF12864HZ-1G1F1F
Rank: Unknown

Handle 0x0006, DMI type 20, 19 bytes
Memory Device Mapped Address
Starting Address: 0x00000000000
Ending Address: 0x0003FFFFFFF
Range Size: 1 GB
Physical Device Handle: 0x0005
Memory Array Mapped Address Handle: 0x0009
Partition Row Position: 2
Interleave Position: 1
Interleaved Data Depth: 1

Handle 0x0007, DMI type 17, 28 bytes
Memory Device
Array Handle: 0x0004
Error Information Handle: Not Provided
Total Width: 64 bits
Data Width: 64 bits
Size: 1024 MB
Form Factor: SODIMM
Set: None
Locator: DIMM1
Bank Locator: BANK 2
Type: <OUT OF SPEC>
Type Detail: Synchronous
Speed: 800 MHz
Manufacturer: Micron
Serial Number: E633576E
Asset Tag: Unknown
Part Number: 8JSF12864HZ-1G4F1
Rank: Unknown

Handle 0x0008, DMI type 20, 19 bytes
Memory Device Mapped Address
Starting Address: 0x00000000000
Ending Address: 0x0003FFFFFFF
Range Size: 1 GB
Physical Device Handle: 0x0007
Memory Array Mapped Address Handle: 0x0009
Partition Row Position: 2
Interleave Position: 2
Interleaved Data Depth: 1

Handle 0x0009, DMI type 19, 15 bytes
Memory Array Mapped Address
Starting Address: 0x00000000000
Ending Address: 0x0007FFFFFFF
Range Size: 2 GB
Physical Array Handle: 0x0004
Partition Width: 0

Handle 0x000A, DMI type 4, 42 bytes
Processor Information
Socket Designation: CPU
Type: Central Processor
Family: Core 2 Duo
Manufacturer: Intel(R) Corporation
ID: 7A 06 01 00 FF FB EB BF
Signature: Type 0, Family 6, Model 23, Stepping 10
Flags:
FPU (Floating-point unit on-chip)
VME (Virtual mode extension)
DE (Debugging extension)
PSE (Page size extension)
TSC (Time stamp counter)
MSR (Model specific registers)
PAE (Physical address extension)
MCE (Machine check exception)
CX8 (CMPXCHG8 instruction supported)
APIC (On-chip APIC hardware supported)
SEP (Fast system call)
MTRR (Memory type range registers)
PGE (Page global enable)
MCA (Machine check architecture)
CMOV (Conditional move instruction supported)
PAT (Page attribute table)
PSE-36 (36-bit page size extension)
CLFSH (CLFLUSH instruction supported)
DS (Debug store)
ACPI (ACPI supported)
MMX (MMX technology supported)
FXSR (Fast floating-point save and restore)
SSE (Streaming SIMD extensions)
SSE2 (Streaming SIMD extensions 2)
SS (Self-snoop)
HTT (Hyper-threading technology)
TM (Thermal monitor supported)
PBE (Pending break enabled)
Version: Genuine Intel(R) CPU U2300 @ 1.20GHz
Voltage: 1.6 V
External Clock: 800 MHz
Max Speed: 1200 MHz
Current Speed: 1200 MHz
Status: Populated, Enabled
Upgrade: Other
L1 Cache Handle: 0x000D
L2 Cache Handle: 0x000B
L3 Cache Handle: Not Provided
Serial Number: Not Specified
Asset Tag: FFFF
Part Number: Not Specified
Core Count: 2
Core Enabled: 2
Thread Count: 2
Characteristics:
64-bit capable

Handle 0x000B, DMI type 7, 19 bytes
Cache Information
Socket Designation: L2 Cache
Configuration: Enabled, Not Socketed, Level 2
Operational Mode: Write Back
Location: Internal
Installed Size: 1024 kB
Maximum Size: 1024 kB
Supported SRAM Types:
Asynchronous
Installed SRAM Type: Asynchronous
Speed: Unknown
Error Correction Type: Single-bit ECC
System Type: Unified
Associativity: 4-way Set-associative

Handle 0x000C, DMI type 7, 19 bytes
Cache Information
Socket Designation: L1 Cache
Configuration: Enabled, Not Socketed, Level 1
Operational Mode: Write Back
Location: Internal
Installed Size: 32 kB
Maximum Size: 32 kB
Supported SRAM Types:
Asynchronous
Installed SRAM Type: Asynchronous
Speed: Unknown
Error Correction Type: Single-bit ECC
System Type: Instruction
Associativity: 8-way Set-associative

Handle 0x000D, DMI type 7, 19 bytes
Cache Information
Socket Designation: L1 Cache
Configuration: Enabled, Not Socketed, Level 1
Operational Mode: Write Back
Location: Internal
Installed Size: 32 kB
Maximum Size: 32 kB
Supported SRAM Types:
Asynchronous
Installed SRAM Type: Asynchronous
Speed: Unknown
Error Correction Type: Single-bit ECC
System Type: Data
Associativity: 8-way Set-associative

Handle 0x000E, DMI type 9, 17 bytes
System Slot Information
Designation: PCI Express Graphic X16
Type: x16 PCI Express
Current Usage: Available
Length: Other
ID: 0
Characteristics:
PME signal is supported
Hot-plug devices are supported

Handle 0x000F, DMI type 9, 17 bytes
System Slot Information
Designation: PCI Express-0
Type: x1 PCI Express
Current Usage: Available
Length: Other
ID: 0
Characteristics:
PME signal is supported
Hot-plug devices are supported

Handle 0x0010, DMI type 10, 6 bytes
On Board Device Information
Type: Video
Status: Enabled
Description:

Handle 0x0011, DMI type 22, 26 bytes
Portable Battery
Location: Primary
Manufacturer: SMP-LG26B3
Name: PT06055
Design Capacity: 5100 mWh
Design Voltage: 10800 mV
SBDS Version: 1.1
Maximum Error: 1%
SBDS Serial Number: 0F7D
SBDS Manufacture Date: 2009-12-04
SBDS Chemistry: LION
OEM-specific Information: 0x00000000

Handle 0x0012, DMI type 11, 5 bytes
OEM Strings
String 1: $HP$
String 2: LOC#ABZ
String 3: ABS 70/71 78 79 7A 7B
String 4: CNB1 048C110000241B00000320000

Handle 0x0013, DMI type 15, 29 bytes
System Event Log
Area Length: 32672 bytes
Header Start Offset: 0x0000
Data Start Offset: 0x0000
Access Method: General-purpose non-volatile data functions
Access Address: 0x0000
Status: Valid, Not Full
Change Token: 0x12345678
Header Format: OEM-specific
Supported Log Type Descriptors: 3
Descriptor 1: POST memory resize
Data Format 1: None
Descriptor 2: POST error
Data Format 2: POST results bitmap
Descriptor 3: Log area reset/cleared
Data Format 3: None

Handle 0x0014, DMI type 32, 20 bytes
System Boot Information
Status: No errors detected

Handle 0x0015, DMI type 41, 11 bytes
Onboard Device
Reference Designation: Mobile Intel(R) Series Express Chipset Family
Type: Video
Status: Enabled
Type Instance: 1
Bus Address: 0000:00:02.0

Handle 0x0016, DMI type 41, 11 bytes
Onboard Device
Reference Designation: Atheros AR9285 802.11b/g/n WiFi Adapter
Type: Ethernet
Status: Enabled
Type Instance: 1
Bus Address: 0000:02:00.0

Handle 0x0017, DMI type 127, 4 bytes
End Of Table
---

the higher wakeups i receive is from "Rescheduling interrupts".
Any idea on how to fix this ?
for now i must stay on <2.6.32 kernel since cpu temperature with higher kernel stay on 53+C while with kernel <2.6.32 stay on 42C
obviously with very high battery consumption.
thanks

Comment by Stefano (kki) - Monday, 22 February 2010, 11:02 GMT
i have tried to do not load the processor module and the problem is gone, but obviously cpu temp and performance are always high.
Comment by Thomas Bächler (brain0) - Monday, 22 February 2010, 12:24 GMT
This commit was added to 2.6.33, no idea if it is also in the stable 2.6.32 tree: http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=370d5cd88509b93b76eb2f5f97efbd71c25061cb

"Since the rewrite of the CPU idle governor in 2.6.32, two laptops have
surfaced where the BIOS advertises a C2 power state, but for some reason
this state is not functioning (as verified in both cases by powertop
before the patch in .32).

The old governor had the accidental behavior that if a non-working state
was chosen too many times, it would end up falling back to C1. The new
governor works differently and this accidental behavior is no longer
there; the result is a high temperature on these two machines.

This patch adds these 2 machines to the DMI table for C state anomalies;
by just not using C2 both these machines are better off (the TSC can be
used instead of the pm timer, giving a performance boost for example).

Addresses http://bugzilla.kernel.org/show_bug.cgi?id=14742

Signed-off-by: Arjan van de Ven <arjan@linux.intel.com>
Reported-by: <akwatts@ymail.com>
Cc: <stable@kernel.org>
Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
Signed-off-by: Len Brown <len.brown@intel.com>"
Comment by Wojo (Wojo) - Monday, 22 February 2010, 12:52 GMT
So it seems like they have not fixed it for my machine (yet).
Lenovo 3000 n200 is having the same problem.
Comment by Stefano (kki) - Monday, 22 February 2010, 14:21 GMT
the same for mine, HP Pavilion DM1-1150SL
Comment by Stefan Wilkens (stefanwilkens) - Monday, 22 February 2010, 16:02 GMT
You should take this upstream Wojo / Stefano,

Kernel devs have requested a bugreport to be made for every individual machine, adding dmicode output. I suggest you read through the following bug report's comments:
http://bugzilla.kernel.org/show_bug.cgi?id=14742
Comment by Dimitrios Apostolou (jimis) - Monday, 22 February 2010, 16:04 GMT
Stefano: Can you please attach the output of "powertop -d", "dmidecode" and "lspci -vvv", with the offending kernel loaded? Moreover what is the content of the following files? When you boot with init=/bin/sh and manually load processor module, do you get any strange messages?

/sys/devices/system/clocksource/clocksource0/available_clocksource
/sys/devices/system/clocksource/clocksource0/current_clocksource

I'll report this info in the same LKML thread so that when the kernel folks fix Wojo's case (which is different that mine and needs a different patch than the one applied) they take yours into account, too.

Also please try booting with "clocksource=pit", it was useful as a temporary workaround in my case.
Comment by Stefano (kki) - Monday, 22 February 2010, 16:26 GMT
@Apostolou , i've attached a file hp.pavilion.dm1-1150sl.txt that is my notebook, tested also the clocksource=pit but no effect, still lot of wakeups.
Monitor-Mwait will be used to enter C-1 state
Monitor-Mwait will be used to enter C-2 state
Marking TSC unstable due to TSC halts in idle
Switching to clocksource hpet
this is from my dmesg with faulted kernel, after this comment i'll try the init=/bin/sh.

root ~ # cat /sys/devices/system/clocksource/clocksource0/available_clocksource
hpet acpi_pm

root ~ # cat /sys/devices/system/clocksource/clocksource0/current_clocksource
hpet


thanks for now!
Comment by Stefano (kki) - Tuesday, 23 February 2010, 11:19 GMT Comment by Wojo (Wojo) - Thursday, 01 April 2010, 23:38 GMT
After few weeks with no respond through e-mail i've decided to open bug on kernel.org's bugzilla.
You can find it here: http://bugzilla.kernel.org/show_bug.cgi?id=15675
Comment by Thomas Dziedzic (tomd123) - Monday, 17 May 2010, 04:26 GMT
upstream bug reports "need info"

Loading...