Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#16726 - [gnome] Wrong background for icons in GNOME system tray

Attached to Project: Arch Linux
Opened by Alessio Bianchi (Venator85) - Sunday, 18 October 2009, 19:28 GMT
Last edited by Jan de Groot (JGC) - Thursday, 19 August 2010, 06:34 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 24
Private No

Details

Description:
Since GNOME 2.28 hit [extra], the icons placed by several apps in the system tray/notification area show wrong background color. This is particularly evident with dark themes such as Shiki Colors, Ubuntu's Dust and New Wave. See the attached screenshot: Gajim, mail-notifications and Pidgin show wrong backgrounds, while other apps such as Dropbox, Network Manager, Fusion icon and Skype do not.

$ pacman -Q gtk2 gtk-engines gnome-panel
gtk2 2.18.2-1
gtk-engines 2.18.4-1
gnome-panel 2.28.0-1

Steps to reproduce:
- Upgrade to GNOME 2.28
- Switch to a dark theme (eg Shiki Colors, Ubuntu's Dust or New Wave)
This task depends upon

Closed by  Jan de Groot (JGC)
Thursday, 19 August 2010, 06:34 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in pidgin 2.7.x
Comment by andrey demidov (demas) - Monday, 19 October 2009, 17:24 GMT
I have this problem too.
Comment by Alper Kanat (T-u-N-i-X) - Wednesday, 21 October 2009, 18:06 GMT
me either!
Comment by Pepe (kerer) - Wednesday, 21 October 2009, 19:42 GMT
So do I
Comment by Jan de Groot (JGC) - Wednesday, 21 October 2009, 20:17 GMT
Unless someone can pinpoint this problem to a certain commit, I don't want any comments here. Posting "Me too" is useless.
Comment by Alessio Bianchi (Venator85) - Wednesday, 21 October 2009, 20:57 GMT
Latest update of the following packages did not solve the issue.

pango (1.26.0-1 -> 1.26.0-2)
shared-mime-info (0.60-1 -> 0.70-1)
gtk2 (2.18.2-1 -> 2.18.3-1)
at-spi (1.28.0-1 -> 1.28.1-1)
consolekit (0.3.1-1 -> 0.4.1-1)
libatasmart (0.14-1 -> 0.16-1)
devicekit-disks (007-1 -> 008-1)
devicekit-power (010-1 -> 012-2)
libspectre (0.2.2-2 -> 0.2.3-1)
poppler (0.12.0-1 -> 0.12.1-1)
poppler-glib (0.12.0-1 -> 0.12.1-1)
gnome-keyring (2.28.0-1 -> 2.28.1-1)
evince (2.28.0-1 -> 2.28.1-1)
fontcacheproto (0.1.2-2 -> 0.1.3-1)
libsoup (2.28.0-1 -> 2.28.1-1)
libsoup-gnome (2.28.0-1 -> 2.28.1-1)
gvfs (1.4.0-1 -> 1.4.1-1)
kbproto (1.0.3-2 -> 1.0.4-1)
libwebkit (1.1.15.2-1 -> 1.1.15.3-1)
randrproto (1.3.0-1 -> 1.3.1-1)
tzdata (2009n-1 -> 2009o-1)
xf86miscproto (0.9.2-2 -> 0.9.3-1)
Comment by Nikolay Gavrushin (ZZaiatSS) - Saturday, 07 November 2009, 12:21 GMT
Same problem
Comment by Alessio Bianchi (Venator85) - Monday, 09 November 2009, 08:55 GMT
Still unresolved with latest updates:
[2009-11-09 09:41] upgraded docbook-xml (4.5-2 -> 4.5-3)
[2009-11-09 09:41] upgraded exempi (2.1.0-1 -> 2.1.1-1)
[2009-11-09 09:41] upgraded gnome-panel (2.28.0-1 -> 2.28.0-2)
[2009-11-09 09:41] upgraded gnutls (2.8.4-1 -> 2.8.5-1)
[2009-11-09 09:41] upgraded gtk2 (2.18.3-1 -> 2.18.3-2)
[2009-11-09 09:41] upgraded gtkspell (2.0.15-1.1 -> 2.0.16-1)
[2009-11-09 09:41] upgraded libmms (0.4-1 -> 0.5-1)
[2009-11-09 09:41] upgraded libpng (1.2.39-1 -> 1.2.40-1)
[2009-11-09 09:41] upgraded libv4l (0.6.0-1 -> 0.6.3-1)
[2009-11-09 09:41] upgraded libxslt (1.1.24-2 -> 1.1.26-1)
[2009-11-09 09:41] upgraded openssl (0.9.8k-4 -> 0.9.8l-1)
[2009-11-09 09:41] upgraded vte (0.22.3-1 -> 0.22.4-1)
[2009-11-09 09:41] upgraded xorg-server (1.7.1.901-1 -> 1.7.1.901-2)
Comment by Pavel (Alsvartr) - Sunday, 06 December 2009, 09:54 GMT
1. this bug also affects banshee and liferea for me;

2. i think this is a new gtk issue, however it solvable with some patches to the particular applications;

3. i've made a little search through upstream bugtrackers:

gajim: http://trac.gajim.org/ticket/5246 (issue solved in hg)
banshee: https://bugzilla.gnome.org/show_bug.cgi?id=588255 (there is a working patch)
pidgin: http://developer.pidgin.im/ticket/10228 (I've not tried to apply this patches, cause I don't use pidgin)
Comment by Jannik Heller (scrawl) - Saturday, 16 January 2010, 15:17 GMT
Still present with gtk2 2.18.5-1 . Please fix this so I can use shiki-colors again :)
Comment by Marcos Roriz (marcosRz) - Tuesday, 19 January 2010, 02:21 GMT
Me too and it seems that is a problem with ARCH pkgs since Ubuntu dont have this problem.
Comment by martin (ueu) - Thursday, 21 January 2010, 18:09 GMT
Confirming, actually the guys from Ubuntu have this bug too( I think in lucid )
vlc is affected as well
Comment by lh (jarryson) - Friday, 05 March 2010, 17:46 GMT
i met this problem, too.

gnome 2.29. but xfce4-panel have not such problem.
Comment by Gavin Bisesi (Daenyth) - Thursday, 01 April 2010, 21:30 GMT
KDE shows this issue as well.
Comment by Benjamin Wild (honki) - Friday, 02 April 2010, 23:28 GMT
i'm not sure what exactly causes this, but at least in pidgin it's fixed in 2.7devel...
Comment by Frozen Fox (FrozenFox) - Wednesday, 28 April 2010, 23:31 GMT
For those who wish to get this working before pidgin 2.7, you can build the current 2.6 from ABS with patches and it seems to be working. See jarryson's later posts in http://bbs.archlinux.org/viewtopic.php?pid=731130 . Other apps are still in need of their own fixes.

Loading...