Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#16584 - [Conky] Conky looks in the wrong sysfs dir for hwmon temperature info after kernel upgrade

Attached to Project: Arch Linux
Opened by partha chowdhury (partha_chowdhury) - Monday, 12 October 2009, 11:34 GMT
Last edited by Giovanni Scafora (giovanni) - Monday, 19 October 2009, 19:56 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Giovanni Scafora (giovanni)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
My problem is exactly same as this one.
https://bugs.launchpad.net/ubuntu/+source/conky/+bug/435571


Additional info:
* package version(s)
conky 1.7.2-1
kernel26 2.6.31.3-1

* config and/or log files etc.


Steps to reproduce:
1.upgrade kernel to latest 2.6.31.3-1
2.reboot
3.Now try to start conky
4.it does not start and throws error message.

After i applied the patch http://bazaar.launchpad.net/~norsetto/%2Bjunk/conky/annotate/head%3A/patches/fix_hwmon_for_2.6.31.patch, it works.
This task depends upon

Closed by  Giovanni Scafora (giovanni)
Monday, 19 October 2009, 19:56 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in conky 1.7.2-5 for both arch.
Comment by partha chowdhury (partha_chowdhury) - Monday, 12 October 2009, 11:52 GMT
i am also attaching the PKGBUILD with the patch applied.
   PKGBUILD (1.2 KiB)
Comment by partha chowdhury (partha_chowdhury) - Monday, 12 October 2009, 11:54 GMT

i am also attaching the PKGBUILD with the patch applied.
   PKGBUILD (1.3 KiB)
Comment by partha chowdhury (partha_chowdhury) - Friday, 16 October 2009, 12:34 GMT
  • Field changed: Percent Complete (100% → 0%)
The same bug is back in the latest update to conky i.e conky 1.7.2-4 .
Comment by partha chowdhury (partha_chowdhury) - Monday, 19 October 2009, 15:42 GMT
As reported in  FS#16650 , the updated patch SHOULD work without breaking anything. Also as reported in this thread http://bbs.archlinux.org/viewtopic.php?id=82231 , me and another memeber have already reported that it works on our machines.

Loading...