Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#13162 - [policykit] usb mounting IsCallerPriviliged failed

Attached to Project: Arch Linux
Opened by Lone_Wolf (Lone_Wolf) - Sunday, 08 February 2009, 15:21 GMT
Last edited by Jan de Groot (JGC) - Sunday, 08 November 2009, 22:25 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity High
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 8
Private No

Details

On mounting any external usb drive/memorystick KDE gives this error :
An error occured when accessing xxxx , the system responded
org.freedesktop.Hal.Device.Volume.UnknownFailure: IsCallerPrivileged() failed

User is in storage group, drives work fine on other os, pmount also fails.
Attached are DMESG output and a screenshot of the error from KDE dolphin.

packages :
hal 0.5.11-7
policykit 0.9-7
policykit-kde 4.2.0-1

The problem is also mentioned in FS #12126 and in 2 forum threads forum :
http://bbs.archlinux.org/viewtopic.php?id=59036
http://bbs.archlinux.org/viewtopic.php?id=59017
This task depends upon

Closed by  Jan de Groot (JGC)
Sunday, 08 November 2009, 22:25 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in 0.5.13-3 (testing)
Comment by Lone_Wolf (Lone_Wolf) - Sunday, 08 February 2009, 16:19 GMT
Checked again, and pmount does work .
I originally set severity to high, because there didn't seem to be a workaround.
Feel free to lower the severity.
Comment by Johannes von Scheidt (clinx) - Sunday, 08 February 2009, 17:45 GMT
Can Confirm this.
Comment by ugaciaka (ugaciaka) - Sunday, 08 February 2009, 19:48 GMT
Can confirm this but only if PolicyKit.conf is

<?xml version="1.0" encoding="UTF-8"?> <!-- -*- XML -*- -->

<!DOCTYPE pkconfig PUBLIC "-//freedesktop//DTD PolicyKit Configuration 1.0//EN"
"http://hal.freedesktop.org/releases/PolicyKit/1.0/config.dtd">

<!-- See the manual page PolicyKit.conf(5) for file format -->

<config version="0.1">
<match action="org.freedesktop.hal.storage.mount-removable">
<return result="yes" />
</match>
<match action="org.freedesktop.hal.storage.eject-removable">
<return result="yes" />
</match>
<match action="org.freedesktop.hal.storage.mount-fixed">
<return result="yes"/>
</match>
<match action="hal-storage-mount-fixed-extra-options">
<return result="yes"/>
</match>
<match action="hal-storage-mount-removable-extra-options">
<return result="yes"/>
</match>
</config>

Comment by Sergio (SergioPR) - Sunday, 08 February 2009, 22:51 GMT
I get another error. You can see it in the attached image. It worked fine before updating hal :S
Comment by Jan de Groot (JGC) - Sunday, 08 February 2009, 23:19 GMT
The new version of hal only works with consolekit. If you don't happen to use kdm or gdm as login manager, you need to add pam_ck_session.so to the login pam module and launch your desktop with ck-launch-session.
Comment by ugaciaka (ugaciaka) - Monday, 09 February 2009, 08:51 GMT
another problem, when I will shutdown pc (i'm using xfce): relogin! I'm using slim...
"failed to execute login command" and relogin
Comment by Alois Nespor (anespor) - Monday, 09 February 2009, 15:51 GMT
x86_64, confirm, used KDE 4.2.0.

Program can not remember the set. No value can not be set. Program either crashes or stops responding
Comment by ugaciaka (ugaciaka) - Monday, 09 February 2009, 15:54 GMT
i solved
in .xinitrc

exec ck-launch-session xfce4-session
Comment by Alois Nespor (anespor) - Monday, 09 February 2009, 16:09 GMT

I have only one message from console: polkit-read-auth-helper: needs to be setgid policykit
Comment by Jan de Groot (JGC) - Monday, 09 February 2009, 16:12 GMT
Please reinstall policykit in that case. Policykit should handle that from post_install/upgrade.
Comment by Lone_Wolf (Lone_Wolf) - Monday, 09 February 2009, 18:30 GMT
Solved with changes made in ~/.xinitrc (Similar to ugaciaka) :

OLD
exec startkde

NEW
exec ck-launch-session startkde

Added to wiki HAL page, http://wiki.archlinux.org/index.php/HAL#Automounting_fails_with_.22IsCallerPrivileged_failed.22_message
Comment by Anton Komolov (xRemaLx) - Tuesday, 10 February 2009, 11:30 GMT
PSP not mount.
I am donwgrade to hal-0.5.11-4
pacman -U /var/cache/pacman/pkg/hal-0.5.11-4-i686.pkg.tar.gz
and it work fine.
Comment by ... (kjon) - Tuesday, 10 February 2009, 16:02 GMT
Please, have a look a this solution.
http://bbs.archlinux.org/viewtopic.php?id=65070
Comment by methuselah (methuselah) - Tuesday, 10 February 2009, 19:14 GMT
I have the same problem as ugaciaka (ugaciaka): I use xfce4 and slim and when I try to quit and shutdown or reboot..... my computer will just go back to the login screen.


I fixed my mount issue with the Policykit fix but my "shutdown/reboot" still wont work unless I use the terminal commands of: "sudo poweroff" or "sudo reboot -n".
Comment by methuselah (methuselah) - Tuesday, 10 February 2009, 20:24 GMT
ROOKIE and westend fixed the xfce4/slim reboot problem in this post: http://bbs.archlinux.org/viewtopic.php?pid=496619#p496619

by adding this to the Policykit.conf (as well as the tip from the HAL wiki page for mounting):

<match action="org.freedesktop.hal.power-management.shutdown">
<return result="yes"/>
</match>
<match action="org.freedesktop.hal.power-management.reboot">
<return result="yes"/>
</match>
Comment by borrell (borrell) - Wednesday, 11 February 2009, 00:12 GMT
I can confirm that

<match action="org.freedesktop.hal.power-management.shutdown">
<return result="yes"/>
</match>
<match action="org.freedesktop.hal.power-management.reboot">
<return result="yes"/>
</match>

fixes the shutdown/reboot problem, and that

<match action="org.freedesktop.hal.storage.*">
<return result="yes"/>
</match>
<match action="hal-storage-mount-fixed-extra-options"> <!-- for internal devices mounted with extra options like a wished mount point -->
<return result="yes" />
</match>
<match action="hal-storage-mount-removable-extra-options"> <!-- for external devices mounted with extra options like a wished mount point -->
<return result="yes" />
</match>

will fix the device mounting issue
Comment by Marco Carrozzo (ozeta) - Wednesday, 18 February 2009, 14:23 GMT
any news?
Comment by Lone_Wolf (Lone_Wolf) - Tuesday, 10 March 2009, 20:17 GMT
The error I described when starting this bug report can be solved by using ck-launch-session in .xinitrc .
However several other errors are described in the comments and it is unclear if they have been solved.
Since the bug has not assignee (yet), i am not sure how to continue.
Comment by Gerardo Exequiel Pozzi (djgera) - Sunday, 31 May 2009, 19:00 GMT
what is the status of this?
Comment by Alessandro Doro (adoroo) - Saturday, 18 July 2009, 01:06 GMT
The reporter solved the problem. Can this be closed as not a bug?
Comment by Alessandro Doro (adoroo) - Wednesday, 21 October 2009, 19:34 GMT
ping

Loading...