Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#12945 - medit not detecting file change on disk properly when FAM is provided by gamin

Attached to Project: Community Packages
Opened by Mauro Santos (R00KIE) - Saturday, 24 January 2009, 21:19 GMT
Last edited by Sergej Pupykin (sergej) - Wednesday, 28 January 2009, 19:14 GMT
Task Type Bug Report
Category
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Low
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
medit doesn't detect file changes on disk properly when used with gamin, it reports that the file being edited was changed by another program after being saved by medit (which is not true). Also when starting medit from the console there is the following error/warning: "medit: Symbol `FamErrlist' has different size in shared object, consider re-linking".
I have been able to make it work properly by changing the PKGBUILD slighty. Line 20 reads "./configure --prefix=/usr --with-pygtk --with-python --with-xml --with-fam", if the option "--with-fam" is removed then medit behaves properly.
The option "--with-fam" is off by default. In the install instructions that come with the source one can read: "FAM seems to work well, but gamin seems to be much less stable. This option is not recommended if FAM is provided by gamin on your system. Note that file monitoring will work even without FAM, so it's unlikely you want to use this option."
Not using the option "--with-fam" in the PKGBUILD will make it work properly regardless of the file alteration monitoring program used.

Additional info:
medit 0.9.4-4
gamin 0.1.10-1

Steps to reproduce:
Ensure FAM is provided by gamin.
Open medit and type any text.
Save the file to disk, gamin should report that the file was changed by some other program by putting an exclamation mark before the name of the file (doesn't happen everytime), further editing and saving/overwriting of the file don't seem to trigger this problem.
Open medit from the console to check the error/warning message.
This task depends upon

Closed by  Sergej Pupykin (sergej)
Wednesday, 28 January 2009, 19:14 GMT
Reason for closing:  Fixed
Additional comments about closing:  0.9.4-5
Comment by Greg (dolby) - Sunday, 25 January 2009, 00:11 GMT
Medit is in community. Theres a seperate section for packages in community.
Comment by Mauro Santos (R00KIE) - Sunday, 25 January 2009, 00:22 GMT
Oh ... right ^^; first bug report .... still learning how things work .... is there any way I can move it there or is it better to close this one and open another one there?
Comment by Greg (dolby) - Sunday, 25 January 2009, 00:25 GMT
No you cant move it. Better let someone who can do it for you. Dont open another report. You could also read http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines if you have the time too :-)
Comment by Mauro Santos (R00KIE) - Sunday, 25 January 2009, 12:40 GMT
Yes, I did look though that wiki page before reporting the bug .... It seems I didn't read it well enough the first time though ^^;;
Anyway, I'll do as you say, I'll let someone who can do it move it to the proper place. Will I need to request the change or will this be noticed and moved?
Comment by Roman Kyrylych (Romashka) - Monday, 26 January 2009, 12:52 GMT
moved to Community Packages project

Loading...