Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#11502 - Gnome Bluetooth support broken after last testing upgrades

Attached to Project: Arch Linux
Opened by Alessio Bianchi (Venator85) - Tuesday, 16 September 2008, 08:14 GMT
Last edited by Geoffroy Carrier (gcarrier) - Saturday, 14 February 2009, 07:59 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Geoffroy Carrier (gcarrier)
Architecture i686
Severity High
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 11
Private No

Details

Description:
Gnome support for Bluetooth is broken:
- bluetooth-applet does not show any available adapter
- launching gnome-obex-server from shell:
$ gnome-obex-server
gnome-obex-server: error while loading shared libraries: libbluetooth.so.2: cannot open shared object file: No such file or directory
- With obex-data-server running in shell, a mobile phone can't detect the PC, but no error message is printed on the shell
- Launching bluetooth-sendto, after picking a file, the "Select destination device" list is disabled and empty, but 'hcitool scan' from a shell correctly finds the phone
- /etc/rc.d/bluetooth (re)start prints no errors

Additional info:
$ pacman -Q udev hal bluez bluez-gnome gnome-bluetooth gvfs
udev 128-3
hal 0.5.11-4
bluez 4.1-1
bluez-gnome 0.25-1
gnome-bluetooth 0.11.0-1.1
gvfs 0.2.5-3

All packages are upgraded to the latest versions available.

$ dmesg|grep -i blue
Bluetooth: Core ver 2.11
Bluetooth: HCI device and connection manager initialized
Bluetooth: HCI socket layer initialized
Bluetooth: HCI USB driver ver 2.9
Bluetooth: L2CAP ver 2.9
Bluetooth: L2CAP socket layer initialized
Bluetooth: RFCOMM socket layer initialized
Bluetooth: RFCOMM TTY layer initialized
Bluetooth: RFCOMM ver 1.8
Bluetooth: BNEP (Ethernet Emulation) ver 1.2

Steps to reproduce:
Upgrade the listed packages. Couldn't tell if this issue started happening after the udev/hal or the bluez upgrade.
Thanks ;)
This task depends upon

Closed by  Geoffroy Carrier (gcarrier)
Saturday, 14 February 2009, 07:59 GMT
Reason for closing:  Fixed
Comment by Blazej (blasse) - Monday, 13 October 2008, 11:35 GMT
This is connected with bluez-gnome pkg (maybe with something else also). Bluez-gnome needs version 1.x to support bluez4 api.
Comment by Alessio Bianchi (Venator85) - Monday, 13 October 2008, 14:46 GMT
Manually bumped bluez-gnome to 1.8 (modified PKGBUILD at http://pastebin.com/f312e7bf9) with no luck :(
Running a very current installation (updated now).
Comment by adam (adamruss) - Monday, 13 October 2008, 20:55 GMT
confirming here
Comment by servilvo (servilvo) - Friday, 17 October 2008, 16:18 GMT
I bumped bluez and bluez-gnome to:

pacman -Q udev hal bluez bluez-gnome gnome-bluetooth gvfs
udev 130-1
hal 0.5.11-4
bluez 4.14-1
bluez-gnome 1.8-1
gnome-bluetooth 0.11.0-2
gvfs 1.0.1-1

and it works again.
Comment by Timm (gummibaerchen) - Friday, 17 October 2008, 17:07 GMT
So seems like the bluez-gnome stuff is really outdated. Sadly no maintainer is given in the webinterface.

The PKGBUILD says: Roman; Aaron uploaded it.
Comment by Blazej (blasse) - Friday, 17 October 2008, 17:35 GMT
pacman -Q udev hal bluez bluez-gnome gnome-bluetooth gvfs
udev 130-1
hal 0.5.11-4
bluez 4.14-1
bluez-gnome 1.8-1
gnome-bluetooth 0.11.0-2
gvfs 1.0.1-1

And still no go. Bluetooth icon shows, but any try to send a file to bluetooth device produces error code: "Launch helper exited with unknown return code 255"
Comment by Alessio Bianchi (Venator85) - Friday, 17 October 2008, 19:03 GMT
No go here as well, I'm in the exact same situation of Blazej.
Comment by servilvo (servilvo) - Wednesday, 22 October 2008, 21:40 GMT
Sorry, i only tried to send from my mobile phone and it worked. But sending from computer don't ("Launch helper exited with unknown return code 255")
Well in the meantime, you can put this script in nautilus script folder.

bluetooth-send
-------------------------------------------------
#!/bin/sh
#Alternative to bluetooth-sendto
TMPFILE=`mktemp`

hcitool scan | grep -v Scanning > ${TMPFILE}
if [ $? -eq 1 ]; then
zenity --error --text="Couldn't scan for devices"
rm ${TMPFILE}
exit
fi

zenity --list --text="Choose a recipient" --column Address --column Name `cat ${TMPFILE}` > ${TMPFILE}

DEST=`cat ${TMPFILE}`

if [ -z ${DEST} ]; then
zenity --error --text="No recipient selected"
rm ${TMPFILE}
exit
fi

for i in $NAUTILUS_SCRIPT_SELECTED_FILE_PATHS; do
obexftp -b `cat ${TMPFILE}` -p "$i"
done

rm ${TMPFILE}
----------------------------------------
You need obexftp, and gnome-python for nautilus-scripts
Bye
Comment by Blazej (blasse) - Wednesday, 29 October 2008, 21:26 GMT
According to http://bbs.archlinux.org/viewtopic.php?pid=442045#p442045 gvfs 1.0.2 isn't compatible with bluez. gvfs-svn is needed. I haven't time to test this however.
Comment by Blazej (blasse) - Thursday, 30 October 2008, 22:08 GMT
With
udev 130-1
hal 0.5.11-4
bluez 4.17-0
bluez-gnome 1.8-1
gnome-bluetooth 0.11.0-2
gvfs-svn 2068
I've managed to get working sharing bluetooh device. (This needs also obex-data-server built without --enable-system-config) However sendig files still does not work.
Comment by Blazej (blasse) - Thursday, 30 October 2008, 22:19 GMT
Any try to copy file to a bluetooth device gives "Operation not supported by backend" error when sharing device or "Method "CreateBluetoohSession" with signature "ss" on interface "org.openobex.Manager" doesn't exist" when using Send files to device context menu frome gnome-bluetooth
Comment by Paul Philippov (themactep) - Friday, 14 November 2008, 15:51 GMT
We've managed bluez-gnome-1.8 to send files with bluez-4.*
Check gentoo bugzilla for patches http://bugs.gentoo.org/show_bug.cgi?id=236357

Comment by warriant (warriant) - Saturday, 15 November 2008, 16:20 GMT
_
Comment by Blazej (blasse) - Saturday, 15 November 2008, 17:05 GMT
openobex 1.4? Thought 1.3 is the latest?
Comment by warriant (warriant) - Saturday, 15 November 2008, 17:10 GMT
_
Comment by Matthias Hartner (matsche) - Monday, 24 November 2008, 09:53 GMT
gvfs 1.0.3 is out!! ftp://ftp.gnome.org/pub/GNOME/sources/gvfs/1.0/

But sending is not working here:
pacman -Q bluez bluez-gnome gvfs obex-data-server openobex
bluez 4.19-1
bluez-gnome 1.8-1
gvfs 1.0.3-1
obex-data-server 0.4.2-1
openobex 1.4-1
Comment by warriant (warriant) - Monday, 24 November 2008, 20:40 GMT
_
Comment by warriant (warriant) - Tuesday, 25 November 2008, 04:51 GMT
_
Comment by Jud (judfilm) - Thursday, 04 December 2008, 09:06 GMT
There will be a new Bluetooth Maintainer soon.
Comment by Ionut Biru (wonder) - Monday, 05 January 2009, 21:18 GMT
works great with bluez 4.25-1 bluez-gnome 1.8-1 gnome-bluetooth 0.11.0-3
Comment by Geoffroy Carrier (gcarrier) - Monday, 05 January 2009, 21:40 GMT
After upgrading, nothing changed, i.e. bluetooth-wizard (launched from bluetooth-applet) didn't detect anything, and bluetooth-applet options had to be set to "always show the icon". Running udevadm control --reload-rules didn't help, restarting bluetooth-applet didn't help, but I restarted dbus (so hal too, so xorg too, so my gnome session too) and it worked. If anybody has an idea about what to run from the install script to get it updated, it would be nice to tell!
Comment by Blazej (blasse) - Monday, 05 January 2009, 22:28 GMT
With obexd I cannot send nor recive files from bluetooth device. (Send file menu is greyed out)
Comment by warriant (warriant) - Tuesday, 06 January 2009, 13:44 GMT
_
Comment by warriant (warriant) - Tuesday, 06 January 2009, 13:55 GMT
_
Comment by Blazej (blasse) - Saturday, 24 January 2009, 11:30 GMT
According to Bluez site obexd should work as a replacement for obex-data-server (they cannot work together).
Comment by warriant (warriant) - Saturday, 24 January 2009, 19:21 GMT
_
Comment by Geoffroy Carrier (gcarrier) - Saturday, 24 January 2009, 19:27 GMT
So we should get rid of obexd and use obex-data-server? Any objection/recommandation?
Comment by Blazej (blasse) - Saturday, 24 January 2009, 20:14 GMT
Obex-data-server works better, so we could go with it. I've just reinstalled system to x86_64. Unfortunately bluetooth isn't working with current packages :/
Comment by warriant (warriant) - Sunday, 25 January 2009, 14:04 GMT
_
Comment by Blazej (blasse) - Sunday, 25 January 2009, 15:22 GMT
obez-data-server should work fine with this pkgbuild:

# $Id$
# Maintainer: Roman Kyrylych <roman@archlinux.org>
# Contributor: Keerthi <keerthi.linux@gmail.com>

pkgname=obex-data-server
pkgver=0.4.2
pkgrel=1
pkgdesc="obex-data-server is D-Bus service providing high-level OBEX client and server side functionality."
arch=('i686' 'x86_64')
provides=('obexd=0.8')
url="http://wiki.muiline.com/obex-data-server"
license=('GPL')
depends=('dbus-glib>=0.76' 'bluez>=4.1' 'openobex>=1.3-3')
source=(http://tadas.dailyda.com/software/obex-data-server-${pkgver}.tar.gz)
#md5sums=('5c71d24e8d471cc294d9d47a8f8de971')

build() {
cd "${srcdir}/${pkgname}-${pkgver}"
./configure --prefix=/usr --sysconfdir=/etc || return 1
make || return 1
make DESTDIR="${pkgdir}" install || return 1
}

However this isn't resolving all bluetooth problems :) Gentoo is dealing with the same, here's bug report: http://bugs.gentoo.org/show_bug.cgi?id=236357 (taken from Paul Philippov comment)
Comment by warriant (warriant) - Sunday, 25 January 2009, 16:18 GMT
_
Comment by Blazej (blasse) - Saturday, 31 January 2009, 20:20 GMT
With bluez 4.27-1, bluez-gnome 1.8-1 and obex-data-server 0.4.2-1 bluetooth still not working. Symptoms the same.
Comment by warriant (warriant) - Saturday, 31 January 2009, 20:23 GMT
_
Comment by Ionut Biru (wonder) - Sunday, 01 February 2009, 00:50 GMT
i confirm that after upgrading to:

[2009-02-01 02:45] upgraded bluez (4.25-2 -> 4.27-1)
[2009-02-01 02:45] upgraded obex-data-server (0.3.4-1 -> 0.4.2-1)
Comment by Blazej (blasse) - Sunday, 01 February 2009, 09:20 GMT
ps. I'm on x86_64 too. I hae compiled this pkg's using abs from arch pkgbuilds.
Comment by Blazej (blasse) - Wednesday, 11 February 2009, 19:46 GMT
Bluetooth works fine WITHOUT bluez-gnome, but with blueman 1.0. Need rebuilded obez-data-server (it WON'T work with -use-system-config). Browsing bluetooth device is not working - need patched gvfs. Maybe we should switch from bluez-gnome to blueman?
Comment by Ionut Biru (wonder) - Wednesday, 11 February 2009, 19:56 GMT
switching is not a solution. blueman is an alternative to bluez
Comment by Blazej (blasse) - Wednesday, 11 February 2009, 20:28 GMT
blueman is an alternative to bluez-gnome. But it still uses bluez as a backend. It's just gtk bluetooth manager, like bluez-gnome. So it IS an option for working bluetooth in Arch. The question is: do we need working bluez-gnome, or do we need working bluetooth.
Comment by warriant (warriant) - Wednesday, 11 February 2009, 20:36 GMT
_
Comment by Blazej (blasse) - Friday, 13 February 2009, 17:11 GMT
NOT fixed. After last update still canto recive files via bluetooth with gnome-bluetooth installed, any sending try gives "Launcher helper exited with unknown return code 127" error.

Loading...