Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#10442 - No wireless with kernel 2.6.25 and Thinkpad T61's Intel 4965n wireless device

Attached to Project: Arch Linux
Opened by Christian (Back2Cali) - Sunday, 18 May 2008, 09:44 GMT
Last edited by Aaron Griffin (phrakture) - Thursday, 20 November 2008, 20:12 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Thomas Bächler (brain0)
Architecture x86_64
Severity High
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

After checking on kernel 2.6.25 my network card on an Lenovo Thinkpad T61, an intel wireless 4965n, won't work any longer. I used knetworkmanager and netcfg2 to check and I can establish a conection to my wireless network. But after that I cannot send or receive any data. Also a ping to my router ends in the Destination host not found message. I checked with an live CD containing the previeous kernel 2.6.24 and it worked again. So it's not a hardware problem. I also checked with the compat-wireless package from AUR and the same thing happens. Also with a different kernel patchset from AUR (kernel26tp) it didn't work. It seems like some people having the same wireless device don't have trouble with the new kernel. I did a fresh install and the problem existed right away. So it's also not a wrong config problem, since there's not much to configure for (k)networkmanager. Also everything is up to date, so it's also not problem of an outdated package or anything like that.
This task depends upon

Closed by  Aaron Griffin (phrakture)
Thursday, 20 November 2008, 20:12 GMT
Reason for closing:  None
Additional comments about closing:  New kernel is out, no longer an issue
Comment by Thomas Bächler (brain0) - Sunday, 18 May 2008, 16:25 GMT
Can you give us some dmesg output and possibly other logs and system info? I have no idea where to start here.
Comment by Christian (Back2Cali) - Monday, 19 May 2008, 15:00 GMT
Sorry for the little delay on it. I attached the dmesg output here. What other logs and system infos do you need? Let me know and I'll post them asap! Thanks!
   dmesg.txt (31.2 KiB)
Comment by Thomas Bächler (brain0) - Monday, 19 May 2008, 17:05 GMT
Thanks.

Because this is only an issue for few people, I will move kernel26 to core anyway today or tomorrow. Make sure to put kernel26 in NoUpgrade or keep a copy of the old kernel/module packages until we sort this out.
Comment by Thomas Bächler (brain0) - Monday, 19 May 2008, 17:17 GMT
Everything seems to be fine:

wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:1c:4a:44:eb:9f
wlan0: RX authentication from 00:1c:4a:44:eb:9f (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:1c:4a:44:eb:9f
wlan0: RX AssocResp from 00:1c:4a:44:eb:9f (capab=0x431 status=0 aid=1)
wlan0: associated
wlan0: switched to short barker preamble (BSSID=00:1c:4a:44:eb:9f)
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
wlan0 (WE) : Wireless Event too big (366)

It looks like you are associated. I have no idea what that last message means, did that also appear with 2.6.24?

Could you try compiling wireless-compat for 2.6.24 and see if that also breaks?

Furthermore, a new compat-wireless package has finally been released, I am trying to build it now, I will probably upload it to http://dev.archlinux.org/~thomas/compat-wireless/ later.
Comment by Christian (Back2Cali) - Monday, 19 May 2008, 17:52 GMT
Well the thing is that it associates and after that no data can be sent or received.
I will check on dmesg using a kubuntu live CD with 2.6.24 kernel and let you know if the same message wit the too big wireless event happens.
But main problem is that I can be associated but no data goes through the device. Pings resulting in destination host not found messages. Are there other information you would need in order to figure out what is wrong? Let me know!


Thanks again for the help!
Comment by Thomas Bächler (brain0) - Monday, 19 May 2008, 18:09 GMT
Could you try with this package and the latest 2.6.25.4 from testing? http://dev.archlinux.org/~thomas/compat-wireless/compat-wireless-2008_05_19-1-x86_64.pkg.tar.gz

You don't have to boot to find the old dmesg output. Just look in /var/log/kernel.log (or kernel.log.1,.2 and so on) and find a session that you booted with 2.6.24 (for example by grepping for 2.6.24), then scroll down and look for the wireless messages.
Comment by Christian (Back2Cali) - Monday, 19 May 2008, 19:26 GMT
Could you send me the PKGBUILD? I need to compile it for kernel26tp which I'm currently running on my Thinkpad. It acts the same way with the wireless so no included patch caused that behavior. Or can I find the PKGBUILD for that version somewhere? Thanks!
Comment by Thomas Bächler (brain0) - Monday, 19 May 2008, 21:23 GMT Comment by Christian (Back2Cali) - Tuesday, 20 May 2008, 08:22 GMT
I had to compile today's version since the sources for yesterday were no longer available. I installed the package but now when I'm loading the module I get the following message:

FATAL: Error inserting iwl4965 (/lib/modules/2.6.25-tp/kernel/drivers/net/wireless/iwlwifi/iwl4965.ko): Unknown symbol in module, or unknown parameter (see dmesg)

Looking at the dmesg output I'll get:

iwl4965: Unknown symbol sta_info_put
iwl4965: Unknown symbol ieee80211_register_hwmode

So the compat wireless drivers won't work at the moment...

I'll start with an kubuntu live cd and let you know the dmesg output for 2.6.24 Kernel which was the last one working for me.
Comment by Christian (Back2Cali) - Tuesday, 20 May 2008, 08:33 GMT
OK, the file attached shows what I get from dmesg when running a kubuntu live CD and connecting to a wireless network. So there is now message about a to big wireless event...
   dmesg.txt (37.5 KiB)
Comment by Thomas Bächler (brain0) - Tuesday, 20 May 2008, 09:37 GMT
That might be a hint.

For compat-wireless, note that you must also unload mac80211 and cfg80211 before loading the new iwl4965 module (or reboot completely if you want it simple).
Comment by Christian (Back2Cali) - Tuesday, 20 May 2008, 10:54 GMT
Already unloaded them the first time and did get those messages. Also after a reboot...
I found the previous source releases back to the 17th of may and they all did drop the exact same message up to the most recent release.
Comment by Christian (Back2Cali) - Saturday, 24 May 2008, 16:01 GMT
I have found out something more about the wireless issue. It seems that the cause of the connection problem is based on the combination iwl4965 and a wpa secured network. Today I entered a wep protected wireless network which worked as it did with wpa connections. I was connected and did take a look on a website. And the website was opened (after a little while of connection, but that seemed to be an issue with the internet provider).
So it seems to be also an issue with the new iwl4965 driver version and wpa. It worked before so I guess the new versions have some sort of incompatibility. What do you think?
I also compiled todays compat-wireless version but when connecting to a wireless network the system freezes immediately. Seems like a kernel crash since the shiftlock led started blinking.

Maybe the wpa issue is a hint where to find the problem? Thanks!
Comment by Philip Stark (Heller_Barde) - Monday, 26 May 2008, 08:52 GMT
I have the same problem. I just upgraded the package today and I can't even get the interface up.
"ifconfig wlan0 up" will return an error, something with SCIOFFLAGS
I already downgraded again, because I need my connection today, I will report on the output and other important logs later this day (meaning in the next 8 hours, I live in switzerland)
What can I do further to help?
Cheers and thanks for the help
Comment by jonas enge (cybe-arch) - Monday, 26 May 2008, 14:30 GMT
I have Lenovo T61p and 4965n - The only change i noticed, is that earlier i only had to do;
iwconfig wlan0 essid <essid>
.. to connect, now i have to define to AP to
iwconfig wlan0 essid <essid> ap <ap>
Comment by Christian (Back2Cali) - Monday, 26 May 2008, 15:18 GMT
An interesting thing happened over here today when I was checking on the new version of compat-wireless(-tp).
The current version in AUR did cause my system to crash so I installed todays version (May 26th). After compiling and installing (and of cause reloading the required modules) I'm now able to connect WEP and WPA protected wireless networks. I have to check on my university network (which is unsecured but needs (k)vpnc to run; btw. does anybody know when vpnc will be integrated into knetworkmanager from AUR) tomorrow to see if that works also.
What I did before, just to mention that if that did something good, was that I went to the /lib/firmware folder and exchanged the two firmware files with each other. After I did that I got an error that the firmware could not be loaded so I redid the renaming and the firmware could be loaded again. After that I checked on the compat-wireless drivers like described and it worked. I don't know if the renaming of the firmware had anything to do with it at all but this is exactly what I've done and now it works.
Comment by Thomas Bächler (brain0) - Monday, 26 May 2008, 15:26 GMT
The firmware without the -1 is an older API version which was necessary for very old iwl versions. Since we had old and new versions in parallel, I included both firmware files. I guess the old one can be deleted by now.
Comment by Dennis Brendel (buddabrod) - Thursday, 29 May 2008, 12:14 GMT
Thomas, could it be because of the 4965 agN chips, mine has n deactivated. I think it's that new HT feature, since the n stuff is the only difference i know of. Disabling it might be worth a try.
Comment by Dennis Brendel (buddabrod) - Thursday, 29 May 2008, 12:16 GMT
To make that clear: it works perfectly here with my 4965ag in my Thinkpad T61, that's why i think it's the n feature.
Comment by Philip Stark (Heller_Barde) - Thursday, 29 May 2008, 13:33 GMT
How would I go about disabling the N feature? I'd like to help and solve this problem
cheers Phil
Comment by Dennis Brendel (buddabrod) - Thursday, 29 May 2008, 13:40 GMT
Get the kernel PKGBUILD (with abs for example), disable CONFIG_IWL4965_HT=y in the .config and recompile it ;)
Comment by Philip Stark (Heller_Barde) - Thursday, 29 May 2008, 16:59 GMT
compiling... I'll report back soon (I hope) Phil
Comment by Philip Stark (Heller_Barde) - Thursday, 29 May 2008, 18:32 GMT
It didn't work. Although I have to say, I don't have a Lenovo, I have a HP Compaq 2510p but the chipset is the same... afaik.
i still get the "siocsifflags" error
Comment by Mr. Morph (morphis) - Tuesday, 03 June 2008, 06:48 GMT
I have the same problem with the current kernel26 that my broadcom card will not run. It connects to the wireless network but I can not contact anybody, get no response. With the kernel26-2.6.24-ARCH I have no problems with the wireless connection. Later I will restart my Laptop and post the dmesg output.
Comment by Thomas Bächler (brain0) - Tuesday, 03 June 2008, 08:49 GMT
morphis, open a separate bug report!
Comment by marcello perathoner (marcello) - Friday, 04 July 2008, 16:00 GMT
I'm having the same problem on a debian Thinkpad T61. Started after upgrading to 2.6.25 from 2.6.24.

Initially the wlan connects to the access point but no data transfer is possible. After running ping for a minute or so, it suddenly starts working. Every 10 minutes or so it hiccups, ie. the link goes dead for about a minute, then starts working again:

64 bytes from 192.168.178.1: icmp_seq=4730 ttl=64 time=16.9 ms
From 192.168.178.21 icmp_seq=4762 Destination Host Unreachable
From 192.168.178.21 icmp_seq=4763 Destination Host Unreachable
From 192.168.178.21 icmp_seq=4764 Destination Host Unreachable
From 192.168.178.21 icmp_seq=4766 Destination Host Unreachable
From 192.168.178.21 icmp_seq=4767 Destination Host Unreachable
From 192.168.178.21 icmp_seq=4768 Destination Host Unreachable
From 192.168.178.21 icmp_seq=4770 Destination Host Unreachable
From 192.168.178.21 icmp_seq=4771 Destination Host Unreachable
From 192.168.178.21 icmp_seq=4772 Destination Host Unreachable
From 192.168.178.21 icmp_seq=4774 Destination Host Unreachable
From 192.168.178.21 icmp_seq=4775 Destination Host Unreachable
From 192.168.178.21 icmp_seq=4776 Destination Host Unreachable
64 bytes from 192.168.178.1: icmp_seq=4731 ttl=64 time=47411 ms
64 bytes from 192.168.178.1: icmp_seq=4732 ttl=64 time=46411 ms
64 bytes from 192.168.178.1: icmp_seq=4733 ttl=64 time=45411 ms
64 bytes from 192.168.178.1: icmp_seq=4734 ttl=64 time=44407 ms
64 bytes from 192.168.178.1: icmp_seq=4735 ttl=64 time=43395 ms
64 bytes from 192.168.178.1: icmp_seq=4736 ttl=64 time=42394 ms
64 bytes from 192.168.178.1: icmp_seq=4737 ttl=64 time=41395 ms
64 bytes from 192.168.178.1: icmp_seq=4738 ttl=64 time=40395 ms
64 bytes from 192.168.178.1: icmp_seq=4739 ttl=64 time=39395 ms
64 bytes from 192.168.178.1: icmp_seq=4740 ttl=64 time=38395 ms
64 bytes from 192.168.178.1: icmp_seq=4741 ttl=64 time=37395 ms
64 bytes from 192.168.178.1: icmp_seq=4742 ttl=64 time=36395 ms
64 bytes from 192.168.178.1: icmp_seq=4743 ttl=64 time=35391 ms
64 bytes from 192.168.178.1: icmp_seq=4744 ttl=64 time=34379 ms
64 bytes from 192.168.178.1: icmp_seq=4745 ttl=64 time=33379 ms
64 bytes from 192.168.178.1: icmp_seq=4746 ttl=64 time=32379 ms
64 bytes from 192.168.178.1: icmp_seq=4747 ttl=64 time=31379 ms
64 bytes from 192.168.178.1: icmp_seq=4748 ttl=64 time=30378 ms
64 bytes from 192.168.178.1: icmp_seq=4749 ttl=64 time=29379 ms
64 bytes from 192.168.178.1: icmp_seq=4750 ttl=64 time=28379 ms
64 bytes from 192.168.178.1: icmp_seq=4751 ttl=64 time=27380 ms
64 bytes from 192.168.178.1: icmp_seq=4752 ttl=64 time=26380 ms
64 bytes from 192.168.178.1: icmp_seq=4753 ttl=64 time=25380 ms
64 bytes from 192.168.178.1: icmp_seq=4754 ttl=64 time=24380 ms
64 bytes from 192.168.178.1: icmp_seq=4755 ttl=64 time=23380 ms
64 bytes from 192.168.178.1: icmp_seq=4756 ttl=64 time=22380 ms
64 bytes from 192.168.178.1: icmp_seq=4757 ttl=64 time=21380 ms
64 bytes from 192.168.178.1: icmp_seq=4758 ttl=64 time=20380 ms
64 bytes from 192.168.178.1: icmp_seq=4759 ttl=64 time=19380 ms
64 bytes from 192.168.178.1: icmp_seq=4760 ttl=64 time=18380 ms
64 bytes from 192.168.178.1: icmp_seq=4777 ttl=64 time=1368 ms
64 bytes from 192.168.178.1: icmp_seq=4778 ttl=64 time=372 ms
64 bytes from 192.168.178.1: icmp_seq=4779 ttl=64 time=1.16 ms

I'm using no NetworkManager, just calling wpa_supplicant from /etc/network/interfaces the debian way. Connection is encrypted with WPA2.

I get the message about too big a wireless event too, but I get that also on 2.6.24 and it never prevented the wlan to run.

# lspci
03:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN Network Connection (rev 61)
# dmesg | grep iwl
[ 8.493448] iwl4965: Intel(R) Wireless WiFi Link 4965AGN driver for Linux, 1.2.23ks
[ 8.493593] iwl4965: Copyright(c) 2003-2007 Intel Corporation
[ 8.494012] iwl4965: Detected Intel Wireless WiFi Link 4965AGN
[ 8.544893] iwl4965: Tunable channels: 13 802.11bg, 19 802.11a channels
[ 8.546289] phy0: Selected rate control algorithm 'iwl-4965-rs'
# uname -a
Linux fool 2.6.25-2-amd64 #1 SMP Fri Jun 27 00:16:12 UTC 2008 x86_64 GNU/Linux
Comment by marcello perathoner (marcello) - Friday, 04 July 2008, 23:10 GMT
Update: actually the hiccups happen *exactly* every 10 minutes. And wpa_supplicant seems to generate a new key immediately before things stop working for about one minute.
Comment by Jonathan Nazario (hyperplus) - Saturday, 26 July 2008, 16:50 GMT
Thanks for you help!

I had exactly the same issues described here. With FC9 release version my wireless + wpa worked, but after updating the system the "Wireless Event too big" issue started appearing.

I am new to Linux and didn't know about the compat-wireless, but installing the latest version (compat-wireless-2.6) fix the iw4965n + wpa issue for me. Hopefully works for everyone else.

I just followed this instructions in the compat-wireless site:
http://linuxwireless.org/en/users/Download#Buildingandinstalling

======================================
Configuration:
======================================
Dell M1330 XPS with Fedora Core 9 (FC9)

[root@localhost sbin]# uname -r
2.6.25.11-97.fc9.x86_64

[root@localhost sbin]# lspci | grep -i Network
0c:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN Network Connection (rev 61)

[root@localhost sbin]# iwconfig wlan0
wlan0 IEEE 802.11abgn ESSID:"<...myssid...>"
Mode:Managed Frequency:2.462 GHz Access Point: 00:1C:F0:F7:65:0B
Bit Rate=48 Mb/s Tx-Power=14 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Encryption key:<...my_encryption_key...> [2] Security mode:open
Power Management:off
Link Quality=100/100 Signal level:-53 dBm Noise level=-95 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

[root@localhost sbin]# iwlist wlan0 scan
Cell 07 - Address: 00:1C:F0:F7:65:0B
ESSID:"<...myssid...>"
Mode:Master
Channel:11
Frequency:2.462 GHz (Channel 11)
Quality=100/100 Signal level:-50 dBm Noise level=-96 dBm
Encryption key:on
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : TKIP CCMP
Authentication Suites (1) : PSK
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : TKIP CCMP
Authentication Suites (1) : PSK
IE: Unknown: 2D1A4E101FFFFF000000000000000000000000000004000000000000
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:tsf=0000010fc9f8f390
Extra: Last beacon: 4ms ago
Comment by ponto (ponto) - Tuesday, 02 September 2008, 21:32 GMT
this happens with me too, not exactly the same. but the same.

i am using wpa2, with a 4965.
root ~ # lspci | grep -i Network
02:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN Network Connection (rev 61)

the last kernel:
root ~ # pacman -Q kernel26
kernel26 2.6.26.3-1

and i've always use compat-wireless.

the "wlan0 (WE) : Wireless Event too big (366)" message makes appearance too.

and yes, as marcello perathoner (marcello) said, "Initially the wlan connects to the access point but no data transfer is possible. After running ping for a minute or so, it suddenly starts working. Every 10 minutes or so it hiccups, ie. the link goes dead for about a minute", but the ten minutes thing is not usually ten minutes, but near.

this started to happen, and here's what's different from other, when my router firmware was upgraded to the last version. i had the first one, and the first firmware is not available on linksys' website, but all the others upgrades yes. i've tried to install others, but this didn't resolve anything.

i've tried to connect with other computers, and no problem. just with this one.

does anyone knows how to resolve this?

ps: i've seen this:
commit 087d833e5a9f67ba933cb32eaf5a2279c1a5b47c
Author: Jouni Malinen <jouni.malinen@atheros.com>
Date: Tue Aug 19 10:54:32 2008 +0300

mac80211: Use IWEVASSOCREQIE instead of IWEVCUSTOM

The previous code was using IWEVCUSTOM to report IEs from AssocReq and
AssocResp frames into user space. This can easily hit the 256 byte
limit (IW_CUSTOM_MAX) with APs that include number of vendor IEs in
AssocResp. This results in the event message not being sent and dmesg
showing "wlan0 (WE) : Wireless Event too big (366)" type of errors.

Convert mac80211 to use IWEVASSOCREQIE/IWEVASSOCRESPIE to avoid the
issue of being unable to send association IEs as wireless events. These
newer event types use binary encoding and larger maximum size
(IW_GENERIC_IE_MAX = 1024), so the likelyhood of not being able to send
the IEs is much smaller than with IWEVCUSTOM. As an extra benefit, the
code is also quite a bit simpler since there is no need to allocate an
extra buffer for hex encoding.

Signed-off-by: Jouni Malinen <jouni.malinen@atheros.com>
Signed-off-by: John W. Linville <linville@tuxdriver.com>

on http://www.kernel.org/pub/linux/kernel/v2.6/testing/ChangeLog-2.6.27-rc5 , is this a kernel bug?


Comment by marcello perathoner (marcello) - Tuesday, 02 September 2008, 22:19 GMT
@ponto

The bug happens only if my AP is configured for draft n. If you are admin of the AP you may try to disable draft n.

In 2.6.27-rc? you can also load the iwlagn module with option 11n_disable, which makes it work too.
Comment by ponto (ponto) - Tuesday, 02 September 2008, 22:40 GMT
i've unistalled compat-wireless, and tried iwlwifi-4965-ucode(228.57.2.21-1).
the first minute thing still happens, but after that the connection appears to be solid. well, maybe his a litle bit to early to say that, but i am connect with no problems (except the initial one minute thing) for about one hour.

yes, my router has draft n. i may try to disable it (i don't know how to do it, i've never did that before lol). thanks : >

i am not using 2.6.27-rc.
Comment by ponto (ponto) - Tuesday, 02 September 2008, 23:25 GMT
ok, i've disable n on my router. is running on 20MHz channel already, and it's still the same, the same said on my last comment.

do you use compat-wireless? later, maybe i can give it a try with compat-wireless. but now i will see if the connect does not drop.
Comment by Jonathan Nazario (hyperplus) - Wednesday, 03 September 2008, 15:54 GMT
Why don't you try exactly wht I did? I just installed the compat-wireless following the instructions from the link below. I have an AP running N even though I am still connecting to G. (Haven't check get if is possible to connect N)...

http://linuxwireless.org/en/users/Download#Buildingandinstalling
Comment by ponto (ponto) - Sunday, 19 October 2008, 17:00 GMT
the roll back solution stopped to work on kernel 2.6.27 'cause an error occurs when loading the ucode. i tried the newer ucode again, and the kernel panics continue. but this time, with this kernel, that take longer to happen.

is there any solution?

using compat-wireless didn't solve anything.
Comment by ponto (ponto) - Sunday, 19 October 2008, 23:40 GMT
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/272015 this bug report seems to be from the same bug
Comment by ponto (ponto) - Sunday, 19 October 2008, 23:41 GMT
ups, last comments don't belong in this bug report : x

Loading...