Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#10033 - Bluetooth OBEX start failed: Invalid path

Attached to Project: Arch Linux
Opened by mark (sickhate) - Sunday, 30 March 2008, 21:15 GMT
Last edited by Geoffroy Carrier (gcarrier) - Thursday, 12 February 2009, 09:05 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Thomas Bächler (brain0)
Roman Kyrylych (Romashka)
Geoffroy Carrier (gcarrier)
Architecture All
Severity Low
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
Both my mobile and laptop are able to 'see' each other as you can see below.
But both them can link each other just for 2 or 3 seconds then loss the link.
I can not sent photos from mobile to laptop, conversely, I can sent files from laptop to mobile.

Why? And Help needed.

Thanks a lot.

[zhangjing@Archlinux007 ~]$ pacman -Q | grep blue
blueman 0.3-3
bluez-gnome 0.25-1
bluez-libs 3.28-1
bluez-utils 3.28-1
gnome-bluetooth 0.11.0-1.1
python-pybluez 0.14-2


[zhangjing@Archlinux007 ~]$ pacman -Q | grep obe
obex-data-server 0.3-3
openobex 1.3-2


[zhangjing@Archlinux007 ~]$ sudo /etc/rc.d/bluetooth restart
:: Stopping bluetooth subsystem: pand dund rfcomm hidd sdpd hcid [DONE]
:: Starting bluetooth subsystem: hcid hidd [DONE]

[zhangjing@Archlinux007 ~]$ lsmod | grep -i blue
bluetooth 51172 9 hidp,bnep,rfcomm,hci_usb,l2cap


[zhangjing@Archlinux007 ~]$ dmesg | grep -i blue
Bluetooth: Core ver 2.11
Bluetooth: HCI device and connection manager initialized
Bluetooth: HCI socket layer initialized
Bluetooth: L2CAP ver 2.9
Bluetooth: L2CAP socket layer initialized
Bluetooth: HCI USB driver ver 2.9
Bluetooth: RFCOMM socket layer initialized
Bluetooth: RFCOMM TTY layer initialized
Bluetooth: RFCOMM ver 1.8
Bluetooth: BNEP (Ethernet Emulation) ver 1.2
Bluetooth: HIDP (Human Interface Emulation) ver 1.2


[zhangjing@Archlinux007 ~]$ bluetooth-applet
Bluetooth OBEX start failed: Invalid path
Bluetooth FTP start failed: Invalid path


[zhangjing@Archlinux007 ~]$ hcitool dev
Devices:
hci0 00:11:B1:07:A3:62


[zhangjing@Archlinux007 ~]$ hcitool scan
Scanning ...
00:11:9F:84:F5:78 Nokia6260

Steps to reproduce:
I can not sent photos from mobile to laptop, conversely, I can sent files from laptop to mobile.
This task depends upon

Closed by  Geoffroy Carrier (gcarrier)
Thursday, 12 February 2009, 09:05 GMT
Reason for closing:  Fixed
Comment by Thomas Bächler (brain0) - Sunday, 06 April 2008, 10:13 GMT
Excuse me, is there a bug here? Isn't that a case for the forums?
Comment by Roman Kyrylych (Romashka) - Sunday, 06 April 2008, 10:24 GMT
oops, sorry, Thomas, I was too quick because it's just one of 100 reports I've edited today
Comment by Giorgio Lando (patroclo7) - Thursday, 01 May 2008, 16:43 GMT
The bug seems to me to be in the bluetooth-applet behaviour: what's that "Invalid path" of obex and ftp? Probaby it is looking for the path where the executables were in previous versions of the core bluetooth packages.
Comment by Priyank M. Gosalia (priyank) - Thursday, 08 May 2008, 15:29 GMT
[zhangjing@Archlinux007 ~]$ bluetooth-applet
Bluetooth OBEX start failed: Invalid path
Bluetooth FTP start failed: Invalid path

That's where the problem is. I looked at the source code of bluetooth-applet and found that it uses the values of XDG_DOWNLOAD_DIRECTORY and XDG_PUBLICSHARE_DIR in order to start the File Recieve service (OBEX) and the FTP service respectively. But it doesn't check to see if these directories are not set. I've attached a patch (for bluetooth-applet) which will set these directories to /home/user/Desktop for OBEX and /home/user/ for FTP. This will allow bluetooth-applet to start the file receiving service. (Tested and it works for me)
Comment by Priyank M. Gosalia (priyank) - Thursday, 08 May 2008, 15:31 GMT
Alternatively, in order to be able to recieve files, you may even use gnome-obex-server (provided by gnome-bluetooth). Just run gnome-obex-server and your computer should be able to recieve files.
Comment by mark (sickhate) - Thursday, 08 May 2008, 19:14 GMT
that doesnt work for me...
i get this
conn_request: bdaddr 00:18:8D:42:20:EF
conn_complete: status 0x00
Comment by Priyank M. Gosalia (priyank) - Friday, 09 May 2008, 15:14 GMT
Well, then try bluetooth-applet with the patch.
Comment by Alessio Bianchi (Venator85) - Sunday, 11 May 2008, 22:11 GMT
I tried to recompile the bluez-gnome with the attached patch, that corrected the 'invalid path' message but I still get the 'conn_complete: status 0x00' message. Any hints?
Comment by Alessio Bianchi (Venator85) - Wednesday, 21 May 2008, 10:24 GMT
Any news on the 'conn_complete: status 0x00' bug?
Should I open a new bug ticket?
Bye ;)
Comment by mark (sickhate) - Wednesday, 21 May 2008, 16:13 GMT
still nothing on this one...obex data server still not updated..soo..i guess its just to wait...
Comment by Alessio Bianchi (Venator85) - Wednesday, 21 May 2008, 17:22 GMT
I attached the updated PKGBUILDs for the following packages:
obex-data-server 0.3.1
bluez-gnome 0.26
bluez-libs 3.32
bluez-utils 3.32
This way I'm able to send and receive files from phones to PC and vice-versa.
Cheers ;)
Comment by Jud (judfilm) - Friday, 05 December 2008, 12:19 GMT
There will be a new Bluetooth Maintainer soon.
Comment by Giorgio Lando (patroclo7) - Friday, 05 December 2008, 13:09 GMT
Good news! The bluetooth stuff is often in a bad condition (only seldom - say - bluez, the gnome stuff, obexftp and blueman work nicely together), so I hope that the new maintainer improves this situation

Loading...