Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#9995 - System won't update due to missing graphiz-package

Attached to Project: Arch Linux
Opened by Timm (gummibaerchen) - Friday, 28 March 2008, 15:16 GMT
Last edited by Pierre Schmitz (Pierre) - Saturday, 29 March 2008, 15:29 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Today my daily "pacman -Syu" refused to upgrade due to a missing graphiz package.

Somehow Anjuta 2.4 (from testing)requires graphiz >= 2.18, but I can't find that package anywhere.

Even Anjuta 2.2 needed graphiz, but that is not in the repos.

So what package does/did actually graphiz?
This task depends upon

Closed by  Pierre Schmitz (Pierre)
Saturday, 29 March 2008, 15:29 GMT
Reason for closing:  Not a bug
Comment by Pierre Schmitz (Pierre) - Friday, 28 March 2008, 15:28 GMT
The package is called graphviz and not graphiz.
Comment by Jan de Groot (JGC) - Friday, 28 March 2008, 17:47 GMT
The graphviz package is in testing and has the right version. Do you use the testing repository below the extra repository? I don't know how pacman handles this, but the version in extra has a force flag set, which forces downgrade to 2.16 when trying to upgrade. I don't know if a versioned dependency can overrule that flag, I guess not.
Comment by Timm (gummibaerchen) - Saturday, 29 March 2008, 14:57 GMT
No, force will allways install, even over "higher" version, that's what it's for I guess.

Sorry, I think Pierre is right, it all boils down, to a typo.

Installing graphviz fixed the issue, sorry for any inconvenience.

Loading...