Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#9988 - missing dependency for graphviz

Attached to Project: Arch Linux
Opened by Francois Charette (Firmicus) - Thursday, 27 March 2008, 22:10 GMT
Last edited by Jan de Groot (JGC) - Thursday, 27 March 2008, 23:43 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

graphviz 2.18.1 requires librsvg>=2.22.2, but the version in extra is 2.20, so update fails.


pacman -Syu
<...>
resolving dependencies...
error: cannot resolve "librsvg>=2.22.2", a dependency of "graphviz"
error: failed to prepare transaction (could not satisfy dependencies)
:: graphviz: requires librsvg>=2.22.2


This task depends upon

Closed by  Jan de Groot (JGC)
Thursday, 27 March 2008, 23:43 GMT
Reason for closing:  Fixed
Additional comments about closing:  Reverted to the old version a few hours ago.
Comment by Tomek ZdybaƂ (tomekzet) - Thursday, 27 March 2008, 22:34 GMT
http://archlinux.org/packages/search/?q=graphviz
shows, that extra contains graphviz-2.16.1-3, which doesn't require any version of libsrvg.

After synchronizing package database, I found /var/lib/pacman/sync/extra/graphviz-2.18-1 in my filesystem, so I think it's wrong package in extra.

I'm using ftp://ftp.hosteurope.de/mirror/ftp.archlinux.org/$repo/os/i686 mirror.

Loading...