Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#9987 - KDE themes disappear after Qt3 update.

Attached to Project: Arch Linux
Opened by Ondřej Konečný (andrew9888) - Thursday, 27 March 2008, 19:12 GMT
Last edited by Pierre Schmitz (Pierre) - Wednesday, 02 April 2008, 10:38 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture i686
Severity High
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
After Qt3 upgrade (3.3.8-6.1 -> 3.3.8-7) have all KDE3 themes diappeared from the theme list in kcontrol. Only the builtin ones remained.

Additional info:
A piece from pacman.log:
[2008-03-27 17:50] synchronizing package lists
[2008-03-27 17:50] starting full system upgrade
[2008-03-27 18:04] upgraded alsa-lib (1.0.15-1 -> 1.0.16-1)
[2008-03-27 18:04] upgraded alsa-utils (1.0.15-2 -> 1.0.16-1)
[2008-03-27 18:04] NOTE:
[2008-03-27 18:04] This package has been built with java support.
[2008-03-27 18:04] If you want java features for runtime, you can either use:
[2008-03-27 18:04] 1. Sun's JRE.
[2008-03-27 18:04] 2. Java-gcj-compat and gcc-gcj.
[2008-03-27 18:04] you will need it for "help" section and some java based wizards
[2008-03-27 18:04] for further reading: http://wiki.services.openoffice.org/wiki/Java_and_OpenOffice.org
[2008-03-27 18:04]
[2008-03-27 18:04] The en_US spellchecker is no longer included. A separate pkg is now
[2008-03-27 18:04] available. Use "pacman -S openoffice-spell-en" to install it.
[2008-03-27 18:04]
[2008-03-27 18:04] use "export OOO_FORCE_DESKTOP=kde" or
[2008-03-27 18:04] use "export OOO_FORCE_DESKTOP=gnome" to preset your desired look,
[2008-03-27 18:04] or put it in /etc/profile, rc.local, or ~/.bashrc.
[2008-03-27 18:04] upgraded openoffice-base (2.3.1-2 -> 2.4.0-1)
[2008-03-27 18:04] upgraded qt3 (3.3.8-6.1 -> 3.3.8-7)
[2008-03-27 18:04] upgraded qtcurve-gtk2 (0.57.1-1 -> 0.58.0-1)
[2008-03-27 18:04] upgraded qtcurve-kde3 (0.57.1-1 -> 0.58.0-1)
[2008-03-27 18:04] upgraded qtcurve-kde4 (0.57.1-1 -> 0.58.0-1)
[2008-03-27 18:04] upgraded sqlite3 (3.5.6-1 -> 3.5.7-1)

* package version(s)
KDE - 3.5.9 (latest package)
qt3 - 3.3.8-7

Steps to reproduce:
Try the upgrade of Qt3.
This task depends upon

Closed by  Pierre Schmitz (Pierre)
Wednesday, 02 April 2008, 10:38 GMT
Reason for closing:  Not a bug
Comment by Neil Darlow (neildarlow) - Thursday, 27 March 2008, 19:20 GMT
This happens also for the Qt theme Polymer. Deleting ~/.qt and executing /opt/qt/bin/qtconfig gives:

[neil@aurora ~]$ rm -Rf .qt
[neil@aurora ~]$ /opt/qt/bin/qtconfig
Conflict in /opt/qt/plugins/styles/polymer.so:
Plugin uses incompatible Qt library!
expected build key "i686 Linux g++-3.* full-config", got "i686 Linux g++-4 full-config".
Comment by Ondřej Konečný (andrew9888) - Thursday, 27 March 2008, 19:51 GMT
While I was trying to recompile Domino to get it working again I got an error message saying that the theme can be loaded only by the version of qt for which the theme is built compiled with the same compiler (sorry I don't paste the entire message, but I've lost it). So i tried downgrading the qt3 package back to 3.5.6-1 and voila! Themes are working again.
Comment by Neil Darlow (neildarlow) - Thursday, 27 March 2008, 20:42 GMT
I just rebuilt polymer against the updated Qt package and it works again.
Comment by Attila (attila) - Thursday, 27 March 2008, 20:52 GMT
I recompiled my kde themes too which works for qinx, qtcurve and serenity but not for comix. Not so much bad in handling it but this is a little bit strange because both, qt and kdelibs, seems only to be rebuilt for other reasons without changes inside.
Comment by crc32 (crc64) - Thursday, 27 March 2008, 21:45 GMT
Pitching in a me too here. My KDE3 themes disappeared after upgrading qt3 and kdelib.

Downgrading qt3 (3.3.8-7 -> 3.3.8-6.1) and kdelib (3.5.9-2 ->3.5.9-1) back to previous versions worked for me.
Comment by Pierre Schmitz (Pierre) - Thursday, 27 March 2008, 21:54 GMT
Just make sure you have kdelibs 3.5.9-2, qt3 3.3.8-7 [and qtcurve-kde3 0.58.0-2] installed. Those should work with each other. This problems seems to be an ABI incompatibility by gcc 4.3. If you use any custom theme, just recompile them.
Comment by crc32 (crc64) - Thursday, 27 March 2008, 22:10 GMT
Sorry if I'm wrong to re-open this bug.
But I think gtk-qt-engine needs to be rebuilt too.
Comment by Matthias Dienstbier (fs4000) - Thursday, 27 March 2008, 22:46 GMT
I don't have any problems with it.
Comment by Ondřej Konečný (andrew9888) - Sunday, 30 March 2008, 14:33 GMT
After kdelibs upgrade I was able to recompile my themes and got them working again. So the bug is solved for me.
Comment by crc32 (crc64) - Wednesday, 02 April 2008, 10:26 GMT
Yes, sorry my bad. There's no problem with gtk-qt-engine. It was one of the themes that need to be rebuilt.

I was the one who requested to reopen this bug. So, please close this bug if there isn't any other issues.

Loading...