Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#9984 - gcc freezes on building some packages

Attached to Project: Arch Linux
Opened by Michael Holub (mholub) - Thursday, 27 March 2008, 15:21 GMT
Last edited by Jan de Groot (JGC) - Friday, 28 March 2008, 08:11 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
gcc 4.3.0 from current core freezes when building ruby1.9 and gcc-devel from AUR.

I tried to build ruby1.9 (see http://aur.archlinux.org/packages.php?ID=14402), but gcc freezes on file parse.c. I hoped, that some bug in gcc was fixed in gcc-devel version and tried to build it from AUR with current gcc. But it froze too.

Additional info:
* package version(s)
[mholub@mumu Desktop]$ gcc -v
Using built-in specs.
Target: i686-pc-linux-gnu
Configured with: ../configure --prefix=/usr --enable-shared --enable-languages=c,c++,fortran,objc,obj-c++,treelang --enable-threads=posix --mandir=/usr/share/man --enable-__cxa_atexit --disable-multilib --libdir=/usr/lib --libexecdir=/usr/lib --enable-clocale=gnu --disable-libstdcxx-pch --with-tune=generic
Thread model: posix
gcc version 4.3.0 (GCC)
[mholub@mumu Desktop]$ uname -a
Linux mumu 2.6.24-ARCH #1 SMP PREEMPT Wed Mar 5 12:07:52 UTC 2008 i686 AMD Sempron(tm) Processor 2600+ AuthenticAMD GNU/Linux

Steps to reproduce:
- build ruby1.9 or gcc-devel from AUR.
This task depends upon

Closed by  Jan de Groot (JGC)
Friday, 28 March 2008, 08:11 GMT
Reason for closing:  Works for me
Comment by Jan de Groot (JGC) - Thursday, 27 March 2008, 18:28 GMT
It builds fine here, but the compilation of parse.c takes nearly 3 minutes on this box with 100% CPU usage on one core (E6750, 8GB memory, x86_64).

Loading...