Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#9971 - list of packages in core and extra without license information

Attached to Project: Arch Linux
Opened by Ronald van Haren (pressh) - Wednesday, 26 March 2008, 08:46 GMT
Last edited by Eric Belanger (Snowman) - Thursday, 21 May 2009, 00:59 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Simo Leone (neotuli)
Eric Belanger (Snowman)
Aaron Griffin (phrakture)
Ronald van Haren (pressh)
Dan McGee (toofishes)
Architecture All
Severity Low
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
see summary

Additional info:
see attached file for the list


Steps to reproduce:
#################################################
#!/bin/bash

# remove old file
rm ~/nolicense-$1.txt

# extract information
find -name "PKGBUILD" | grep -rl "license" * >> /tmp/with
find -name "PKGBUILD" | grep -rl "depends" * >> /tmp/all
diff -Naur /tmp/with /tmp/all >> /tmp/changed
sed -n '/@@/!p' /tmp/changed >> /tmp/changed2
sed -n '/+/p' /tmp/changed2 >> ~/nolicense-$1.txt
sed -i 's/+//' ~/nolicense-$1.txt

# removed temp files
rm /tmp/{with,all,changed,changed2}
echo "the required information is location in ~/nolicense-$1.txt"
###########################################
This task depends upon

Closed by  Eric Belanger (Snowman)
Thursday, 21 May 2009, 00:59 GMT
Reason for closing:  Fixed
Additional comments about closing:  see my last comment
Comment by Tobias Kieslich (tobias) - Wednesday, 26 March 2008, 16:59 GMT
Hi pressh,

just making sure you get an answer here, the developers have an internal TODO list for missing licenses. BTW. I didn't look into your code much but there are false positives, such as courier-maildrop which got licenses added 5 month ago. But we are on it.
Comment by Ronald van Haren (pressh) - Wednesday, 26 March 2008, 17:06 GMT
IC, it is indeed there in the web interface, but it is not there in my ABS tree (which I checked out today) (why?)

Well, as you guys have your own list I won't bother too much with it, but apart from above issue only the packages with /path/to/PKGBUILD in the list had missing licenses in my ABS tree.

Comment by Ronald van Haren (pressh) - Wednesday, 26 March 2008, 17:08 GMT
I found it :/

Courier-maildrop has a license field added, but it is wrong:

licecnse=('GPL2')
Comment by Tobias Kieslich (tobias) - Wednesday, 26 March 2008, 18:51 GMT
goddamn it. but it's fixed in cvs since Eric caught it. :P I'll rebuild it later.
Don't get me wrong here, I appreciate your report, just wanted to let the users know that we are on this task. It just takes time.

As for your question. abs checks out only what is tagged as "CURRENT". Sometimes, as in courier-maildrop's case the cvs HEAD is different since changes are checked in to be honoured in the next build but not tagged as CURRENT yet because no new binary package was build, This is why the web interface can be different from an abs checkout.
Comment by Roman Kyrylych (Romashka) - Thursday, 28 August 2008, 21:27 GMT
What is the status of this report?
IIRC there was a lot of license updates in past months.
Does someone have current stats?
Comment by Ronald van Haren (pressh) - Thursday, 28 August 2008, 21:38 GMT
there are still many to go, I'll see if I can get my hands on the current stats in the next few days.
Comment by Xavier (shining) - Friday, 29 August 2008, 06:30 GMT
What about this to find them :
find /var/abs/core -name PKGBUILD | xargs grep -L license

However this is probably better run against the svn tree, and only the trunk directories, to only check the latest PKGBUILDs.
Comment by Dan McGee (toofishes) - Friday, 05 December 2008, 13:22 GMT
Oh yeah, this bug. How are we looking in core? Maybe we should make it harder to upload a community or extra pkg without a license too.
Comment by Abhishek Dasgupta (abhidg) - Saturday, 21 February 2009, 16:37 GMT
From http://abhidg.mine.nu/arch/namcap-reports/tag/missing-license.html
there are four packages in [core] without licenses and quite a large number
in [extra] as well.

Also I think it should be made impossible to upload a community or extra
package without a license. If there's no license for the software, then
it should not exist in an official Arch binary repository.

Comment by Ronald van Haren (pressh) - Saturday, 21 February 2009, 17:53 GMT
keep in mind that a lot of these packages with no license information packages with infrequent releases. Also quite some are already fixed in svn but they have not yet been rebuild (not sure if you have taken these into account?)
Comment by Abhishek Dasgupta (abhidg) - Saturday, 21 February 2009, 18:22 GMT
I do know that quite a few packages without license info have
infrequent releases; in that case a new package with the updated
license should be uploaded.

I haven't done a svn checkout (only ABS) so the numbers I'm reporting
are certainly upper bounds. Doing a full svn checkout would be excessive
just to check for missing licenses.
Comment by Abhishek Dasgupta (abhidg) - Saturday, 21 February 2009, 18:35 GMT
Just checked that the packages in [core] which are showing up as missing licenses
in my abs checkout have licenses in trunk.
Comment by Gerardo Exequiel Pozzi (djgera) - Wednesday, 20 May 2009, 22:05 GMT
The klibc-1.5.15-2 package have the license=('BSD') but this package:

1) Not install any "LICENSE" file like others packages that have "BSD" as license.
2) The LICENSE file include some comments about that some files are GPL2, others are under BSD (original but the note about the clause 3), and others under MIT/X11.
Comment by Eric Belanger (Snowman) - Thursday, 21 May 2009, 00:59 GMT
Gerardo: I'll open a new bug report for klibc.

This bug is for missing license meta-data. I'll just go ahead and close it. The license rebuild is done except a few packages that will be fixed/removed: http://www.archlinux.org/pipermail/arch-dev-public/2009-May/011407.html

Loading...