Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#9912 - [linux] Unable to compile external dvb modules - no header files.

Attached to Project: Arch Linux
Opened by Wiktor Grebla. (greblus) - Saturday, 22 March 2008, 21:00 GMT
Last edited by Jan Steffens (heftig) - Thursday, 19 April 2018, 15:16 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Today I managed to compile newly written driver for my HVR-900 tuner (userspace version of em28xx which can be found here: http://mcentral.de/wiki/index.php5/Installation_Guide but it should be possible on a typical installation without the need to use additionally prepared kernel sources.

The problem is here:

http://greblus.net/trunk/compilation_error.txt

As I suppose it's caused by the fact that the /usr/src/linux-2.6.24-ARCH/drivers/media/dvb/dvb-core directory is empty.

I had to make a link /lib/modules/2.6.24-ARCH/build -> /root/build/linux-2.6.24 and compile the kernel until the modpost command is compiled.

I suppose that this driver could be easily installable on Arch if the missing header files were included.
This task depends upon

Closed by  Jan Steffens (heftig)
Thursday, 19 April 2018, 15:16 GMT
Reason for closing:  Upstream
Comment by Tomasz M. Nowak (tmn505) - Thursday, 19 April 2018, 15:08 GMT
  • Field changed: Percent Complete (100% → 0%)
Comment by Jan Steffens (heftig) - Thursday, 19 April 2018, 15:15 GMT
The headers were moved to include/media. Fix the driver.

Loading...