Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#9892 - Bugtracker - advanced search in comments not working

Attached to Project: Arch Linux
Opened by Michael Klier (chimeric) - Thursday, 20 March 2008, 23:01 GMT
Last edited by Roman Kyrylych (Romashka) - Monday, 08 June 2009, 22:30 GMT
Task Type Bug Report
Category Bugtracker
Status Closed
Assigned To Simo Leone (neotuli)
Roman Kyrylych (Romashka)
Architecture All
Severity High
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 14
Private No

Details

Description:

The advanced search in the bugtracker doesn't seem to work when the "Search in comments" checkbox is ticked. It results in the following MySql error (shortened):

Failed! (Unknown column 'c.comment_text' in 'where clause')

Reproducible: always
This task depends upon

This task blocks these from closing
 FS#10481 - flyspray "search in comments" busted 
Closed by  Roman Kyrylych (Romashka)
Monday, 08 June 2009, 22:30 GMT
Reason for closing:  Fixed
Additional comments about closing:  hurray!
Comment by Roman Kyrylych (Romashka) - Thursday, 20 March 2008, 23:04 GMT
Eliott, please save me from manual searching! ;)
(maybe try to downgrade or maybe there is some patch already)
Comment by eliott (cactus) - Sunday, 23 March 2008, 04:07 GMT
hooray. :/
Comment by eliott (cactus) - Sunday, 23 March 2008, 04:36 GMT
omg! ugly sql error is ugly!
I made a stab at fixing it, but it decided to do something crazy, and i had to kill the sql query thread.

Open a bug upstream I guess.
Comment by Dan McGee (toofishes) - Tuesday, 25 March 2008, 12:51 GMT
  • Field changed: Severity (Critical → High)
Comment by Xavier (shining) - Saturday, 17 May 2008, 10:01 GMT
How do I know whether arch flyspray has been updated or not? I don't see where the version is.
Not that this would help me anyway, because I have no idea in which upstream version this bug is fixed either.
I believe this bug should stay open as long as arch flyspray is broken.
Comment by Greg (dolby) - Saturday, 17 May 2008, 10:06 GMT
I tried finding out the version we are running before closing the other duplicate bug report. It seems we are not running a snapshot version so i would guess the stable 0.9.9.5.1.
Maybe it would be better to upddate to the latest snapshot?
Project download page says "Can be preferred over the latest release, contains all bug fixes. Only for upgrading from a stable release."
But then i suppose we wouldnt be able to upgrade again if something else goes wrong until the next stable release
Comment by Simo Leone (neotuli) - Monday, 16 June 2008, 09:21 GMT
ftr I'm fed up with flyspray's development stupidities. I mean seriously, what are these guys smoking?
Latest version: 0.9.9.5.1
Previous version: 0.9.9.5
What's next? 0.9.9.5.1.1.2.5? My guess is "probably".
Comment by Xavier (shining) - Monday, 16 June 2008, 10:01 GMT
That is stupid, but well...
Is the bug at least fixed in 0.9.9.5.1?
Comment by Greg (dolby) - Tuesday, 17 June 2008, 21:08 GMT
No its not fixed :/
Comment by Xavier (shining) - Monday, 18 August 2008, 18:46 GMT
So I asked Florian Schmitz (current project manager of flyspray) about this issue.
Here are some answers:
"currently there are no releases planned."
"Stable snapshots are available here:
http://snaps.flyspray.org/flyspray-0.9.9-latest.tar.bz2";

This is the same thing dolby mentioned above. These stable snapshots "Can be preferred over the latest release, contains all bug fixes."

So looks like we should switch to that?
Comment by Glenn Matthys (RedShift) - Thursday, 11 December 2008, 07:13 GMT
Status: not implemented.
Comment by Dan McGee (toofishes) - Monday, 12 January 2009, 03:35 GMT
Simo- do we just want to switch to a development snapshot?
Comment by Roman Kyrylych (Romashka) - Thursday, 28 May 2009, 19:13 GMT
big + for dev snapshot, there are way too many really annoying bugs in our current installation :(

Loading...