Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#9866 - major glitches in 3D with xf86-video-intel 2.2.1-2

Attached to Project: Arch Linux
Opened by quantax (quantax) - Tuesday, 18 March 2008, 10:36 GMT
Last edited by Jan de Groot (JGC) - Wednesday, 14 May 2008, 19:57 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Alexander Baldeck (kth5)
Architecture All
Severity Medium
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
After the lastest -Syu I got some weird graphical glitches in 3D games:
Textures where missing on some surfaces and for example in Quake3 the Rocket Launcher has a weird polygon spike reaching form the weapon to the crosshair in the middle of the screen.

I tried different versions of libgl and mesa but this didn't do the trick.
I couldn't test it with different xorg-server versions since I cleaned my pacman cache recently, but downgrading to xf86-video-intel 2.2.1-1 "solved" the problem.

Package versions:

libgl 7.0.3rc2-1
mesa 7.0.3rc2-1
xf86-video-intel 2.2.1-1
xorg-server 1.4.0.90-8

From my /etc/X11/xorg.conf:

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "NoAccel" # [<bool>]
#Option "SWcursor" # [<bool>]
#Option "ColorKey" # <i>
#Option "CacheLines" # <i>
#Option "Dac6Bit" # [<bool>]
#Option "DRI" # [<bool>]
#Option "NoDDC" # [<bool>]
#Option "ShowCache" # [<bool>]
#Option "XvMCSurfaces" # <i>
#Option "PageFlip" # [<bool>]
Identifier "965gm"
Driver "intel"
# way slow
#Driver "i810"
VendorName "Intel Corporation"
BoardName "Mobile GM965/GL960 Integrated Graphics Controller"
BusID "PCI:0:2:0"
Option "NoAccel" "false"
Option "DRI" "true"
Option "DDC" "true"
# screws up 3d display
#Option "PageFlip" "true"
#Option "TripleBuffer" "true"
Option "XVideo" "true"
Option "AccelMethod" "exa"
Option "ExaNoComposite" "false"
Option "XAANoOffscreenPixmaps" "true"
#Option "Legacy3D" "false"
Option "AllowGLXWithComposite" "true"
#Option "MigrationHeuristic" "greedy"
#Option "FramebufferCompression" "true"
#Option "Tiling" "true"
EndSection
This task depends upon

Closed by  Jan de Groot (JGC)
Wednesday, 14 May 2008, 19:57 GMT
Reason for closing:  Fixed
Comment by Roman Kyrylych (Romashka) - Tuesday, 18 March 2008, 10:53 GMT
Try with XAA instead of EXA.
EXA is buggy.
Comment by quantax (quantax) - Wednesday, 19 March 2008, 01:01 GMT
I wonder why every time when I have a problem with my GPU I get the recommendation to switch the AccelMethod. Doesn't matter which one I currently have - just switch to the other one. They both have their bugs but from the documentation I get the impression that XAA is deprecated...

Ok, 'nuff ranted.
Switching to XAA didn't help only downgrading improved the situation.

I made some screenshots:
http://img209.imageshack.us/img209/2170/shot0001uz4.jpg
http://img210.imageshack.us/img210/9463/shot0002aa2.jpg

Don't wonder about the ugliness: http://bbs.archlinux.org/viewtopic.php?id=41375
Comment by Roman Kyrylych (Romashka) - Wednesday, 19 March 2008, 07:13 GMT
> I wonder why every time when I have a problem with my GPU I get the recommendation to switch the AccelMethod. Doesn't matter which one I currently have - just switch to the other one. They both have their bugs but from the documentation I get the impression that XAA is deprecated...

Probably because it fixes issues for some people. True, XAA is deprecated, but also EXA seems to be in beta quality in most drivers.
Comment by quantax (quantax) - Friday, 21 March 2008, 22:19 GMT
I can corroborate the bug report.
I tested xf86-video-intel 2.2.1-2 with xorg-server 1.4.0.90-7. Same problem as with on pkgrel 8.
xf86-video-intel 2.2.1-1 still works everywhere.
Comment by Otakar Truněček (otakar) - Thursday, 27 March 2008, 19:25 GMT
Same here, glitches in openGL games like Medal of Honor and Wolfenstein since last uppgrade of intel driver (and mesa, xorg-server and libgl) . Both native and in wine. And with both accel methods. No errors or warnings in xorg.0.log.
From my xorg.conf
Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "NoAccel" # [<bool>]
#Option "SWcursor" # [<bool>]
#Option "ColorKey" # <i>
#Option "CacheLines" # <i>
#Option "Dac6Bit" # [<bool>]
#Option "DRI" # [<bool>]
#Option "NoDDC" # [<bool>]
#Option "ShowCache" # [<bool>]
#Option "XvMCSurfaces" # <i>
Option "PageFlip" "True" # [<bool>]
Option "AccelMethod" "XAA"
Identifier "Card0"
Driver "intel"
VendorName "Intel Corporation"
BoardName "965 G1 Integrated Graphics Controller"
BusID "PCI:0:2:0"
EndSection

Comment by Adrian C. (anrxc) - Saturday, 29 March 2008, 18:10 GMT
I can confirm this, I've tried various tweaks and settings in xorg.conf, nothing helped. I've read in another bug report that there is a pre relase of intel drivers 2.2.99 which should fix some bugs but I've not tried it because of various patches that you add to this package.

My packages;
local/libgl 7.0.3rc2-1
local/mesa 7.0.3rc2-1
local/xorg-server 1.4.0.90-9 (xorg)
local/xf86-video-intel 2.2.1-2 (xorg-video-drivers)
Comment by Adrian C. (anrxc) - Saturday, 29 March 2008, 18:47 GMT
A little update... I did try the pre realease 2.2.99.901 now, I had to, and I'm sorry to report that glitches are still present.
Comment by Otakar Truněček (otakar) - Saturday, 29 March 2008, 20:39 GMT
I think that upgrading intel driver won't help, because these glitches started with libgl (7.0.3rc1-1 -> 7.0.3rc2-1) and mesa (7.0.3rc1-1 -> 7.0.3rc2-1) upgrade. The xf86-video-intel package didn't change version, just release (2.2.1-1 -> 2.2.1-2) as it was rebuilt against new mesa and libgl.
Comment by Adrian C. (anrxc) - Saturday, 29 March 2008, 20:56 GMT
Oh, I have Wolfenstein ET which I run once a month, so I've lost track of various updates and wasn't sure what caused this. I will problably downgrade mesa here, and hopefully it will be fixed in the future.
Comment by ianux (ianux) - Sunday, 30 March 2008, 17:07 GMT
I agree with all above.
Can someone post a link to the xf86-video-intel-2.2.1-1 package since it isn't available anymore in arch repository?
Comment by Otakar Truněček (otakar) - Sunday, 30 March 2008, 17:26 GMT Comment by quantax (quantax) - Sunday, 30 March 2008, 18:31 GMT
@ianux
You can always get older PKGBUILDs and other files for building packages from http://cvs.archlinux.org/
Just dig out the older versions of the files:
http://cvs.archlinux.org/cgi-bin/viewcvs.cgi/x11-drivers/xf86-video-intel/?cvsroot=Extra
Comment by ianux (ianux) - Monday, 31 March 2008, 02:56 GMT
yes it works!!!
I think I didn't realize the power of AUR and PKGBUILDS!!!
th
Comment by Adrian C. (anrxc) - Friday, 25 April 2008, 13:44 GMT
Fixed with libgl and mesa that are now in [testing].
Comment by quantax (quantax) - Friday, 25 April 2008, 14:26 GMT
I can confirm this.
It is working again with the following packages from testing:

xorg-server 1.4.0.90-10
libgl 7.0.3rc3-1
mesa 7.0.3rc3-1
xf86-video-intel 2.2.1-3

Loading...