Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#9848 - Allocation memory by xf86-video-intel 2.2.1-1 driver

Attached to Project: Arch Linux
Opened by Andrey Gusev (metal) - Sunday, 16 March 2008, 11:39 GMT
Last edited by Jan de Groot (JGC) - Wednesday, 14 May 2008, 19:57 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Alexander Baldeck (kth5)
Architecture All
Severity Low
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: New version of Intel driver isn't support parameter "VideoRam" any more. It isn't good for systems with small amount of memory. Example:
Mem: 498880k total, 490084k used, 8796k free, 16444k buffers
Swap: 506008k total, 120k used, 505888k free, 143968k cached
PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
3441 root 20 0 246m 39m 8528 S 2.0 8.0 6:10.78 Xorg

Xorg cuts a half memory, because video driver allocates 128MB. Source code of current driver:
#if 0
from = X_CONFIG;
pScrn->videoRam = pI830->pEnt->device->videoRam;
#else
/* Disable VideoRam configuration, at least for now. Previously,
* VideoRam was necessary to avoid overly low limits on allocated
* memory, so users created larger, yet still small, fixed allocation
* limits in their config files. Now, the driver wants to allocate more,
* and the old intention of the VideoRam lines that had been entered is
* obsolete.
*/
from = X_DEFAULT;
pScrn->videoRam = pI830->FbMapSize / KB(1);

if (pScrn->videoRam != pI830->pEnt->device->videoRam) {
xf86DrvMsg(pScrn->scrnIndex, X_WARNING,
"VideoRam configuration found, which is no longer "
"recommended.\n");
xf86DrvMsg(pScrn->scrnIndex, X_INFO,
"Continuing with default %dkB VideoRam instead of %d "
"kB.\n",
pScrn->videoRam, pI830->pEnt->device->videoRam);
}
#endif


Additional info:
* package version(s)
xf86-video-intel 2.2.1-1
* config and/or log files etc.
lines from Xorg.log:
(WW) intel(0): VideoRam configuration found, which is no longer recommended.
(II) intel(0): Continuing with default 131072kB VideoRam instead of 32768 kB.


Steps to reproduce:
1) Install xf86-video-intel 2.2.1-1
2) Set VideoRam Parameter for driver.
3) Start X server.
This task depends upon

Closed by  Jan de Groot (JGC)
Wednesday, 14 May 2008, 19:57 GMT
Reason for closing:  Upstream
Comment by Andrey Gusev (metal) - Sunday, 16 March 2008, 13:31 GMT
I try to create packet for myself with: "#if 1" to restore old behavior of driver. Unfortunately, it doesn't take good effect.
if "VideoRam" is 32768, driver is failed to allocate memory.
if "VideoRam" is 65536, it works, but memory is not enough for "dri".
It looks like best solution is upgrade. Fortunately, it's possible for my machine.

Comment by Jan de Groot (JGC) - Sunday, 16 March 2008, 22:36 GMT
That's the cost you pay for integrated video. Depending on the resolution, the driver allocates enough memory for your framebuffer, DRI memory and for XV operations, which can be quite much in some cases. On my system it reserves 256MB memory for my G33 videochip.

If you're low on memory, use the older i810 driver, which allows setting memory limits.
Comment by Andrey Gusev (metal) - Monday, 17 March 2008, 21:14 GMT
Oh, I thought 128Mb is very big chunk and it can't be bigger. But, it seems normal. It is written from 8MB to 32MB in instruction of my laptop. Likely, it is about driver of windows. I have 855GM, it is more powerful, than I am expected. :)
Comment by Michal Bůžek (smajchl) - Monday, 07 April 2008, 21:57 GMT
I have made a bugreport on bugs.freedesktop.org -> http://bugs.freedesktop.org/show_bug.cgi?id=15394

Loading...