Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#9839 - vim doesn't start -> built against perl in testing.

Attached to Project: Arch Linux
Opened by Eric Belanger (Snowman) - Friday, 14 March 2008, 21:26 GMT
Last edited by Jan de Groot (JGC) - Sunday, 23 March 2008, 12:03 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Kieslich (tobias)
Architecture All
Severity High
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

As reported here:

http://bbs.archlinux.org/viewtopic.php?pid=342261

It seems that vim was build against the perl in testing. I didn't had time yet to confirm (I use testing repo) that it's the cause of the problem or whether vi, gvim or the x86_64 packages are also affected. As no one else complained yet, it might be a problem specific to that user.
This task depends upon

Closed by  Jan de Groot (JGC)
Sunday, 23 March 2008, 12:03 GMT
Reason for closing:  Fixed
Additional comments about closing:  perl 5.10 is in core now.
Comment by Eric Belanger (Snowman) - Saturday, 15 March 2008, 03:19 GMT
After checking it, vim works fine on i686 with the perl in core.
Comment by Tobias Kieslich (tobias) - Saturday, 15 March 2008, 03:57 GMT
I know, I wonder what setup the original user had, it might have to do with vim plugins that use perl scripting abilities. Are there such?
Comment by Eric Belanger (Snowman) - Saturday, 15 March 2008, 06:58 GMT
I don't know but the file that gives the error is part of perl. Perhaps he's using an half-updated system.
Comment by Jens (defcon) - Saturday, 15 March 2008, 22:04 GMT
My System is an up2date core system.
I rebuild vi/vim/gvim from abs, and it works fine.
Before rebuilding i found out, that the problem is my ~/.vim folder with some scripts.
After rebuilding it works with my .vim folder

scripts i use:
http://www.vim.org/scripts/script.php?script_id=556
http://www.vim.org/scripts/script.php?script_id=365
http://vim.sourceforge.net/scripts/script.php?script_id=213
Comment by Greg (dolby) - Thursday, 20 March 2008, 17:39 GMT
perl currently in testing is supposed to move into extra tomorrow. this should be fixed then
Comment by Tobias Kieslich (tobias) - Thursday, 20 March 2008, 22:49 GMT
Yepp, I figured that which is why I didn't touch it. The one thing I wondererd thoug is why the issue came up so late. There were several vims build against perl 5.10. I'm sorry I didn't catch it though

Loading...