Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#9776 - Xscreensaver fails to lock or start screensaver

Attached to Project: Arch Linux
Opened by Radu Potop (wooptoo) - Thursday, 06 March 2008, 21:01 GMT
Last edited by Greg (dolby) - Saturday, 17 May 2008, 16:00 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Eric Belanger (Snowman)
Architecture i686
Severity Medium
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

I recently upgraded to Xscreensaver 5.05-1.
While the Xscreensaver daemon (xscreensaver -nosplash) starts, it doesn't respond to xscreensaver-command commands. So, if you try something like "xscreensaver-command -lock" it won't do anything. It gives no output either.
I tried to (re)start it from the GUI (xscreensaver-demo) but it says that the daemon failed to (re)start.


Steps to reproduce:

pacman -S xscreensaver
xscreensaver -nosplash &
xscreensaver-command -lock
This task depends upon

Closed by  Greg (dolby)
Saturday, 17 May 2008, 16:00 GMT
Reason for closing:  Not a bug
Comment by Eric Belanger (Snowman) - Friday, 07 March 2008, 07:47 GMT
It works fine here. Is your system fully up-to-date?
Comment by Radu Potop (wooptoo) - Friday, 07 March 2008, 10:22 GMT
yes
Comment by Eric Belanger (Snowman) - Monday, 10 March 2008, 03:15 GMT
Try using the verbose option to get output:

xscreensaver -verbose -no-splash &
xscreensaver-command -lock

You could also downgrade to 5.04 to see if the old package is still working fine. It could be possible that the problem comes from another package or system modification.
Comment by Radu Potop (wooptoo) - Monday, 10 March 2008, 05:46 GMT
$ xscreensaver -verbose -no-splash
xscreensaver 5.05, copyright (c) 1991-2008 by Jamie Zawinski <jwz@jwz.org>.
xscreensaver: running as wooptoo/users (1000/100)
xscreensaver: in process 20639.
xscreensaver: 07:44:31: compensating for Xinerama braindamage:
xscreensaver: 07:44:31: 0: 1024x768+0+0 enclosed by 1024x768+0+0
xscreensaver: 07:44:31: 1: 1024x768+0+0 duplicated
xscreensaver: 07:44:31: running on display ":0.0" (0 Xinerama screens).
xscreensaver: 07:44:31: vendor is The X.Org Foundation, 10400090.
xscreensaver: 07:44:31: useful extensions:
xscreensaver: 07:44:31: MIT Screen-Saver (disabled at compile time)
xscreensaver: 07:44:31: Shared Memory
xscreensaver: 07:44:31: Double-Buffering
xscreensaver: 07:44:31: Power Management
xscreensaver: 07:44:31: GLX
xscreensaver: 07:44:31: XF86 Video-Mode
xscreensaver: 07:44:31: Xinerama
xscreensaver: 07:44:31: Resize-and-Rotate
xscreensaver: 07:44:31: Xinerama layout:
xscreensaver: 07:44:31: selecting RANDR events
xscreensaver: 07:44:31: consulting /proc/interrupts for keyboard activity.
xscreensaver: 07:44:31: selecting events on extant windows... done.
xscreensaver: 07:44:31: awaiting idleness.


$ xscreensaver-command -lock
xscreensaver-command: no screensaver is running on display :0.0


I'll try 5.04 and post if it works.
Comment by Radu Potop (wooptoo) - Monday, 10 March 2008, 13:59 GMT
Xscreensaver 5.04-2 works.

Loading...