Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#9772 - [xfwm4-4.4.2-1] awn steals focus from other windows (fix provided)

Attached to Project: Arch Linux
Opened by Corrado Primier (bardo) - Thursday, 06 March 2008, 13:20 GMT
Last edited by Tobias Kieslich (tobias) - Wednesday, 12 March 2008, 03:55 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Kieslich (tobias)
Architecture All
Severity Medium
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

At the moment the avant-window-navigator doesn't work with xfce because it steals the focus from all the other windows. There's a small patch, which has already been applied in svn that fixes this behavior: http://launchpadlibrarian.net/10696841/xfwm4-4.4.1-dock-window-fix.patch
This task depends upon

Closed by  Tobias Kieslich (tobias)
Wednesday, 12 March 2008, 03:55 GMT
Reason for closing:  Fixed
Comment by Roman Kyrylych (Romashka) - Sunday, 09 March 2008, 08:55 GMT
so, to fix a bug in avant we need to patch xfce?
Comment by Corrado Primier (bardo) - Sunday, 09 March 2008, 13:54 GMT
It's not a bug in awn, it's a bug in xfwm4, and the patch is pretty clear in what it does. This patch, as I said, was already committed to the svn: it means that also the xfce developers think it's a bug in their app. Awn sets itself as WINDOW_TYPE_DONT_FOCUS (as it's a panel, not a window) and rightly expects the current WM to respect this choice...
Comment by Roman Kyrylych (Romashka) - Sunday, 09 March 2008, 14:14 GMT
ah, thanks for explanation :)

Loading...