Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#9765 - texlive for x86_64 is 32 bit

Attached to Project: Community Packages
Opened by Borbus (Borbus) - Wednesday, 05 March 2008, 02:13 GMT
Last edited by Francois Charette (Firmicus) - Friday, 28 March 2008, 13:53 GMT
Task Type Bug Report
Category
Status Closed
Assigned To Francois Charette (Firmicus)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: texlive-most package installs i686 binaries on an x86_64 system.

Additional info:
None.


Steps to reproduce:
pacman -S texlive-most
/opt/texlive/bin/pdftex (for example) is a 32 bit binary.
This task depends upon

Closed by  Francois Charette (Firmicus)
Friday, 28 March 2008, 13:53 GMT
Reason for closing:  Fixed
Additional comments about closing:  Successfully built for x86_64
Comment by Francois Charette (Firmicus) - Thursday, 06 March 2008, 07:56 GMT
I did not build the x86_64 package of texlive-bin, but I still find this very strange, because nobody has reported this before! I'll look into it, but first I need more info: are you sure the i686 binaries you found come from the texlive-bin-*-x86_64.pkg.tar.gz package?
Comment by Borbus (Borbus) - Friday, 07 March 2008, 00:21 GMT
The package name is just texlive-bin-2007.2-2.pkg.tar.gz I got the same package from two different x86_64 mirrors.
Comment by Francois Charette (Firmicus) - Wednesday, 26 March 2008, 15:26 GMT
I now have a x86_64 machine. I'll build the binaries as soon as I can.
Comment by Francois Charette (Firmicus) - Thursday, 27 March 2008, 15:01 GMT
Building with gcc 4.3 fails. I'll downgrade to 4.2.3 and try again tonight.

Loading...