Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#9739 - udev in testing doesn't respawn udevd like in previous releases

Attached to Project: Arch Linux
Opened by Hussam Al-Tayeb (hussam) - Sunday, 02 March 2008, 13:28 GMT
Last edited by Thomas Bächler (brain0) - Friday, 19 September 2008, 07:18 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Tobias Powalowski (tpowa)
Aaron Griffin (phrakture)
Thomas Bächler (brain0)
Roman Kyrylych (Romashka)
Architecture All
Severity Medium
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

After the removal of udev_start, if I 'init s' and then 'init 5' (for whatever reason), I have to manually run 'udevd --daemon'.
This wasn't the case before as udevd was automatically respawned.

I realize that there aren't many cases where 'init s' is needed. but since this worked before, it is clearly a regression.

Maybe 'init 5' should check if udevd isn't running and run it in /etc/rc.multi

Without udevd, certain things like gnome-volume-manage/gnome-mount/hal appear to stop working properly.
This task depends upon

Closed by  Thomas Bächler (brain0)
Friday, 19 September 2008, 07:18 GMT
Reason for closing:  Fixed
Comment by Roman Kyrylych (Romashka) - Sunday, 02 March 2008, 16:41 GMT
the whole runlevel switching is a little broken since old times IMHO,
need to fix that stuff finally....
Comment by Hussam Al-Tayeb (hussam) - Sunday, 02 March 2008, 17:04 GMT
Yes, there are some old issues but this is a new regression.
Comment by Aaron Griffin (phrakture) - Tuesday, 04 March 2008, 23:04 GMT
Wait wait... so 'init s' kills udevd somehow? It shouldn't die at all.
Comment by Hussam Al-Tayeb (hussam) - Tuesday, 04 March 2008, 23:14 GMT
Yes, it does. It terminates all running processes.
Comment by Aaron Griffin (phrakture) - Wednesday, 05 March 2008, 23:30 GMT
Ok, so let me see here, because I'm obviously missing something. 'init s' terminates _all_ processes.
First question: should it? Should 'init s' terminate everything, or only non-critical ones?
So then 'init 5' does not rerun udev?
Second question: should not switching from S to 5 rerun rc.multi only? If this is the case, anything done in rc.sysinit should NOT be undone by 'init s'
Comment by Roman Kyrylych (Romashka) - Wednesday, 05 March 2008, 23:42 GMT
I believe that "if [ $RUNLEVEL ..." things in rc.single are wrong.
I remember that switching runlevels 3 -> s -> 3 resulted in incorrect udev reloading and reasonless syslog reloading, so the status of the system after such switch back & forth was different.
Comment by Tobias Powalowski (tpowa) - Monday, 24 March 2008, 09:24 GMT
is this still an issue?
Comment by Hussam Al-Tayeb (hussam) - Monday, 24 March 2008, 09:51 GMT
No, it's no longer an issue but only because /etc/start_udev is back. Will it remain?
Comment by Dan McGee (toofishes) - Tuesday, 25 March 2008, 13:01 GMT
Why'd this get closed?
Comment by Aaron Griffin (phrakture) - Tuesday, 25 March 2008, 15:47 GMT
Yes, this bug needs to remain open because start_udev will be dying. It has been readded to the package to appease the gallery.

When it goes away this bug will still remain
Comment by Dariusz Brzezinski (dabrze) - Monday, 07 April 2008, 06:49 GMT
Another problem somehow connected to the udev update to 119-1 and initscripts to 2008.03-4 I have discovered trying to use my usb scanner (MICROTEK SCANMAKER 3600). After this update my scanner has got wrong owner flags (root:root). I have manually run once 'start_udev' to fix this problem (root:scanner). Then even I switched the scanner off and on again several times it works fine till next system reboot.

[darek@agnieszka ~]$ ls -l /dev/bus/usb/002/006
crw-r--r-- 1 root root 189, 133 kwi 6 23:51 006
[darek@agnieszka ~]$ sudo /etc/start_udev
Hasło:
mounting... ramfs at /dev
Creating initial udev device nodes:
Kernel >= 2.6.15 and supports uevents
udev startup is finished! - time = 4
[darek@agnieszka ~]$ ls -l /dev/bus/usb/002/006
crw-rw-r-- 1 root scanner 189, 133 kwi 6 23:54 006
Comment by Hussam Al-Tayeb (hussam) - Sunday, 14 September 2008, 17:24 GMT
this bug is back in udev 127 and 128 because start_udev is missing again.
Comment by Thomas Bächler (brain0) - Sunday, 14 September 2008, 17:32 GMT
start_udev is gone and won't return, no idea why it was re-added in the first place. This must be fixed in rc.single.
Comment by Thomas Bächler (brain0) - Thursday, 18 September 2008, 17:06 GMT
This should be fixed with initscripts 2008.09-1, please confirm.
Comment by Hussam Al-Tayeb (hussam) - Friday, 19 September 2008, 06:32 GMT
Yes, definitely fixed in initscripts 2008.09-2
Thanks you :) You may close the bug.

Loading...