Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#9700 - Testing initscripts breaks the network

Attached to Project: Arch Linux
Opened by Aytug Gurbuz (Majorix) - Wednesday, 27 February 2008, 06:19 GMT
Last edited by Aaron Griffin (phrakture) - Monday, 17 March 2008, 19:18 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Aaron Griffin (phrakture)
Thomas B├Ąchler (brain0)
Architecture All
Severity High
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Updating to the latest testing initscripts breaks the network. Both wired and wireless.
For all the further ado and see how this evolved into a bug report, please see this topic from the forums:
http://bbs.archlinux.org/viewtopic.php?id=44541

Packages affected:
-initscripts 2008.02-1

Steps to reproduce:
-(Don't) Try initscripts 2008.02-1!
This task depends upon

Closed by  Aaron Griffin (phrakture)
Monday, 17 March 2008, 19:18 GMT
Reason for closing:  Not a bug
Additional comments about closing:  See  FS#9836 
Comment by Roman Kyrylych (Romashka) - Thursday, 28 February 2008, 00:42 GMT Comment by Aytug Gurbuz (Majorix) - Friday, 29 February 2008, 22:54 GMT
  • Field changed: Percent Complete (100% → 0%)
Despite the comment that closed the topic, I have already tried this with netcfg; unsuccessfully.
Comment by Aaron Griffin (phrakture) - Friday, 29 February 2008, 22:55 GMT
The variable name has changed... from NET_PROFILES to NETWORKS, I believe.

I need to add an install message to the initscripts, so I will keep this open.
Comment by Aytug Gurbuz (Majorix) - Saturday, 01 March 2008, 21:00 GMT
NETWORKS and NET_PROFILES refer to two different daemons I believe; network and net-profiles, respectively. Look here:
http://wiki.archlinux.org/index.php/Network_Profiles
Even though that wiki lacks a few small additions, it should show that the two are different things.

I believe the old daemon with NET_PROFILES might be obsolete, as everybody talks of that.

I tried it with both daemons, yet I couldn't connect to the net. To fix this, I sadly had to reinstall and disable testing this time.
Comment by Aytug Gurbuz (Majorix) - Monday, 03 March 2008, 02:46 GMT
I have tested it, and I can say that the networkmanager daemon isn't affected by this bug. However the awful bootup time issue is still there.

Loading...