Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#9693 - Buggy ipw2200 module after resuming from suspend

Attached to Project: Arch Linux
Opened by Flavien Bridault (vlaaad) - Tuesday, 26 February 2008, 15:09 GMT
Last edited by Greg (dolby) - Saturday, 26 July 2008, 06:00 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Thomas B├Ąchler (brain0)
Architecture i686
Severity Medium
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When I hibernate my laptop and then I resume, my wifi adapter no longer works (no network detected and the led doesn't show up). Neither with networkmanager nor wifi-radar. I tested and it seems that the bug comes from the latest kernel packages. Indeed, the problem doesn't appear with 2.6.24-1, but it is present with 2.6.24.1-2 from core and 2.6.24.2-1 from testing.

I tried to unload/load the module after resuming but the adapter still doesn't seem to work. I think I didn't noticed any error in the kernel log, but I can provide it if needed.

Steps to reproduce:
- Hibernate the laptop (indeed with gnome-power-manager).
- Resume
- Try to detect a network with wifi-radar or nm-applet
This task depends upon

Closed by  Greg (dolby)
Saturday, 26 July 2008, 06:00 GMT
Reason for closing:  Upstream
Additional comments about closing:  Not an Archlinux bug
Comment by Pierre Schmitz (Pierre) - Wednesday, 27 February 2008, 13:03 GMT
I use kernel 2.6.24.3-1 and ipw2200 and I do not have any problems with suspend2ram or suspend2disk. (using pm-utils and tested with netcfg/iwlist).

This might not really help you, but shows that this is not a generall problem.
Comment by Roman Kyrylych (Romashka) - Thursday, 28 February 2008, 00:35 GMT
I don't think this kind of (mainstream) issues can be fixed in Arch (unless there is some patch).
Comment by Flavien Bridault (vlaaad) - Saturday, 22 March 2008, 18:00 GMT
I think I found a clue. It seems to be because of the acerhk module !

Indeed the package was not available for 2.6.24.1 so I didn't have it loaded. When I upgraded to 2.6.24.2, the acerhk was also upgraded. I realized that because I finally recompiled acerhk with 2.6.24.1 and then the problem appeared.

So now I switched back to the latest kernel, and if I take care to unload it in the suspend/hibernate scripts, then the problem is solved.

Hopelessly the acerhk module seems unmaintained, so I don't know how to get this fixed upstream.
Comment by Greg (dolby) - Saturday, 17 May 2008, 16:06 GMT
Is it still a problem with 2.6.25.X ? You should consider making a bug report upstream
Comment by Flavien Bridault (vlaaad) - Saturday, 07 June 2008, 12:43 GMT
Hopelessly yes it is still a problem with 2.6.25.X :-/

Of course I should consider reporting the bug upstream, but as I said, the module is currently unmaintained...

Loading...