Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#9647 - xorg-server: xf86-input-evdev causes wrong keyboard layout

Attached to Project: Arch Linux
Opened by dema (maschino) - Thursday, 21 February 2008, 20:37 GMT
Last edited by Jan de Groot (JGC) - Monday, 23 February 2009, 13:59 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Jan de Groot (JGC)
Alexander Baldeck (kth5)
Architecture All
Severity High
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Package xf86-input-evdev (version 1.2.0-1 from testing) breaks my keyboard layout. Per example my arrow-up-key is triggering the keycode for taking a screenshot. The letter keys are working normally, only the special buttons like the arrow keys, delete, page down etc. are affected.

Additional info:
* xorg-server 1.4.0.90-7
* xf68-input-evdev 1.2.0-1
* Logitech Media Keyboard

Steps to reproduce:
Update the tow packages below from testing and set up xorg.conf to automatically recognize your keyboard.
This task depends upon

Closed by  Jan de Groot (JGC)
Monday, 23 February 2009, 13:59 GMT
Reason for closing:  Deferred
Additional comments about closing:  The reopen request has nothing to do with the original bug.
Comment by Roman Kyrylych (Romashka) - Thursday, 21 February 2008, 21:03 GMT
I guess this is because of added support for dbus/hal.
@maschino: see /etc/hal/fdi/policy/11-xkeyboard.fdi (but I don't know how to configure it)
Comment by Jan Spakula (bender02) - Friday, 22 February 2008, 04:32 GMT
For me, the problem with evdev/hal backend in xorg was fixable by tweaking my xorg.conf. I posted what I did on the forum http://bbs.archlinux.org/viewtopic.php?pid=333663
Comment by Maciej Sitarz (macieks2) - Saturday, 23 February 2008, 13:49 GMT
Installer suggests:
echo ":: ATTENTION!"
echo ":: Since xorg-server version 1.4.0.90-7 hal support has"
echo ":: been enabled. By default keyboard layouts and variants"
echo ":: will now be overridden by hal. Please modfiy"
echo "::"
echo ":: /etc/hal/fdi/policy/11-xkeyboard.fdi"

but the file won't be saved after upgrade/reinstall of the xorg-server package.

So maybe better way to change the keymap is:
cp /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi /etc/hal/fdi/policy/12-keymap.fdi
and then modify this file?
Comment by Jan Spakula (bender02) - Saturday, 23 February 2008, 16:59 GMT
macieks2 wrote: but the file won't be saved after upgrade/reinstall of the xorg-server package
---
This can be solved by adding 'backup=(etc/hal/fdi/policy/11-xkeyboard.fdi)' to the PKGBUILD, which is IMO better than copying files around.
Comment by Greg (dolby) - Saturday, 23 February 2008, 17:06 GMT
may i ask what was the reason hal was enabled in the package in the first place? i tried searching relevant bug reports and the arch-dev-public list and i didnt see the reason anywhere
Comment by Greg (dolby) - Sunday, 24 February 2008, 07:34 GMT
oh it was #9563
Comment by Greg (dolby) - Sunday, 11 May 2008, 19:52 GMT
Is this still a problem? HAL support in xorg-server has been disabled long ago
Comment by dema (maschino) - Monday, 12 May 2008, 10:05 GMT
For me it's working again. It can be closed.
Comment by Carlos Eduardo (cemsbr) - Wednesday, 11 February 2009, 20:08 GMT
Similiar problem
Comment by Aaron Griffin (phrakture) - Wednesday, 11 February 2009, 20:09 GMT
cemsbr: Please provide more details
Comment by Greg (dolby) - Wednesday, 11 February 2009, 20:20 GMT
cemsbr: are you using x86_64 ? Maybe it has something to do with latest xorg lib packages updates. See for example  FS#13188  Is this in GNOME?
Comment by Carlos Eduardo (cemsbr) - Thursday, 12 February 2009, 17:55 GMT
My keyboard has a layout which needs to have "Fn" key in order to type "/" and "Alt Gr" to type "?". As I use terminal a lot, this is quite annoying and I configured xorg.conf with another variant (thinkpad) so I can type "/" by only pressing right control key and "?" by pressing shift+right control key. This preserves all other keys, including the annoying ones and there couldn't be better layout.

But then hal appeared, ignored my xorg.conf settings, detected a wrong keyboard layout and I couldn't type some keys. To set my desired layout for X (and not gnome/kde specifically), I had to create /etc/hal/fdi/policy/10-keymap.fdi, which is not as simple as writing an option in xorg.conf. Now it works!

Yes, I'm using x86_64. I think there's no better way to set a different layout from the correct one, otherwise I'd be glad to know about it.

Loading...