Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#9643 - man PKGBUILD shows slanted single quotes

Attached to Project: Arch Linux
Opened by Paul Bredbury (brebs) - Thursday, 21 February 2008, 17:02 GMT
Last edited by Greg (dolby) - Tuesday, 17 June 2008, 10:40 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Aaron Griffin (phrakture)
Architecture All
Severity Low
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi, "man PKGBUILD" corrupts *all* instances of single quotes as *slanted* single quotes, showing e.g.:

license=(´GPL´)

This happens even though /var/abs/core/base/pacman/src/pacman-3.1.1/doc/PKGBUILD-example.txt looks correct:

license=('GPL')

As reported in http://bbs.archlinux.org/viewtopic.php?id=44309
This task depends upon

Closed by  Greg (dolby)
Tuesday, 17 June 2008, 10:40 GMT
Reason for closing:  Fixed
Comment by Aaron Griffin (phrakture) - Thursday, 21 February 2008, 17:06 GMT
Could you please verify which version of groff you have installed and if you merged man.conf and /etc/profile from previous upates (namely: removing LESSCHARSET and -Tlatin1).
This should fix the quote thing:
http://cvs.archlinux.org/cgi-bin/viewcvs.cgi/base/groff/man-utf8.tmac?rev=1.1&content-type=text/vnd.viewcvs-markup
Comment by Paul Bredbury (brebs) - Thursday, 21 February 2008, 17:33 GMT
This is with groff 1.19.2-4, and man.conf & profile are standard. Problem occurs both on x86 & x86_64.

I'm sure the quotes were OK the last time I looked at them, which was roughly a month ago.
Comment by Travis Willard (Cerebral) - Thursday, 21 February 2008, 17:58 GMT
make sure you don't have a profile.pacnew hanging around somewhere
Comment by Xavier (shining) - Thursday, 21 February 2008, 18:09 GMT
Aaron and Travis, do you mean you can't reproduce this problem?

It happens on my two box here (one using testing).
Comment by Travis Willard (Cerebral) - Thursday, 21 February 2008, 18:10 GMT
I'm at work. Can't test right now.
Comment by Aaron Griffin (phrakture) - Thursday, 21 February 2008, 18:13 GMT
Same, I didn't test it, but I *know* it's related to that groff tmac stuff. Try fiddling with that file I pointed to up there.
Comment by Dan McGee (toofishes) - Thursday, 21 February 2008, 18:13 GMT
you see the package´s license there, simply reference it in the
license field (e.g. license=(´GPL´)). If the package provides a

I have them too. I pasted the first line to show where we do want these special quotes, although it is not critical.
Comment by Aaron Griffin (phrakture) - Thursday, 21 February 2008, 18:15 GMT
Actually, we don't - just like the dash thing, we want to ONLY use the quote char that you can type on your keyboard. Apparently, I got the wrong char in the tmac file.
Comment by Xavier (shining) - Thursday, 21 February 2008, 18:45 GMT
. char \- \N'45'
. char - \N'45'
. char ' \N'39'

Well, for the dash, we remap both \- and -, but for the quote, we remap only '.
PKGBUILD man page actually uses \'
I confirm than adding the following line works fine :
. char \' \N'39'
Comment by Aaron Griffin (phrakture) - Thursday, 21 February 2008, 18:54 GMT
Thanks Xavier, that's exactly what I was hoping for
Comment by Gavin Bisesi (Daenyth) - Wednesday, 04 June 2008, 18:36 GMT
Is this fixed then?
Comment by Xavier (shining) - Thursday, 05 June 2008, 08:27 GMT
It is not fixed, the fix I suggested was not applied :
http://repos.archlinux.org/viewvc.cgi/groff/repos/core-i686/man-utf8.tmac?revision=1&view=markup

However, it might be a bad time to remind Aaron about this since he is in a period of low activity :
http://archlinux.org/pipermail/arch-dev-public/2008-June/006390.html
Comment by Aaron Griffin (phrakture) - Thursday, 05 June 2008, 15:10 GMT
Dan, would you mind committing the changes to that file? I can rebuild when I have internets again
Comment by Dan McGee (toofishes) - Thursday, 05 June 2008, 15:27 GMT
$ svn commit -m "fix issue with  FS#9643 , slanted single quotes in man page"
Sending trunk/man-utf8.tmac
Transmitting file data .
Committed revision 2513.

Done.

Loading...