Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#9549 - XFCE4 package group should depend on openssh

Attached to Project: Arch Linux
Opened by testing (farkus888) - Tuesday, 12 February 2008, 17:03 GMT
Last edited by Greg (dolby) - Saturday, 17 May 2008, 16:14 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Kieslich (tobias)
Architecture All
Severity Medium
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: after installing a base install, xorg, and xfce4 following the wikis startxfce4 fails with an error about ssh. manually adding the openssh package to the system with pacman resolves the issue


Additional info:
* xfce4 and xorg package groups on a base install only, no other packages installed
* I replicated this with both i686 and x86-64
* I tried starting X to a display manager and using the display manager to start xfce, I was able to start the display manager but got the same error when starting xfce. that is why I believe it is the xfce4 group that needs openssh added and not the xorg group

Steps to reproduce:
1. perform a base install
2. install xorg
3. install video drivers (I have tried catalyst in i686 and nvidia in x86-64)
4. install xfce4
5. configure xorg.conf
6. at this point startxfce4 has given the ssh error every time on both systems.
7. pacman -S openssh
8. at this point startxfce4 works every time.
This task depends upon

Closed by  Greg (dolby)
Saturday, 17 May 2008, 16:14 GMT
Reason for closing:  Not a bug
Comment by Greg (dolby) - Wednesday, 13 February 2008, 01:47 GMT
i dont believe this is valid. i installed xfce4 just a couple of days ago without having openssh in that installation present, unless pacman -S xfce4 fetched it, and startxfce4 worked
Comment by Tobias Kieslich (tobias) - Wednesday, 13 February 2008, 03:30 GMT
all ways to start xfce4 work fine without openssh installed here. having it installed brings up the ssh-agent which is convenient but that does not make it a dependency.
I can't reproduce that it would fail xfce4 to start having it not installed.
Comment by sfgdg (merlyn) - Sunday, 24 February 2008, 21:23 GMT
What is exactly "ssh error" ?
Comment by Schwarze Krause (SchwarzeKrause) - Sunday, 24 February 2008, 23:34 GMT
Well, I got this error while trying to login from gdm, but I also needed to change read/write permissions for /tmp
Comment by testing (farkus888) - Monday, 25 February 2008, 12:41 GMT
I don't remember the exact wording of the error, it was something about ssh-agent though.
Schwarze Krause, I had the issue with permissions on /tmp as well but only during the ftp based install that I had done. that is a separate issue that there is a bug posted for. both the ftp based install and the cd based install I had done gave me the same error about ssh-agent. like I said before, xfce failed to start both directly and when using gdm to launch it. I did not try xdm or kdm so I do not know if you would get the same errors with them.
Comment by Marc St-Laurent (peart) - Saturday, 05 April 2008, 03:44 GMT
I think I know what this is about. If the reporter copied xfce4's default startup script (/etc/xdg/xfce4/xinitrc), that script tries to start ssh-agent, if it is installed. If it isn't, an error similar to "which: no ssh-agent found" will be displayed.

This error wouldn't stop xfce from starting though. If I'm right about the source of the error message, then there is a 2nd issue which is preventing xfce4 from starting.

Loading...