Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#9501 - pam broken

Attached to Project: Arch Linux
Opened by Michal (broch) - Friday, 08 February 2008, 20:32 GMT
Last edited by Roman Kyrylych (Romashka) - Friday, 08 February 2008, 23:40 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:


Additional info:
* package version(s)
coreutils?
* config and/or log files etc.
/etc/pam.d/su


Steps to reproduce:

edit
/etc/pam.d/su
uncomment this line
auth sufficient pam_wheel.so trust use_uid

save file

Now every user in the wheel group should be able to invoke su without root password.
This is very nice/secure way of managing elevated privileges

Problem:
after the latest update (coreutils?)
members of wheel group are asked for root password when issuing
su

this indicates that pam is broken

latest system update
02-08-2008
arch: i686

reproduced here:
http://bbs.archlinux.org/viewtopic.php?id=43509
This task depends upon

Closed by  Roman Kyrylych (Romashka)
Friday, 08 February 2008, 23:40 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#4857 
Comment by Tobias Powalowski (tpowa) - Friday, 08 February 2008, 20:35 GMT
please update to coreutils-6.10-2
Comment by Michal (broch) - Friday, 08 February 2008, 20:53 GMT
I will try
currently:

sudo pacman -Syu
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
:: Starting full system upgrade...
local database is up to date
$ pacman -Qe | grep coreutils
coreutils 6.10-1


Comment by Tobias Powalowski (tpowa) - Friday, 08 February 2008, 20:54 GMT
it's in testing due to signoff verification
Comment by Roman Kyrylych (Romashka) - Friday, 08 February 2008, 23:28 GMT
Duplicate of  FS#4857 . I've used exactly the same steps to test it with 6.9-4, 6.10-1 and 6.10-2. The latest version fixed the bug (tested on i686).

Loading...