Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#9437 - pcre 7.6-1 kills gnome system monitor !

Attached to Project: Arch Linux
Opened by Frederic Bezies (fredbezies) - Saturday, 02 February 2008, 07:29 GMT
Last edited by Jan de Groot (JGC) - Sunday, 03 February 2008, 15:16 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Medium
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: When I try to launch gnome-system-monitor, it stops, saying :

[fred@fredo-arch ~]$ gnome-system-monitor: symbol lookup error: gnome-system-monitor: undefined symbol: _ZN7pcrecpp6no_argE

A little search makes me think that pcre is guilty because I found this bug report on ubuntu's launchpad :

https://bugs.launchpad.net/debian/+source/pcre3/+bug/130428

Additional info:
* pcre 7.6-1
* gnome-system-monitor 2.20.2-1


Steps to reproduce: see description. It makes gnome-system-monitor useless, which is annoying.


This task depends upon

Closed by  Jan de Groot (JGC)
Sunday, 03 February 2008, 15:16 GMT
Reason for closing:  Fixed
Additional comments about closing:  ABI breakage reverted in 7.6-2. Please "downgrade" any package you rebuilt for 7.6-1.
Comment by Gianvito (gianvito) - Saturday, 02 February 2008, 11:26 GMT
Same problem... after upgrading pcre gnome system monitor doesn't work
Comment by Gianvito (gianvito) - Saturday, 02 February 2008, 11:32 GMT
downgrading to pcre-7.5-1 resolved my problem
Comment by Jan de Groot (JGC) - Saturday, 02 February 2008, 12:14 GMT
This is an ABI breakage in pcre. Rebuilding gnome-system-monitor should fix it, but as pcre didn't bump soname, this is a regression in pcre itself. Libraries that break ABI should have bumped their soname.
Comment by Gianvito (gianvito) - Saturday, 02 February 2008, 13:10 GMT
Rebuilding gnome-system-monitor by ABS fix the problem. I tried now and it works
Comment by Frederic Bezies (fredbezies) - Saturday, 02 February 2008, 15:25 GMT
Any hope to get a new version for both i686 and AMD64 soon ?

Thanks for an optimistic answer :)

Loading...