Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#9411 - WebDAV support missing in latest subversion package

Attached to Project: Arch Linux
Opened by M. H. (DerGuteMoritz) - Thursday, 31 January 2008, 09:47 GMT
Last edited by Simo Leone (neotuli) - Friday, 08 February 2008, 07:17 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Jason Chu (jason)
Kevin Piche (kpiche)
Architecture All
Severity Medium
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 14
Private No

Details

Description:

After subversion has been rebuilt against the latest perl (cf. http://bugs.archlinux.org/task/9252 - thanks a lot, by the way!), it seems that WebDAV support is broken/missing from the package. Checking out a repository through http(s) yields

svn: Unrecognized URL scheme for 'http://svn.example.com/trunk'



Package versions:
* subversion 1.4.5-3


Steps to reproduce:

Just checkout any svn repository through http(s).
This task depends upon

Closed by  Simo Leone (neotuli)
Friday, 08 February 2008, 07:17 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in subversion 1.4.5-4 in testing.
Comment by Bjørn Øivind Bjørnsen (MrKaKe) - Thursday, 31 January 2008, 13:23 GMT
I can confirm this, but it does not affect the package currently in extra/ (1.4.5-2) as the bugreport states, but the package in testing/ (1.4.5-3)

The package in extra/ still works.
Comment by M. H. (DerGuteMoritz) - Thursday, 31 January 2008, 15:25 GMT
Oh yes, of course, sorry! :)
Comment by Alessio Bianchi (Venator85) - Friday, 01 February 2008, 10:13 GMT
I can also confirm this. SVN+SSH is broken as well.
Comment by Gianvito (gianvito) - Saturday, 02 February 2008, 17:33 GMT
me too... same problem
Comment by M. H. (DerGuteMoritz) - Sunday, 03 February 2008, 16:29 GMT
Maybe someone could notify Mr K. Piche <kevin@archlinux.org> about this?
Comment by Hussam Al-Tayeb (hussam) - Monday, 04 February 2008, 00:15 GMT
Confirmed here too.
Comment by Pierre-Paul Paquin (peets) - Monday, 04 February 2008, 01:05 GMT
Same problem here.

The subversion FAQ talks about this: http://subversion.tigris.org/faq.html#unrecognized-url-error
Comment by cristian (fancris3) - Monday, 04 February 2008, 11:03 GMT
And me
Comment by dillweed (dillweed) - Tuesday, 05 February 2008, 21:36 GMT
Current version doesn't work for me either. But in the meantime I monkeyed with the subversion-neon.patch and PKGBUILD to get it working. See attachments. Just be sure to copy all the other stuff from /var/abs/testing/devel/subversion (or whereever you have it) to a different directory and build away. Seems to be working for me, but as always YMMV.

Loading...