Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#9386 - UDMA mode changes in boot due to "40-wire" cable

Attached to Project: Arch Linux
Opened by Ray Clancy (lilsirecho) - Tuesday, 29 January 2008, 06:58 GMT
Last edited by Greg (dolby) - Tuesday, 17 June 2008, 10:43 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture i686
Severity Low
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:UDMA rated CF/IDE adapter utilized to enter Faunos "Live" flash drive having UDMA 5 capability. Dmesg reveals that UDMA 2 mode was set due to "40-wire" cable. 80-wire cable is installed and proper interface connections verified in the adapter/cable interface by inspection. Googling the internet reveals this problem exists in other linux OS and libata is found to be the problem.

The solution that has been employed to correct this problem is provided in the following URL:

linux-ide@vger.kernel.org/msg14722.html"> http://www.mail-archive.com/linux-ide@vger.kernel.org/msg14722.html

Pertinent dmesg data follows:

ata_piix 0000:00:1f.1: version 2.12
ACPI: PCI Interrupt 0000:00:1f.1[A] -> GSI 18 (level, low) -> IRQ 18
PCI: Setting latency timer of device 0000:00:1f.1 to 64
scsi0 : ata_piix
scsi1 : ata_piix
ata1: PATA max UDMA/133 cmd 0x000101f0 ctl 0x000103f6 bmdma 0x0001f000 irq 14
ata2: PATA max UDMA/133 cmd 0x00010170 ctl 0x00010376 bmdma 0x0001f008 irq 15
usb 5-5: new high speed USB device using ehci_hcd and address 2
ata1.00: CFA: LEXAR ATA FLASH CARD, 20070228, max UDMA/100
ata1.00: 7831152 sectors, multi 0: LBA
ata1.00: limited to UDMA/33 due to 40-wire cable
ata1.00: configured for UDMA/33
usb 5-5: configuration #1 chosen from 1 choice
scsi 0:0:0:0: Direct-Access ATA LEXAR ATA FLASH 2007 PQ: 0 ANSI: 5
hub 5-5:1.0: USB hub found
hub 5-5:1.0: 4 ports detected NOTE: CFA is compact flash adapter UDMA 5

Faunos is based on archlinux and Larch elements.

This is not a strict archlinux bug unless a "Live" flash drive version of archlinux is involved but it seems it would give the same answer.

Kernel version 2.6.23 X86

Result in two computers was identical.




Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:See the referenced URL for other examples. Perhaps a patch can be established.
This task depends upon

Closed by  Greg (dolby)
Tuesday, 17 June 2008, 10:43 GMT
Reason for closing:  Upstream
Comment by Tobias Powalowski (tpowa) - Tuesday, 29 January 2008, 12:30 GMT
please confirm the problem on .24 kernel from testing, .23 is dead ;)
Comment by Ray Clancy (lilsirecho) - Tuesday, 29 January 2008, 16:06 GMT
Unable to comply with request because no kernel upgrade is possible for this "Live" system.

You may close the bug if this prevents any further action.

Thanks.
Comment by Ray Clancy (lilsirecho) - Tuesday, 29 January 2008, 22:35 GMT
Please consider the following post as related:

http://bbs.archlinux.org/viewtopic.php?id=43097
Comment by Ray Clancy (lilsirecho) - Wednesday, 30 January 2008, 05:02 GMT
The following post is also considered to be relevant due to the UDMA constriction shown in dmesg. The problem was solved with changes removing ata related entries.

* Kernel & Hardware Issues
* » Ata problems with new dvd drive. [SOLVED]

Comment by Ray Clancy (lilsirecho) - Wednesday, 30 January 2008, 05:31 GMT
Also see the mess made of UDMA in this post!

# Laptop Issues
# » My Archie boot is very slow on my laptop
Comment by Ray Clancy (lilsirecho) - Wednesday, 30 January 2008, 05:33 GMT
And another:

# Laptop Issues
# » ata2 exception Emask (timeout)
Comment by Ray Clancy (lilsirecho) - Wednesday, 30 January 2008, 05:50 GMT
And another with botched DMA:

# Laptop Issues
# » old hp laptop ata2 problem causing boot delay
Comment by Ray Clancy (lilsirecho) - Tuesday, 19 February 2008, 20:04 GMT
http://pixca.net/2008/02/03/limited-to-udma33-due-to-40-wire-cable/

This URL gives a kernel patch for correction of the problem of 80-wire cable identification.
Comment by Glenn Matthys (RedShift) - Tuesday, 17 June 2008, 09:16 GMT
You can force a module to use DMA with the libata.dma=4 parameter on the kernel command line. Anyways it's an upstream bug, so report/vote for it in upstream.

Loading...