Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#9366 - libtcl8.4.so missing

Attached to Project: Arch Linux
Opened by Cristian C. (ckristi) - Sunday, 27 January 2008, 22:57 GMT
Last edited by Eric Belanger (Snowman) - Tuesday, 29 January 2008, 03:17 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Eric Belanger (Snowman)
Jeff Mickey (codemac)
Architecture All
Severity High
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I think it's enough just one report for this... because you can solve the problem by simply adding a symlink from /usr/lib/libtcl8.5.so to /usr/lib/libtcl8.4.so. Even if two packages are affected (tuxracer and etracer). Sorry for posting in another section earlier (by mistake). No need to bash me around. At least I tried to fix the problems before, but you weren't interested in what I had to say. You just removed my report. Couldn't you just move it?
Whatever...
What I have to say is:
Etracer would compile OK with tcl8.5, tuxracer would not. So the symlink workaround should work fine for both of them, without the need for two recompilations. I built etracer from ABS and works ok, tuxracer compilation died because it didn't find tcl8.4.
If you don't like the style I do my reports, no problem, you can remove my bugreport. BUT AT LEAST SOLVE THE BUG! Thank you.


Additional info:
* tcl 8.5.0-1
* tuxracer 0.61.6
* etracer 0.4-1



Steps to reproduce:
Run tuxracer and etracer. They will end up with the following error:
tuxracer: error while loading shared libraries: libtcl8.4.so: cannot open shared object file: No such file or directory
This task depends upon

Closed by  Eric Belanger (Snowman)
Tuesday, 29 January 2008, 03:17 GMT
Reason for closing:  Fixed
Comment by Corrado Primier (bardo) - Sunday, 27 January 2008, 23:31 GMT
Your report hasn't been removed, it just has been closed but it's still there (just enter the number 9364 in the top right field to access it). Closing bugs is normal. In fact the final objective of a bug reporting systems is... guess what... closing bugs.

Now, about this problem, a symlink isn't a viable solution, it is just a workaround that can't be adopted in an official package. I think this bug will be closed just like the other, because as you were told it is in fact two bugs, one for tuxracer and one for etracer. These two packages are maintained by two different persons: they have to (and will be) solved separately. I hope it's clearer now.
Comment by Cristian C. (ckristi) - Monday, 28 January 2008, 06:01 GMT
Ok, it's fine by me to close the bug. But, the bugs was caused by only one package. Not by two. That's why I think there's no need to report twice. It's the same bug, after all. So, no problem with me if the bug is closed. BUT I want to see the problem solved. Thank you and sorry for being defensive, I just felt bashed and it's not a good feeling when all you want to do is to help.
Comment by Corrado Primier (bardo) - Monday, 28 January 2008, 10:35 GMT
Well, etracer has been fixed today and now works, so only tuxracer remains.
Comment by Xavier (shining) - Monday, 28 January 2008, 13:16 GMT
Your help is appreciated, thanks for reporting bugs.
It's just that you could be easily even more helpful by reporting one bug report per package. That point is important, and bardo already explained it.
But I insist :
"These two packages are maintained by two different persons: they have to (and will be) solved separately."
We didn't mean to bash you or anything like that. I apologize if you felt that way.

And I see now that you were confused by what the problem was. The problem is really in tuxracer and etracer, not in tcl.

But no problem, this bug has been assigned to the two different maintainers of these two packages. So it will probably be good for this time.
(and it is is already half solved anyway)

Loading...