Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#9280 - mythtv and myth* packages should depend on qt3 or be rebuilt for qt4

Attached to Project: Arch Linux
Opened by Aaron Hurt (leprechau) - Monday, 21 January 2008, 03:02 GMT
Last edited by Paul Mattal (paul) - Monday, 04 February 2008, 04:14 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Paul Mattal (paul)
Architecture All
Severity Low
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The mythtv and mythdvd, etc... packages depend on libqt-mt.so.3 which is part of the qt3 arch package. It appears that in the time since the mythtv packages were last built that qt4 has been renamed to plain qt and the old qt which was qt 3.x to qt3. I would think a simple change to the dependencies or a rebuild against qt4 should fix the problem with the myth packages.

Steps to reproduce:

pacman -S mythtv

pacman will pull in qt which is really qt 4.x as a dependency and mythtv will not function.
This task depends upon

Closed by  Paul Mattal (paul)
Monday, 04 February 2008, 04:14 GMT
Reason for closing:  Fixed
Comment by Paul Mattal (paul) - Thursday, 24 January 2008, 03:18 GMT
This should be resolved in 20071129-2 in testing. I actually had to force the build to make sure qt WASN'T there in addition to changing the depend to qt3.
Comment by Aaron Hurt (leprechau) - Thursday, 24 January 2008, 18:37 GMT
Thank you Paul I just re-synced and updated all looks good and got a newer myth version out of it too...thank you

Loading...