Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#9254 - Many wxWidgets programs crash with "BadAlloc (insufficient resources for operation)"

Attached to Project: Arch Linux
Opened by Paolo (palmaway) - Friday, 18 January 2008, 15:47 GMT
Last edited by Jan de Groot (JGC) - Sunday, 23 March 2008, 21:38 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Alexander Baldeck (kth5)
Architecture All
Severity High
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 12
Private No

Details

Description:wxWidgets
Many programs are crashing after today's update of xorg-server and libxfont (2008/18/01). They crash right after starting, giving an error message that reports an X Window System error received by the application.

Here's Filezilla log:

[paolo@liberty ~]$ filezilla
The program 'filezilla' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
(Details: serial 306 error_code 11 request_code 148 minor_code 5)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)

aMule is affected too:
[paolo@liberty ~]$ amule
Initialising aMule
Checking if there is an instance already running...
No other instances are running.
The program 'amule' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
(Details: serial 611 error_code 11 request_code 148 minor_code 5)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)

Other apps are reported to show the same behavior, like vlc:
http://bbs.archlinux.org/viewtopic.php?id=42502

The problem has arised on many other Linux distros.
See for example this Ubuntu bug report:
https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/184003

Additional info:
* package version(s): xorg-server-1.4.0.90-4
* additional packages that could be the cause: libxfont-1.3.1-2

Steps to reproduce:
Update xorg-server to 1.4.0.90-4, libxfont to 1.3.1-2 and run any of the mentioned applications (probably any wxWidgets program will do).
This task depends upon

Closed by  Jan de Groot (JGC)
Sunday, 23 March 2008, 21:38 GMT
Reason for closing:  Fixed
Additional comments about closing:  Should be fixed with 1.4.0.90-8 and 1.4.0.90-9.
Comment by Paolo (palmaway) - Friday, 18 January 2008, 15:53 GMT
Ubuntu seems to have downgraded on their official repository, see:
https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/183969
Comment by Christoper Daley (luciferin) - Friday, 18 January 2008, 16:52 GMT
Same problem as reported on the forum.
http://bbs.archlinux.org/viewtopic.php?pid=319036
Comment by kenen (kenen) - Friday, 18 January 2008, 19:38 GMT
Downgrade to libxfont-1.3.1-1 does NOT fix the problem.
Comment by kenen (kenen) - Friday, 18 January 2008, 21:51 GMT
No problems with 1.4.0.90-3 and libxfont-1.3.1-2.

If you have cleaned your cache, here are some links to get the xorg-server-1.4.0.90-3 package (i686 and x86_64).

Official (Outdated) Mirror:

i686: ftp://ftp.tu-chemnitz.de/pub/linux/sunsite.unc-mirror/distributions/archlinux/extra/os/i686/xorg-server-1.4.0.90-3-i686.pkg.tar.gz
x86_64: ftp://ftp.tu-chemnitz.de/pub/linux/sunsite.unc-mirror/distributions/archlinux/extra/os/x86_64/xorg-server-1.4.0.90-3-x86_64.pkg.tar.gz

Inofficial "Emergency" (in case of an update of ftp.tu-chemnitz.de) Mirror:
i686: http://files.kenen.de/xorg-server-1.4.0.90-3-i686.pkg.tar.gz
x86_64: http://files.kenen.de/xorg-server-1.4.0.90-3-x86_64.pkg.tar.gz
Comment by Zygfryd Homonto (zyghom) - Friday, 18 January 2008, 23:50 GMT
I'm afraid this emergency might kill more - in my case it killed complete X - starting with nvidia
only reinstallation of half of X helped (means still on 1.4.0.90-4) but vlc still not working
Comment by Jan de Groot (JGC) - Saturday, 19 January 2008, 00:54 GMT
http://gitweb.freedesktop.org/?p=xorg/xserver.git;a=commitdiff_plain;h=e9fa7c1c88a8130a48f772c92b186b8b777986b5;hp=23f3f0e27dc90b7b3a375f2a5dd094e6f53552b5

That URL is the fix for this bug. Another workaround is to put this in xorg.conf:

Section "Extensions"
Option "MIT-SHM" "no"
EndSection

This will disable the offended feature, though fixing the offended feature is better for performance than disabling it.
Comment by Øyvind Heggstad (Mr.Elendig) - Saturday, 19 January 2008, 03:25 GMT
Seems like the bug kills apps based on the SWT windgets too. Atleast it breakes azureus, with an error that points at swt.
Comment by Jan de Groot (JGC) - Saturday, 19 January 2008, 12:27 GMT
It kills all applications that use 8bit SHM operations and only on 32bit architectures.
Comment by Mika Hynnä (ighea) - Saturday, 19 January 2008, 15:31 GMT
I got this fixed just by reinstalling nvidia-package. Might have been only my case but I had these same BadAllocs and BadMallocs in gentoo too and same fix was effective.
Comment by Mike Dill (Theoden) - Saturday, 19 January 2008, 18:24 GMT
I had exactly this problem azureus. The error message indicated it was a problem with swt - BadAlloc.
I reinstalled swt - no help. I downgraded xorg-server from 1.4.0.90-4 back to 1.4.0.90-3 , and everything works right again. So it seems to be an xorg-server problem apparently.

--Theoden
Comment by Matti Lahtinen (wor) - Sunday, 20 January 2008, 14:29 GMT
Here's a patch against 1.4.0.90-4.
Comment by Jan de Groot (JGC) - Sunday, 20 January 2008, 20:48 GMT
xorg-server 1.4.0.90-5 is in extra now for both architectures and has been patched to fix this regression. Please confirm your bug is fixed.
Comment by Paolo (palmaway) - Sunday, 20 January 2008, 21:33 GMT
I just upgraded to xorg-server-1.4.0.90-5-i686 and the fix worked just fine. I'm now able to run all the previously affected application, including aMule, Filezilla and Azureus. Bug closure requested. Thanks, great work guys.
Comment by lklklk (kknull) - Monday, 28 January 2008, 18:54 GMT
the bug still exists here with xorg-server 1.4.0-5
Comment by Matti Lahtinen (wor) - Monday, 28 January 2008, 19:33 GMT

Loading...