Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#9150 - Handling of accents in package description

Attached to Project: Pacman
Opened by Ben Dibbens (ibendiben) - Thursday, 10 January 2008, 14:11 GMT
Last edited by Dan McGee (toofishes) - Wednesday, 06 February 2008, 02:33 GMT
Task Type Bug Report
Category Output
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version 3.0.6
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Summary and Info:
Some packages have accents in their description, pacman can't handle those and turns them in to non-printable �
------------------------------------------------------------
From the homepage-package-search:
Extra lib libdjvu 3.5.19-1 Library to process DjVu ('déjà vu') documents
Extra office djvulibre 3.5.19-1 Suite to create, manipulate and view DjVu ('déjà vu') documents
------------------------------------------------------------
From pacman -Ss djvu
extra/djvulibre 3.5.19-1
Suite to create, manipulate and view DjVu ('d�j� vu') documents
extra/libdjvu 3.5.19-1
Library to process DjVu ('d�j� vu') documents

Steps to Reproduce:
This task depends upon

Closed by  Dan McGee (toofishes)
Wednesday, 06 February 2008, 02:33 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Packaging issue. Known pakages with wrong encoding have since been fixed.
Comment by Xavier (shining) - Thursday, 10 January 2008, 15:39 GMT
Isn't that problem in the djvu packages, rather than in pacman?
For example, cat /var/lib/pacman/sync/extra/djvulibre-3.5.19-1/desc produce the same result.
The problem is that the description is in ISO-8859 instead of UTF-8.

/var/lib/pacman/sync/extra/djvulibre-3.5.19-1/desc: ISO-8859 text

After converting that file using recode, pacman then displays it correctly :
recode ISO-8859-1..UTF-8 /var/lib/pacman/sync/extra/djvulibre-3.5.19-1/desc
Comment by Ben Dibbens (ibendiben) - Thursday, 10 January 2008, 16:46 GMT
So should the description (or encoding) change?
Comment by Xavier (shining) - Thursday, 10 January 2008, 16:59 GMT
Yes, I think the following PKGBUILD (which contain the description) should be converted to UTF8 :
./extra/lib/libdjvu/PKGBUILD: ISO-8859 text
./extra/office/djvulibre/PKGBUILD: ISO-8859 text
./testing/extra/office/djvulibre/PKGBUILD: ISO-8859 text
Comment by Ben Dibbens (ibendiben) - Thursday, 10 January 2008, 18:12 GMT
So should the description (or encoding) change?
Comment by Ben Dibbens (ibendiben) - Thursday, 10 January 2008, 18:14 GMT
Ohh, that was accidental, the page was left open and I just did a refresh...
I was going to say, that I'll report other faulty descriptions...
Comment by Aaron Griffin (phrakture) - Thursday, 10 January 2008, 18:58 GMT
It might be worthwhile to add a namcap check for utf8 encoding, other than that, this seems to be a packaging issue
Comment by Alexander F. Rødseth (xyproto) - Tuesday, 27 September 2011, 12:18 GMT
I think that PKGBUILDS should be in UTF-8, that it should be added to the packaging guidelines and that namcap should check for it.

Loading...