Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#9080 - kodak m753 not in 54-gphoto.rules in udev

Attached to Project: Arch Linux
Opened by Florian (minus) - Thursday, 03 January 2008, 14:53 GMT
Last edited by Greg (dolby) - Monday, 14 July 2008, 20:06 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jason Chu (jason)
Architecture All
Severity Very Low
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


When trying to connect to my camera using digiKam it doesn't work as normal user. But as root it works. I am in camera, udev and hal group. Problem is solved by adding
ATTRS{idVendor}=="040a", ATTRS{idProduct}=="059f", MODE="0660", GROUP="camera"
to /etc/udev/rules.d/54-gphoto.rules

Additional info:

Steps to reproduce:
This task depends upon

Closed by  Greg (dolby)
Monday, 14 July 2008, 20:06 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in libgphoto2 2.4.2-1
Comment by Roman Kyrylych (Romashka) - Thursday, 10 January 2008, 22:59 GMT
@Florian: I suggest reporting this to upstream as well.
Comment by Greg (dolby) - Saturday, 17 May 2008, 10:52 GMT
Any link to upstream?
Comment by Florian (minus) - Saturday, 17 May 2008, 15:56 GMT
I have forgotten to report it to upstream. I just did. Here is the link:
Comment by Greg (dolby) - Monday, 19 May 2008, 09:56 GMT
"and it is in in libgphoto2 2.4.1, so archlinux likely just hasnt updated
it yet" which is true. Seems its gonna be fixed in new version.