Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#9078 - perl packages with compiled libraries need recompilation with perl 5.10.0

Attached to Project: Arch Linux
Opened by Francois Charette (Firmicus) - Wednesday, 02 January 2008, 10:44 GMT
Last edited by Kevin Piche (kpiche) - Wednesday, 26 March 2008, 02:56 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Kevin Piche (kpiche)
Architecture i686
Severity High
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:

All perl packages that contain compiled libraries need to be recompiled to work with perl 5.10.0, because the new version of perl does not unterstand the symbol Perl_Tstack_sp_ptr

Steps to reproduce:
Try to use a module that relies on such a compiled library, such as for example:
> perl -e "require XML::Parser"
perl: symbol lookup error: /usr/lib/perl5/site_perl/current/i686-linux-thread-multi/auto/XML/Parser/Expat/Expat.so: undefined symbol: Perl_Tstack_sp_ptr

On my machine I was able to identify all packages that require recompilation with
find /usr/lib/perl5/site_perl/ -name '*.so' -exec pacman -Qo '{}' \;

The package given by the output include these (from extra), and many more:
cairo-perl
glade-perl
glib-perl
gtk2-perl
imagemagick
mod_perl
net-snmp
perl-compress-raw-zlib
perl-crypt-ssleay
perl-dbi
perl-event
perl-html-parser
perl-tk
perlxml
subversion
...
This task depends upon

Closed by  Kevin Piche (kpiche)
Wednesday, 26 March 2008, 02:56 GMT
Reason for closing:  Fixed
Additional comments about closing:  Rebuilt rrdtool.
Comment by Pierre-Paul Paquin (peets) - Thursday, 03 January 2008, 05:49 GMT
I noticed rxvt-unicode broke; recompiling solved the issue. There's already a new package in the repos, good job.
Comment by Francois Charette (Firmicus) - Thursday, 03 January 2008, 11:16 GMT
rxvt-unicode is a different case, because it itself embeds the perl interpreter: such packages (vim is another example) must also be recompiled, as mentioned in the post_install blurb of perl 5.10.0.
Comment by Corrado Primier (bardo) - Thursday, 03 January 2008, 15:27 GMT
I also had to recompile a few things to make gmusicbrowser work. The packages from [extra] are:
gnome-perl
gnome-vfs-perl
gnomecanvas-perl
perl-locale-gettext

There's also a few from [community], which I post as a remainder:
perl-gstreamer
perl-gstreamer-interfaces
perl-gtk2-trayicon
perl-net-dbus
perl-xml-twig
Comment by Corrado Primier (bardo) - Thursday, 03 January 2008, 15:47 GMT
I did a little modification to Francois's one-liner, this one just lists the packages:
LANG=C find /usr/lib/perl5/site_perl/ -name '*.so' -exec pacman -Qo '{}' \; | cut -d\ -f5 | sort | uniq

Excluding the ones I already posted, I can add, from [extra]:
frozen-bubble
perl-digest-sha1
perl-libintl-perl
perl-term-readkey
perl-unicode-string
sdl_perl

And from [community]:
perl-fuse
perl-gtk2-mozembed
perl-text-iconv
Comment by Francois Charette (Firmicus) - Thursday, 03 January 2008, 15:51 GMT
There are actually some more. I will actually post the complete list on the aur-general ML, so we can update them as soon as perl 5.10.0 moves from [testing] to [core].
Comment by Kevin Piche (kpiche) - Friday, 04 January 2008, 05:19 GMT
I'm already aware of most of these - thanks for listing the others. I'm going through all the modules in extra and rebuilding them. It just takes time. Completed are: perl-locale-gettext, sdl_perl, and frozen-bubble.
Comment by Jason Chu (jason) - Thursday, 10 January 2008, 19:12 GMT
I'm not sure if you want us to keep listing them or not, but I just found perl-net-dns.
Comment by Kevin Piche (kpiche) - Friday, 11 January 2008, 04:54 GMT
Just finished rebuilding it thanks. I know about all the modules in extra, I installed them all and did a find|grep .so$

I don't know the packages that have perl modules bundled with them like subversion or imagemagick.
Comment by Cagnulein (Cagnulein) - Thursday, 17 January 2008, 15:07 GMT
according to http://bbs.archlinux.org/viewtopic.php?id=42433

from [extra]
perl-text-iconv
Comment by Cagnulein (Cagnulein) - Sunday, 20 January 2008, 01:47 GMT
from [extra]
perl-term-readkey
Comment by Jeroen Habraken (VeXocide) - Monday, 24 March 2008, 15:44 GMT
from [extra]
rrdtool

is also broken:
perl: symbol lookup error: /usr/lib/perl5/site_perl/current/i686-linux-thread-multi/auto/RRDs/RRDs.so: undefined symbol: Perl_Tstack_sp_ptr
Comment by Kevin Piche (kpiche) - Wednesday, 26 March 2008, 02:55 GMT
rrdtool 1.2.27-1 was built for 5.10.0.

Loading...