Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#8948 - kernel26 2.6.23.11-1 : snd-hda-intel stopped working

Attached to Project: Arch Linux
Opened by Xavier (shining) - Sunday, 16 December 2007, 18:58 GMT
Last edited by Tobias Powalowski (tpowa) - Saturday, 22 December 2007, 13:31 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture i686
Severity Low
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 10
Private No

Details

Description:
I just upgraded to the 2.6.23.11-1 kernel in testing, and alsa doesn't work anymore.

I first noticed it in cmus. Then tried mplayer, and here are the errors :
[AO_ALSA] alsa-lib: pcm_hw.c:983:(snd_pcm_hw_open_fd) TSTAMP failed

[AO_ALSA] alsa-lib: pcm_dmix.c:866:(snd_pcm_dmix_open) unable to open slave
[AO_ALSA] Playback open error: Inappropriate ioctl for device
Could not open/initialize audio device -> no sound.
Audio: no sound


Additional info:
* kernel26 2.6.23.11-1 package
* hda intel chipset (snd-hda-intel module)
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Saturday, 22 December 2007, 13:31 GMT
Reason for closing:  Fixed
Additional comments about closing:  2.6.23.12-3
Comment by Pierre Schmitz (Pierre) - Sunday, 16 December 2007, 19:18 GMT
I have seen something similar with a soudblaster live (emu10k1). The same issue with my laptop using Intel ICH-4.

But my sb still plays sounds. Perhaps this is related to hw/sw mixing?
Comment by CiHO (CiHO) - Sunday, 16 December 2007, 19:23 GMT
Something like that with snd_via82xx:

[AO_ALSA] alsa-lib: pcm_hw.c:1099:(snd_pcm_hw_open) open /dev/snd/pcmC0D0p failed: Device or resource busy
[AO_ALSA] Playback open error: Device or resource busy
Could not open/initialize audio device -> no sound.
Audio: no sound

Comment by Xavier (shining) - Sunday, 16 December 2007, 21:14 GMT
Not sure if that helps, but I went there : http://www.alsa-project.org/main/index.php/Download
I tried the last (unofficial snapshot) : ftp://ftp.suse.com/pub/projects/alsa/snapshot/driver/alsa-driver-hg20071215.tar.bz2
It still had the same problem.
I then tried the stable release : ftp://ftp.alsa-project.org/pub/driver/alsa-driver-1.0.15.tar.bz2
And it works perfectly.

I couldn't find anything about this issue on the alsa bugtracker, but maybe my search skills just suck.
Comment by Hussam Al-Tayeb (hussam) - Sunday, 16 December 2007, 21:46 GMT
This broke gstreamer too
Error running pipeline 'ALSA - Advanced Linux Sound Architecture': Resource busy or not available. [gstalsasink.c(622): gst_alsasink_open (): /pipeline1/alsasink4:
Device 'default' is busy]

Also using snd_via82xx driver as CiHO

Comment by Greg Meyer (oggb4mp3) - Sunday, 16 December 2007, 22:46 GMT
All of my sound cards are being reported busy with this kernel.

$ cat /proc/asound/cards
0 [NVidia ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xfbdf0000 irq 17
1 [AV710 ]: ICE1724 - Chaintech AV-710
Chaintech AV-710 at 0xec00, irq 20
2 [CS46xx ]: CS46xx - Sound Fusion CS46xx
Sound Fusion CS46xx at 0xfbfff000/0xfbe00000, irq 21
Comment by Greg Meyer (oggb4mp3) - Sunday, 16 December 2007, 22:55 GMT
I just confirmed that when reverting to 2.6.23.9, the sound devices work.

Looks like the new ALSA snapshot is broken.
Comment by Hussam Al-Tayeb (hussam) - Monday, 17 December 2007, 01:30 GMT
Rebuilding the 2.6.23.11 kernel with the alsa patches used in the 2.6.23.9 package fixes it.
I agree with Greg Meyer. It looks like the new alsa snapshot is broken.
Comment by Aaron Griffin (phrakture) - Monday, 17 December 2007, 05:48 GMT
Tpowa, can we revert the alsa patches to a previous version?
Comment by Vojtěch Gondžala (vogo) - Monday, 17 December 2007, 13:58 GMT
I've the same problem whith snd-hda-intel and emu10k1 too.

I get this error message:
$ aplay something
ALSA lib pcm_dmix.c:866:(snd_pcm_dmix_open) unable to open slave

kernel26-2.6.23.9-1 works fine
Comment by Jan Spakula (bender02) - Monday, 17 December 2007, 17:09 GMT
Same here, no sound with snd-hda-intel (intel 82801H (ICH8 Family) HDA card) with 2.6.23.11, 2.6.23.9 works fine.
Comment by Paweł Paprota (yagood) - Monday, 17 December 2007, 17:12 GMT
OSS works fine, though.
Comment by Roberth Sjonøy (roberth) - Monday, 17 December 2007, 18:17 GMT
I'm also affected by this,

01:08.0 Multimedia audio controller: Creative Labs SB Audigy LS
Comment by Glenn Hope (MrAwesome) - Monday, 17 December 2007, 18:43 GMT
snd-hda-intel here, worked right until I did pacman -Syu this morning.
Comment by Xavier (shining) - Monday, 17 December 2007, 18:52 GMT
Hm ok, I think we have enough confirmations than alsa is broken now :)

A guy on alsa irc channel said hg alsa was indeed broken, and also:
17:54 mranostay_work >> DarkMac: you could apply my patch to hg alsa-lib repo for a quick hack

here is the patch:
http://mailman.alsa-project.org/pipermail/alsa-devel/2007-December/004745.html

But it's probably not a good idea to apply this hack.
The alsa kernel patch should rather be reverted to the previous one. Or even to the stable alsa version.
Does the 2.6.23.11 vanilla kernel contain alsa 1.0.15 ? That version works perfectly here.
But even if it contains an older version, it probably works as well.
Comment by Yan Brodeur (neodreams) - Monday, 17 December 2007, 19:23 GMT
snd-es1938 still working except mixing.

I can't open 2 or more softwares that use sound.

When i revert back to the core kernel everything work fine.
Comment by Alexandre Garcia (alexmgarcia) - Monday, 17 December 2007, 19:57 GMT
Same here. (http://bbs.archlinux.org/viewtopic.php?pid=308394)
Downgraded to 2.6.23.9 and solved.
Comment by Alper Kanat (T-u-N-i-X) - Tuesday, 18 December 2007, 13:24 GMT
I also have the same problem here :(
Comment by Jakub Schmidtke (tanis) - Wednesday, 19 December 2007, 03:53 GMT
Same here.
I have soundcard with Realtek ALC660-VD chipset.
Comment by Tobias Powalowski (tpowa) - Wednesday, 19 December 2007, 10:26 GMT
please try .12 kernel from testing.
Comment by Pierre Schmitz (Pierre) - Wednesday, 19 December 2007, 12:13 GMT
works for me now.
Comment by Alexandre Garcia (alexmgarcia) - Wednesday, 19 December 2007, 15:08 GMT
It is ok now. Using hda-intel.
Thank you :-)
Comment by wild (wildarcher) - Wednesday, 19 December 2007, 19:53 GMT
also problem with 2.6.23.12-1 (soundcard ad1998)
Comment by Jan Spakula (bender02) - Wednesday, 19 December 2007, 22:10 GMT
Works for me with 2.6.23.12-1 (intel 82801H (ICH8 Family) HDA card).
Comment by Vojtěch Gondžala (vogo) - Wednesday, 19 December 2007, 22:15 GMT
The 2.6.23.12-1 works fine, Intel Corporation 82801G (ICH7 Family) HDA Controller.
Comment by Matt Runion (mrunion) - Friday, 21 December 2007, 16:43 GMT
I upgraded to 12-2 and this was not fixed. It was the ONLY thing I upgraded. I went from 9-1 to 21-2 and lost sound. See my posts here: http://bbs.archlinux.org/viewtopic.php?pid=309396#p309396
(mrunion is my user ID). I went back to 9-1 and got sound back.
Comment by Matt Runion (mrunion) - Friday, 21 December 2007, 16:48 GMT
Oh, the 21-2 in the previous post by me is supposed to be 12-2. Kernel 12-2 caused the issue.

And since the kernel is the only thing that made a difference in having sound and not, and I know this as a fact, if you guys need me to look at something on my system, or send a particular file or setting, let me know. I'll do my absolute best to get it to you.

Brief system specs:
HP dv9000 Laptop (dv9650us)
nVidia 7600
2GB RAM
ICH8 (hda-intel) sound (I think it's a realtek card)
Using the latest updates from core/extra/community but NOT using the testing archive.

Thanx guys!
Comment by Tobias Powalowski (tpowa) - Friday, 21 December 2007, 18:12 GMT
we are here in a real dilemma, alsa is always broken especially the snd-hda driver.
The question is which breakage is less, using up to date alsa from development tree ,
then the whole subsystem needs to be used or use kernel inside provided alsa.
The last snapshots were not really good and a lot bugs were opened,
so i decided to step back to kernel alsa.
I cannot help you much on this because this is an upstream issue which is hopefully solved in the future.
Here is the .24rc6 kernel if you wanna give that alsa version a shot:
http://www.archlinux.org/~tpowa/2.6.24/
Comment by Matt Runion (mrunion) - Friday, 21 December 2007, 18:24 GMT
OK, cool. I won't pretend to understand exactly what you are saying, but it sounds like you are saying that alsa and the kernel aren't really on the same page yet I guess. Thanks for the response, though. Would it be worth moving to OSS instead of using alsa? I don't know much about the pros and cons on that.
Comment by Tobias Powalowski (tpowa) - Friday, 21 December 2007, 18:30 GMT
the kernel alsa is always behind the official alsa development version.
using development version contains the risk of breakage.
using old kernel alsa contains the risk of not having the latest hardware support.
Comment by Hussam Al-Tayeb (hussam) - Friday, 21 December 2007, 18:30 GMT
Exactly what version of the alsa driver does kernel 2.6.24 ship with? 1.0.15 or older?
Comment by Tobias Powalowski (tpowa) - Friday, 21 December 2007, 18:32 GMT
a bit greater then 1.0.15
Comment by Matt (v01d) - Friday, 21 December 2007, 18:35 GMT
In my case I upgraded from 9-1 to 12-2 and my problem was that the 'model=acer' parameter I was using for snd-hda-intel (which fixed the problem of the headphones not muting and such) now it doesn't work, which is rather annoying. I have an ALC268 codec, and through dmesg it seems to be complaining about 'unknown model' for this codec (even If I use model=acer).
It seems I have to downgrade... grrr
Comment by Matt Runion (mrunion) - Friday, 21 December 2007, 20:12 GMT
OK, I think I've beat this dead horse long enough. I reinstalled 12-2. I installed and set up OSS and "disabled" ALSA. Well, the good news is that the mute indicator didn't stay muted. Yay! I though it might be licked. But no sound still came out of the speakers. I went back to ALSA. You can load something like Audacity and SEE that the machine thinks sound is playing but no sound actually comes out.

I think this is something deeper than I can figure out. but neither ALSA nor OSS gives sound with the newer kernel. Does anyone think it'll ever come back?
Comment by Tobias Powalowski (tpowa) - Friday, 21 December 2007, 20:51 GMT
tomorrow it comes back in 12-3
Comment by Jan de Groot (JGC) - Friday, 21 December 2007, 22:25 GMT
Ok, this is a mess.

2.6.23 contains Alsa 1.0.14, which is older than the alsa-lib that we ship, and supports less drivers than alsa 1.0.15.
We have some choices here:
- leave alsa like it is in kernel 2.6.23 and hope 2.6.24 will be better
- continue to use snapshots (bad idea)
- upgrade alsa to last stable, which is 1.0.15

I would opt for the last one. This can be done by either removing alsa support and building it out of tree with an alsa release, or patch it using the patch from 2.6.23-mm: ftp://ftp.de.kernel.org/pub/linux/kernel/people/akpm/patches/2.6/2.6.23/2.6.23-mm1/broken-out/git-alsa.patch

If we're switching to snapshots, please consider using the official alsa kernel git repository instead of the alsa-kernel mercurial repository: http://git.kernel.org/?p=linux/kernel/git/perex/alsa.git
Comment by Tobias Powalowski (tpowa) - Saturday, 22 December 2007, 13:18 GMT
jan i addeed the last working snapshot to it.
it's the same state as kernel .24 series

Loading...