Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#8911 - Irssi doesn't start with new perl version

Attached to Project: Arch Linux
Opened by Martin Skytte (marteus) - Wednesday, 12 December 2007, 19:22 GMT
Last edited by Roman Kyrylych (Romashka) - Saturday, 15 December 2007, 13:34 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Kevin Piche (kpiche)
Dan McGee (toofishes)
Architecture All
Severity Medium
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

After upgrading perl to 5.8.8-10 from testing irssi exits immediately without an error message.

Steps to reproduce:

upgrade perl, launch irssi. Won't run

downgrade perl, launch irssi. Runs fine again.

btw the irssi package in ABS does not build.
This task depends upon

Closed by  Roman Kyrylych (Romashka)
Saturday, 15 December 2007, 13:34 GMT
Reason for closing:  Fixed
Additional comments about closing:  in irssi 0.8.12-2
Comment by Scott H (stonecrest) - Thursday, 13 December 2007, 01:05 GMT
I can confirm this.

I also got a weird error using pacman-git when downgrading perl:

$ pacman -U /var/cache/pacman/pkg/perl-5.8.8-9-i686.pkg.tar.gz
loading package data... done.
checking dependencies...
(1/1) checking for file conflicts [#########################] 100%
error: cannot remove file 'usr/lib/perl5/site_perl/5.8.8/': Not a directory
(1/1) upgrading perl [#########################] 100%


I'm not sure exactly what that error means (file? directory?), but it is symlink pointing to the /usr/lib/perl5/site_perl/current directory.

Comment by Gary D. Huffman, II (Arch4Ever) - Thursday, 13 December 2007, 06:46 GMT
I can confirm this bug as well.
Comment by Xavier (shining) - Thursday, 13 December 2007, 08:11 GMT
Stonecrest : I believe you can safely ignore that error, it shouldn't break anything. It's just that diverting with symlinks is rather complicated and messy.
I also noticed it recently, and mentioned it on the ML : http://www.archlinux.org/pipermail/pacman-dev/2007-December/010451.html

I'm not sure, but I think it's rather the last perl change that broke something:
http://cvs.archlinux.org/cgi-bin/viewcvs.cgi/base/perl/PKGBUILD.diff?r1=1.52&r2=1.53&cvsroot=Core
Or maybe it just doesn't play nice with an existing system.
Comment by Jan Spakula (bender02) - Thursday, 13 December 2007, 19:11 GMT
Another confirm of this on forums:
http://bbs.archlinux.org/viewtopic.php?pid=307342
The problem is with the symlinks, I believe that they should point to core_perl after upgrade to 5.8.8-10.
Comment by Aaron Griffin (phrakture) - Friday, 14 December 2007, 19:26 GMT
Note: because irssi embeds a perl interpreter and our perl @INC path changed, we need to recompile this to pick it up.

Loading...