Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#8895 - [evms] The initcpio install-hooks should install more modules

Attached to Project: Arch Linux
Opened by Menno Tammens (menno) - Tuesday, 11 December 2007, 14:21 GMT
Last edited by Andrea Scarpino (BaSh) - Thursday, 18 June 2009, 22:25 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Aaron Griffin (phrakture)
Architecture All
Severity Medium
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I have created a RAID1 array on /dev/sda1 & /dev/sdb1 in EVMS
The devices are claimed by /dev/md0 and are not available in EVMS.


Messages during boot:

:: Running Hook [evms]
device-mapper: ioctl: 4.11.0-ioctl (2006-10-12) initialised: dm-devel@redhat.com
Engine: The plug-in SWAPFS in module /usr/lib/evms/2.5.5/swap-1.1.13.so failed to load. The plug-in's setup_evms_plugin() function
failed with error code 38: Function not implemented.
md: bind<dm-0>
md: bind<dm-1>
md: personality for level 1 is not loaded!
md: array md0 already has disks!
md: array md0 already has disks!
md: array md0 already has disks!

/dev/md0 is created, /dev/evms/md0 is not.


Additional info:
* package version(s)
evms-2.5.5-5

* config and/or log files etc.
/etc/mkinitcpio.conf:
HOOKS="base udev evms pata scsi sata keymap filesystems"

/lib/initcpio/install/evms:
MODULES="dm_mod md_mod"

Setup:
sda6 => Compatibility Volume /dev/evms/sda6, and is mounted on /
sda1 & sdb1 => RAID1: md/md0 => EVMS volume: /dev/evms/md0, not mounted

Steps to reproduce:
* Install EVMS
* Created a RAID1 Volume

Fix:
Change modules loaded by evms:
/lib/initcpio/install/evms:
MODULES=" $(checked_modules "drivers/md/*") "

Messages during boot:

:: Running Hook [evms]
device-mapper: ioctl: 4.11.0-ioctl (2006-10-12) initialised: dm-devel@redhat.com
Engine: The plug-in SWAPFS in module /usr/lib/evms/2.5.5/swap-1.1.13.so failed to load. The plug-in's setup_evms_plugin() function
failed with error code 38: Function not implemented.
md: bind<dm-0>
md: bind<dm-1>
md: raid1 personality registered for level 1
raid1: raid set md0 active with 2 out of 2 mirrors

/dev/evms/md0 is created
Only the needed modules (dm_mod, md_mod and raid1) are loaded
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Thursday, 18 June 2009, 22:25 GMT
Reason for closing:  Fixed
Additional comments about closing:  in [testing] due to readline rebuild
Comment by Aaron Griffin (phrakture) - Monday, 08 December 2008, 23:32 GMT
  • Field changed: Status (Assigned → Researching)
Committed to svn trunk, package flagged. Should be rebuilt at some point
Comment by Gavin Bisesi (Daenyth) - Saturday, 21 March 2009, 14:09 GMT
Status?
Comment by Allan McRae (Allan) - Saturday, 21 March 2009, 14:23 GMT
Still sitting in svn truck waiting on an update.

Loading...