Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#8846 - iputils fails to build needs OPEN_MAX patch

Attached to Project: Arch Linux
Opened by Steve Ponsford (sparchy) - Wednesday, 05 December 2007, 23:42 GMT
Last edited by Tobias Powalowski (tpowa) - Saturday, 08 December 2007, 11:40 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity Low
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: iputils PKGBUILD in core/base fails to build because the OPEN_MAX define has been removed from kernel headers >= 2.6.23


Additional info:
* package version(s)
* config and/or log files etc.

kernel: kernel26 2.6.23.8-1
iputils 20070202-3

Steps to reproduce:
makepkg -c
...
rdisc.c: In function 'do_fork':
rdisc.c:250: error: 'OPEN_MAX' undeclared (first use in this function)
rdisc.c:250: error: (Each undeclared identifier is reported only once
rdisc.c:250: error: for each function it appears in.)
make: *** [rdisc] Error 1
==> ERROR: Build Failed. Aborting...

rdisc.c needs a patch for the removed OPEN_MAX constant. Lunar linux has a patch that seems to work for it. I successfully applied the patch against archs iputils and I didn't get the build failure. No extensive testing of the in.rdiscd daemon was performed, I just executed in test mode to see if it would run.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Saturday, 08 December 2007, 11:40 GMT
Reason for closing:  Fixed
Additional comments about closing:  in new iputils
Comment by Tobias Powalowski (tpowa) - Friday, 07 December 2007, 20:51 GMT
it would make life easier if you would post it here
Comment by Steve Ponsford (sparchy) - Friday, 07 December 2007, 22:41 GMT
Sorry, lost attached file when I changed the bug description, here is the updated PKGBUILD

Loading...