Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#8821 - Pacman downgrade package (feature request)

Attached to Project: Pacman
Opened by Alberto Gonzalez (Luis) - Sunday, 02 December 2007, 20:49 GMT
Last edited by Dan McGee (toofishes) - Wednesday, 05 December 2007, 14:07 GMT
Task Type Feature Request
Category General
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version 3.0.6
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

I filed a feature request for pacman to autoclean the cache so you don't need to pacman -Scc from time to time, losing all packages in the cache. This request depends on that one before it could be implemented.

The autoclean request is here (for reference):
http://bugs.archlinux.org/task/8819

So we assume now that we almost always have the previous version of a package in the cache, flagged as <packagename>-old. Now pacman would need a new switch that would downgrade the package. For example, pacman -D <packagename>, would:

- Search the cache for <packagename>-old
- If found, it would downgrade to that version, remove the higher version from the cache, and remove the -old flag from the downgraded version.
- If not found, it would display a message saying "Sorry, but the previous version of <packagename> could not be found in the cache".

Thanks!
This task depends upon

Closed by  Dan McGee (toofishes)
Wednesday, 05 December 2007, 14:07 GMT
Reason for closing:  Duplicate
Additional comments about closing:  dupe of 6420
Comment by Dan McGee (toofishes) - Wednesday, 05 December 2007, 14:06 GMT
  • Field changed: Attached to Project (Arch Linux → Pacman)
  • Field changed: Status (Unconfirmed → New)
First, please file your bug reports under the correct project.

Second, adding a new switch to pacman is not something we do lightly. And since downgrading can already be done with -U <oldpackagefile>, I have a hard time elevating this feature to anything more than a request that we might consider if a patch was attached.

Third, please search Flyspray first:  bug 6420 . Please repost your comments there as I will close this bug.

Loading...