Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#8806 - xfig cant use ps fonts

Attached to Project: Arch Linux
Opened by Travis (tesjo) - Friday, 30 November 2007, 21:34 GMT
Last edited by Eric Belanger (Snowman) - Monday, 29 December 2008, 22:31 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Eric Belanger (Snowman)
Architecture i686
Severity Low
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
xfig 3.2.5-1 is unable to change text font to anything but default. No error of missing font just wont change. Downgraded to xfig 3.2.4-3 and fonts are again working.


Additional info:
http://bbs.archlinux.org/viewtopic.php?id=40455
Generic build from 3.2.5 source had same issue

Steps to reproduce:
This task depends upon

Closed by  Eric Belanger (Snowman)
Monday, 29 December 2008, 22:31 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in xfig-3.2.5-1 that was moved out of testing.
Comment by Damir Perisa (damir.perisa) - Sunday, 02 December 2007, 00:01 GMT
i have no clue why. i can reproduce it and it is a bad thing - although i never used other fonts than default in my figures since labeling happens outside for me, i see this as a major break.

will investigate if i find time... alternative: should we downgrade to 3.2.4 till a solution is found?
Comment by Travis (tesjo) - Saturday, 15 December 2007, 16:33 GMT
I have found that I can specify any font when starting xfig with 'xfig -startpsFont <font>' (ie symbol, courier) and use that font but once I try to change it in the interface it goes to default.
Comment by marco (domanov) - Tuesday, 19 February 2008, 18:29 GMT
> alternative: should we downgrade to 3.2.4 till a solution is found?

IMHO we should.
Comment by Damir Perisa (damir.perisa) - Tuesday, 19 February 2008, 20:59 GMT
it looks very much the only solution. the 3.2.5 is such a pain!!!! - i will downgrade and decide that we skip it completely. next arch release will be 3.2.6, agree?
Comment by marco (domanov) - Tuesday, 19 February 2008, 21:17 GMT
I perfectly agree.
I'm looking at ipe, I've made an uptodate PKGBUILD, it runs smoothly. Interesting, I didn't know about it. Or what do you use to includ latex tags in your images?
Comment by Damir Perisa (damir.perisa) - Tuesday, 19 February 2008, 21:42 GMT
ok, i'll downgrade it.

ipe? i don't know it - is it worth? more useable than xfig? (more up to date? using some cooler gui widgets? *smile*) if it is the new replacement, we should add it to extra.
Comment by marco (domanov) - Tuesday, 19 February 2008, 22:01 GMT
Ipe is not a real replacement to xfig, but it has some cool features (and definitely better widgets). I started just few moments ago playing with it (and got already a crash). It is worth looking... http://tclab.kaist.ac.kr/ipe/

Looking forward the downgrade of xfig though...
Comment by Damir Perisa (damir.perisa) - Tuesday, 19 February 2008, 22:18 GMT
===> Commited with "upgpkg: xfig 3.2.4-10
xfig downgrade - as decided in bug http://bugs.archlinux.org/task/8806"; message

rebuild in i686 will follow later
Comment by Damir Perisa (damir.perisa) - Tuesday, 19 February 2008, 22:39 GMT
hmm, ipe looks promising, but is quite unstable, i just tried it and it crashed multiple times... maybe it will mature.

downgraded the xfig in x86_64, i686 will follow later
Comment by Travis (tesjo) - Tuesday, 19 February 2008, 22:40 GMT
I agree I have been using 3.2.4 with pacman ignoring 3.2.5 anyway. I did rebuild 3.2.5 today and for some reason it is a little better you can choose fonts but if you dont have the exact right fontsize it will say font is missing. As far as 3.2.6 there is a note on the xfig 3.2.5 download page that this is expected to be final version.
Comment by Cyriac BENOIT (cycyx) - Thursday, 13 March 2008, 20:42 GMT
Just a quick comment: xfig depends on xaw3d, but is not linked against libXaw3d.so...
This small patch (call to sed) fix this:
--- PKGBUILD.org 2008-03-13 21:38:52.000000000 +0100
+++ PKGBUILD 2008-03-13 21:40:07.000000000 +0100
@@ -35,6 +35,7 @@
# =3.2.4
patch -Np1 -i ../xfig-gcc4.patch

+ sed -e 's/^XCOMM #define XAW3D/#define XAW3D/' -i Imakefile
# make makefile with imake
xmkmf || return 1



Is xdraft (http://xdraft.sourceforge.net/) a possible alternative to xfig?
Comment by Glyn Adgie (glyn) - Thursday, 27 March 2008, 12:02 GMT
I have been using a patched version of xfig 3.2.4 for some time. The patch replaces the standard Postscript font names with the names of the equivalent URW fonts that come with Ghostscript. This worked better for me than using fonts.alias or whatever.

Anyway, it appears that this patch works with xfig 3.2.5. I have no problem with fonts.

I am a bit busy at present, but I will post a more informative comment when I get time.
Comment by Eric Belanger (Snowman) - Sunday, 07 December 2008, 23:08 GMT
Glyn: Could you attached the patch you are using?

I intend to update xfig to 3.2.5 once I fix this font problem. There is a comment in the PKGBUILD about 3.2.5 having other problems as well. Does anyone know what they might be?
Comment by Eric Belanger (Snowman) - Tuesday, 09 December 2008, 08:59 GMT
FYI: I believe I have fixed this fonts issue and other issues with a bunch of patches from Fedora. They replace the missing fonts with their URW equivalent. It's probably the same patch Glyn refered above. It could take some time before the package is updated because it needs the newest xaw3d to build and that will necessitate a rebuild of everything that depends on xaw3d.
Comment by Eric Belanger (Snowman) - Tuesday, 16 December 2008, 09:58 GMT
The font problem should be fixed in the xfig 3.2.5-1 in testing repo. It is built against xaw3d 1.5E-1 in testing so you'll need to also update your xaw3d and all your packages that depends on it by their versions in testing.

Loading...